summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-11-20 21:25:46 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-20 21:27:15 +0100
commit1713780be34c291036483fc06dd67a1ed7c4ac39 (patch)
treed31d2d0259710623642a1e85b61474fb971cea62 /media-libs/adplug
parentmedia-libs/babl: 0.1.38 (bug 638202) (diff)
downloadgentoo-1713780be34c291036483fc06dd67a1ed7c4ac39.tar.gz
gentoo-1713780be34c291036483fc06dd67a1ed7c4ac39.tar.bz2
gentoo-1713780be34c291036483fc06dd67a1ed7c4ac39.zip
media-libs/adplug: Version bump to 2.3
Bug: https://bugs.gentoo.org/509660 Bug: https://bugs.gentoo.org/580992 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'media-libs/adplug')
-rw-r--r--media-libs/adplug/Manifest1
-rw-r--r--media-libs/adplug/adplug-2.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/adplug/Manifest b/media-libs/adplug/Manifest
index 4c15b5cb9a84..67a99aec465c 100644
--- a/media-libs/adplug/Manifest
+++ b/media-libs/adplug/Manifest
@@ -1 +1,2 @@
DIST adplug-2.2.1.tar.bz2 810257 SHA256 f95a015268a0dfe9ff5782f3ea7b2a69e09b8d36ccd19ebf4d979d767b6e53ef SHA512 e9b434ad58114a6677907e8f7007a325fa908f9228fbe283d72d1e2394fa27850b929309e038c84ae94f64f8db003b871775502ee8b231219caa51f6ba5d787f WHIRLPOOL 3f337b914f1779f9702014108d4cb4dc816830d1cadc0623751d979bd81213286d431225aa7d28a7aeb35fb32bc614cf581915b6e27357f3f6dc51f30ae58d19
+DIST adplug-2.3.tar.bz2 1462858 SHA256 f64a37f6243836bd0c9c1b7c3a563e47f4b15676d30c074e88b75b2415bfdf6a SHA512 591192032772fbedfec67924693fce3fc490e5bccb1898eea8d38b6d10f066373ebdc4868751041dd21461b5112b349f0be7ff047d7ccaa896fe4ece88ebab74 WHIRLPOOL 073898dab4bdf17a82cd0f4fd31e50381369cc7287da5aafc04932619aaaba726c0bae55aab5f0607b100a7b64b7ebfabfc35b990d261b55600da704fc94761e
diff --git a/media-libs/adplug/adplug-2.3.ebuild b/media-libs/adplug/adplug-2.3.ebuild
new file mode 100644
index 000000000000..12fcc15d3f9c
--- /dev/null
+++ b/media-libs/adplug/adplug-2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit out-of-source
+
+DESCRIPTION="A free, cross-platform, hardware independent AdLib sound player library"
+HOMEPAGE="http://adplug.sourceforge.net"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/adplug/adplug.git"
+else
+ SRC_URI="https://github.com/adplug/${PN}/releases/download/${P}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="debug static-libs"
+
+RDEPEND=">=dev-cpp/libbinio-1.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+my_src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+}
+
+my_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}