summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-11-20 10:33:41 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-11-20 10:37:06 +0100
commitad4d69ab8842913a7f55f62ef965b300ea336dc7 (patch)
tree2d22fed5a8ad581d3fc47d3bb4d94c92277ff367 /media-libs/alsa-lib
parenteclass/tests/git-r3_GIT_DIR.sh: stub out git calls (diff)
downloadgentoo-ad4d69ab8842913a7f55f62ef965b300ea336dc7.tar.gz
gentoo-ad4d69ab8842913a7f55f62ef965b300ea336dc7.tar.bz2
gentoo-ad4d69ab8842913a7f55f62ef965b300ea336dc7.zip
media-libs/alsa-lib: Bump to version 1.2.1.1
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/Manifest1
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.2.1.1.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/Manifest b/media-libs/alsa-lib/Manifest
index 4a73525a476b..096c6bf85c7a 100644
--- a/media-libs/alsa-lib/Manifest
+++ b/media-libs/alsa-lib/Manifest
@@ -1,4 +1,5 @@
DIST alsa-lib-1.1.2.tar.bz2 947423 BLAKE2B 09cd6a625d8f681c5515fd925191fb5468158ed77cc3878c076f4344e4d8f7b15e9872d3d6635710049ca14199851f2343246e94810fe2a0bb0d1e02915c941e SHA512 a6c6675b1fd86955ef5072b9e6090795fc6b0b16f32481bece049e5f100e689be48b6416ff7cf36abfc67e0b94f420e08c15ff13a9701987d6bb69a8fa567e8a
DIST alsa-lib-1.1.8.tar.bz2 1002562 BLAKE2B a531ab501943924d007f7ae0e4489deea805ccbc8f2f02d3ee392aa2dbe54ffe31f58ee1744308f851a68f693c83125088708e901d0d83e4a7a5f644ef448aa3 SHA512 50ae107c6efe8200b4c41e0463e099d16e149332f1d3a22c3e81d3e7d980b7f93f3610fc9711ef62067caeb1054e7ea612ba3903bf8a91ebeffa48687cf80eed
DIST alsa-lib-1.1.9.tar.bz2 1058187 BLAKE2B 60454be162a0f36334602586762f8ce657d2883636bcb65ae91dedce62297bd40f3dbdc6213ef773542708b367f8796e143b1fc987c40de6d5d5a69a648f6b18 SHA512 402e39cca82d17555e3e52ef06b8ed9dcf58531da393809a7b5cf18658299fa90ee8a60bfc5213482d7a02b13140c441f1333b144556f44ab4adb786a2fb3c49
+DIST alsa-lib-1.2.1.1.tar.bz2 1002960 BLAKE2B 6df2145e0fdd42b86759a6250f6fa3d18075d1bbff1c5ec0b4b6130f934ab369e5cc0edd9a53c3b6298dce0d374a9888c5fc63ae0d42b3fd0ef5ca97eff00369 SHA512 8a0b6f1ecc58d60991b4509e791b1581eebae57cd754b0b4829e66b1cfee81d588b04f42a17f598f06310b9658d9f46fd748cca516cc48b6f2989389c22c42e9
DIST alsa-lib-1.2.1.tar.bz2 1003711 BLAKE2B 6aa34238a07c9da2c1fe86e51111018541a647779e0ab4a5ecbfc4a8dcfdc168d5d921ec1c5ae4822227a31ea317cccc41a5c23f19d0e92a6302bba81bfa1423 SHA512 a5bd60ed0cfca3911db534364554412c479d2cb6ded6c8e7011d2510797a6cbd10613d6e1d42cb589afec8e7408c8fd5465360ddd14df8701af7dc414961c19e
diff --git a/media-libs/alsa-lib/alsa-lib-1.2.1.1.ebuild b/media-libs/alsa-lib/alsa-lib-1.2.1.1.ebuild
new file mode 100644
index 000000000000..ba7e99bdece2
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.2.1.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit autotools multilib multilib-minimal python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="https://alsa-project.org/"
+SRC_URI="https://www.alsa-project.org/files/pub/lib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alisp debug doc elibc_uclibc python +thread-safety"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.6-missing_files.patch" #652422
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+ # https://bugs.gentoo.org/509886
+ if use elibc_uclibc ; then
+ sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die
+ fi
+ # https://bugs.gentoo.org/545950
+ sed -i -e '5s:^$:\nAM_CPPFLAGS = -I$(top_srcdir)/include:' test/lsb/Makefile.am || die
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-maintainer-mode
+ --disable-resmgr
+ --enable-aload
+ --enable-rawmidi
+ --enable-seq
+ --enable-shared
+ # enable Python only on final ABI
+ $(multilib_native_use_enable python)
+ $(use_enable alisp)
+ $(use_enable thread-safety)
+ $(use_with debug)
+ $(usex elibc_uclibc --without-versioned '')
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ emake doc
+ grep -FZrl "${S}" doc/doxygen/html | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use doc; then
+ docinto html
+ dodoc -r doc/doxygen/html/.
+ fi
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f \( -name '*.a' -o -name '*.la' \) -delete || die
+ dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}