summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-10-16 15:58:41 +0200
committerDavid Seifert <soap@gentoo.org>2021-10-16 15:58:41 +0200
commitd72ae6aba2dd32706bbe05b22ec18f7b8c96c505 (patch)
tree7576f587b73fc4ce8fd49296dd2409bb38323da6 /media-libs/cal3d/cal3d-0.11.0-r1.ebuild
parentmedia-gfx/sfftobmp: port to EAPI 8 (diff)
downloadgentoo-d72ae6aba2dd32706bbe05b22ec18f7b8c96c505.tar.gz
gentoo-d72ae6aba2dd32706bbe05b22ec18f7b8c96c505.tar.bz2
gentoo-d72ae6aba2dd32706bbe05b22ec18f7b8c96c505.zip
media-libs/cal3d: port to EAPI 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs/cal3d/cal3d-0.11.0-r1.ebuild')
-rw-r--r--media-libs/cal3d/cal3d-0.11.0-r1.ebuild45
1 files changed, 21 insertions, 24 deletions
diff --git a/media-libs/cal3d/cal3d-0.11.0-r1.ebuild b/media-libs/cal3d/cal3d-0.11.0-r1.ebuild
index 4ed4f9c971d4..14ba7aa6fe82 100644
--- a/media-libs/cal3d/cal3d-0.11.0-r1.ebuild
+++ b/media-libs/cal3d/cal3d-0.11.0-r1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit epatch autotools
+EAPI=8
+
+inherit autotools
DESCRIPTION="Cal3D is a skeletal based character animation library"
-HOMEPAGE="http://home.gna.org/cal3d"
+HOMEPAGE="https://mp3butcher.github.io/Cal3D/"
SRC_URI="http://download.gna.org/cal3d/sources/${P}.tar.gz"
LICENSE="LGPL-2.1"
@@ -13,23 +14,22 @@ SLOT="0"
KEYWORDS="amd64 ~ia64 ppc x86"
IUSE="16bit-indices debug doc"
-DEPEND="doc? (
+BDEPEND="
+ doc? (
app-doc/doxygen
app-text/docbook-sgml-utils
)"
-RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-tests.patch
+ "${FILESDIR}"/${P}-verbose.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+ "${FILESDIR}"/${P}-docbook2html.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-tests.patch \
- "${FILESDIR}"/${P}-verbose.patch \
- "${FILESDIR}"/${P}-gcc6.patch
- sed -i \
- -e "s:db2html:docbook2html:g" \
- configure.in \
- docs/Makefile.am \
- || die "sed for doc failed"
+ default
eautoreconf
}
@@ -41,17 +41,14 @@ src_configure() {
src_compile() {
emake
+
if use doc; then
- cd docs
+ cd docs || die
emake doc-api
emake doc-guide
- mkdir -p html/{guide,api}
- mv *.{html,gif} html/guide/
- mv api/html/* html/api/
+ mkdir -p html/{guide,api} || die
+ mv *.{html,gif} html/guide/ || die
+ mv api/html/* html/api/ || die
+ HTML_DOCS=( docs/html/api docs/html/guide )
fi
}
-
-src_install() {
- default
- use doc && dohtml -r docs/html/api docs/html/guide
-}