summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/esdl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/esdl')
-rw-r--r--media-libs/esdl/Manifest2
-rw-r--r--media-libs/esdl/esdl-1.0.1.ebuild42
-rw-r--r--media-libs/esdl/esdl-1.2.ebuild42
-rw-r--r--media-libs/esdl/metadata.xml22
4 files changed, 108 insertions, 0 deletions
diff --git a/media-libs/esdl/Manifest b/media-libs/esdl/Manifest
new file mode 100644
index 000000000000..457cc7931a04
--- /dev/null
+++ b/media-libs/esdl/Manifest
@@ -0,0 +1,2 @@
+DIST esdl-1.0.1.src.tar.gz 428917 SHA256 16fcf29656e6a54c9e10d0a73faa3e5b305c6aab3ab691cad2206c427265877d SHA512 dedc3a4b995e1cdeccd8b389f9de4f8dcb4aa780e8e0ed01730972c94bae8a4897edf2183f24a15df19c0e1ae7bda5481bdbdc55f4e3de0da3efef13291f33ac WHIRLPOOL 1cd0273e132f2cec34d526363a6e44227f6fa1b40fea9838562f3ace3d25909d09b883931e41757a708698c90d9504cd08834882ca49d4210c7436b062ba2efb
+DIST esdl-1.2.src.tar.gz 270309 SHA256 492898262a283a5d0256b287f49fa6462febf4f026d95274ce3bc6263ce4767d SHA512 74fa747f03deb38aee993ffbb1633120517a1aa43ef339d269482e41e91b925507bb60f0c37a082c4fb5b9938f8e7b7a6e9de9541b061be19446ee61a14a17d6 WHIRLPOOL 0cf9599434f9e6052a7bcdbae46e601dd24b99cb549984c8646bbe93cbd1171e0f4680ef400e9c21c11bbb6dc999242b3ac3fcf383d9023aed64469b7d75d76f
diff --git a/media-libs/esdl/esdl-1.0.1.ebuild b/media-libs/esdl/esdl-1.0.1.ebuild
new file mode 100644
index 000000000000..b6cce217d529
--- /dev/null
+++ b/media-libs/esdl/esdl-1.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit fixheadtails multilib eutils
+
+DESCRIPTION="Erlang bindings for the SDL library"
+HOMEPAGE="http://esdl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/esdl/${P}.src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 x86"
+IUSE="image truetype"
+
+RDEPEND=">=dev-lang/erlang-13
+ >=media-libs/libsdl-1.2.5[opengl]
+ image? ( media-libs/sdl-image )
+ truetype? ( media-libs/sdl-ttf )
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i "/CFLAGS.*=/s:-g -O2 -funroll-loops -Wall -ffast-math:${CFLAGS}:" c_src/Makefile
+ ht_fix_file Makefile c_src/Makefile
+ if use image ; then
+ sed -i "/ENABLE_SDL_IMAGE = /s:no:yes:" Makefile
+ fi
+ if use truetype ; then
+ sed -i "/ENABLE_SDL_TTF = /s:no:yes:" Makefile
+ fi
+}
+
+src_install() {
+ addpredict /usr/$(get_libdir)/erlang/lib
+ ERLANG_DIR="/usr/$(get_libdir)/erlang/lib"
+ ESDL_DIR="${ERLANG_DIR}/${P}"
+ dodir ${ESDL_DIR}
+ make install INSTALLDIR="${D}"/${ESDL_DIR} || die "make install"
+}
diff --git a/media-libs/esdl/esdl-1.2.ebuild b/media-libs/esdl/esdl-1.2.ebuild
new file mode 100644
index 000000000000..47be3aa9dbc3
--- /dev/null
+++ b/media-libs/esdl/esdl-1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit fixheadtails multilib eutils
+
+DESCRIPTION="Erlang bindings for the SDL library"
+HOMEPAGE="http://esdl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/esdl/${P}.src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="image truetype"
+
+RDEPEND=">=dev-lang/erlang-14
+ media-libs/libsdl[opengl]
+ image? ( media-libs/sdl-image )
+ truetype? ( media-libs/sdl-ttf )
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i "/CFLAGS.*=/s:-g -O2 -funroll-loops -Wall -ffast-math:${CFLAGS}:" c_src/Makefile
+ ht_fix_file Makefile c_src/Makefile
+ if use image ; then
+ sed -i "/ENABLE_SDL_IMAGE = /s:no:yes:" Makefile
+ fi
+ if use truetype ; then
+ sed -i "/ENABLE_SDL_TTF = /s:no:yes:" Makefile
+ fi
+}
+
+src_install() {
+ addpredict /usr/$(get_libdir)/erlang/lib
+ ERLANG_DIR="/usr/$(get_libdir)/erlang/lib"
+ ESDL_DIR="${ERLANG_DIR}/${P}"
+ dodir ${ESDL_DIR}
+ make install INSTALLDIR="${D}"/${ESDL_DIR} || die "make install"
+}
diff --git a/media-libs/esdl/metadata.xml b/media-libs/esdl/metadata.xml
new file mode 100644
index 000000000000..969ea43fe180
--- /dev/null
+++ b/media-libs/esdl/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <maintainer>
+ <email>george@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ESDL - What is that?
+
+It is library that gives you access to SDL and Opengl
+functionality in your erlang program.
+SDL handles 2d graphics, user events and audio while
+Opengl handles 3d graphics. More information.
+</longdescription>
+ <use>
+ <flag name="image">Enable image support</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">esdl</remote-id>
+ </upstream>
+</pkgmetadata>