summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-30 21:22:22 +0000
committerSam James <sam@gentoo.org>2021-01-30 21:22:22 +0000
commit51a34463a1a3d69cec0e68c9ae4078d4b35a5a34 (patch)
tree19cb024bdaa984c577363c7589644bf33ade034d /media-libs/gd
parentmail-client/thunderbird: Stabilize 78.7.0 x86, #767394 (diff)
downloadgentoo-51a34463a1a3d69cec0e68c9ae4078d4b35a5a34.tar.gz
gentoo-51a34463a1a3d69cec0e68c9ae4078d4b35a5a34.tar.bz2
gentoo-51a34463a1a3d69cec0e68c9ae4078d4b35a5a34.zip
media-libs/gd: bump to 2.3.1
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/gd')
-rw-r--r--media-libs/gd/Manifest1
-rw-r--r--media-libs/gd/gd-2.3.1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/media-libs/gd/Manifest b/media-libs/gd/Manifest
index b3942941ec34..7c6d5873b36f 100644
--- a/media-libs/gd/Manifest
+++ b/media-libs/gd/Manifest
@@ -1 +1,2 @@
DIST libgd-2.3.0.tar.xz 2539188 BLAKE2B a90f48be959d1bb6774ec44960e191b8be134ff3e74401eba4cbf9b165c72665f3dffe3beaaf92fa6069e0ef79533be5d57a5946a1839f55446072fa322ed808 SHA512 5b201d22560e147a3d5471010b898ad0268c3a2453b870d1267b6ba92e540cf9f75099336c1ab08217e41827ac86fe04525726bf29ad117e5dcbaef9a8d0622a
+DIST libgd-2.3.1.tar.xz 2632076 BLAKE2B 22457c4a2fc493872ccbc8a2c45283e785ab200ca671c48f00f3f22a037fac3b97afb35534f5ec7288714a16dfaa59ed53acbbd39c3e7f89f16cdec72ef1bed1 SHA512 0b96406a1d62129d7d63f78fc4558062c223a3bfbf9719be86362fd922b72b5dac294524dd1b0a996a4a7a709ee9d2dfc790ee32564add70adad41d044a0ed80
diff --git a/media-libs/gd/gd-2.3.1.ebuild b/media-libs/gd/gd-2.3.1.ebuild
new file mode 100644
index 000000000000..698406d51559
--- /dev/null
+++ b/media-libs/gd/gd-2.3.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib-minimal
+
+DESCRIPTION="Graphics library for fast image creation"
+HOMEPAGE="https://libgd.org/ https://www.boutell.com/gd/"
+SRC_URI="https://github.com/libgd/libgd/releases/download/${P}/lib${P}.tar.xz"
+S="${WORKDIR}/lib${P}"
+
+LICENSE="gd IJG HPND BSD"
+SLOT="2/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_sse fontconfig +jpeg +png static-libs test tiff truetype webp xpm zlib"
+RESTRICT="!test? ( test )"
+
+# fontconfig has prefixed font paths, details see bug #518970
+REQUIRED_USE="
+ prefix? ( fontconfig )
+ test? ( png )
+"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="fontconfig? ( >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}] )
+ jpeg? ( >=virtual/jpeg-0-r2:0=[${MULTILIB_USEDEP}] )
+ png? ( >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}] )
+ tiff? ( media-libs/tiff:0[${MULTILIB_USEDEP}] )
+ truetype? ( >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}] )
+ webp? ( media-libs/libwebp:=[${MULTILIB_USEDEP}] )
+ xpm? ( >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}] >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3.0-disable-flaky-tests.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # bug 603360, https://github.com/libgd/libgd/blob/fd06f7f83c5e78bf5b7f5397746b4e5ee4366250/docs/README.TESTING#L65
+ if use cpu_flags_x86_sse ; then
+ append-cflags -msse -mfpmath=sse
+ else
+ append-cflags -ffloat-store
+ fi
+
+ # bug 632076, https://github.com/libgd/libgd/issues/278
+ if use arm64 || use ppc64 || use s390 ; then
+ append-cflags -ffp-contract=off
+ fi
+
+ # we aren't actually {en,dis}abling X here ... the configure
+ # script uses it just to add explicit -I/-L paths which we
+ # don't care about on Gentoo systems.
+ local myeconfargs=(
+ --disable-werror
+ --without-x
+ --without-liq
+ $(use_enable static-libs static)
+ $(use_with fontconfig)
+ $(use_with png)
+ $(use_with tiff)
+ $(use_with truetype freetype)
+ $(use_with jpeg)
+ $(use_with webp)
+ $(use_with xpm)
+ $(use_with zlib)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ dodoc README.md
+ find "${ED}" -name '*.la' -delete || die
+}