summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-09 17:44:31 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-09 17:45:17 -0500
commit234f6d457396c138cf76dcc8f3973ece14845410 (patch)
treefff1c8195a9447cd030372950a059c06b75dc9c0 /media-libs/glew/glew-1.10.0-r100.ebuild
parentnet-print/cups-filters: BUmp to version 1.13.0 (diff)
downloadgentoo-234f6d457396c138cf76dcc8f3973ece14845410.tar.gz
gentoo-234f6d457396c138cf76dcc8f3973ece14845410.tar.bz2
gentoo-234f6d457396c138cf76dcc8f3973ece14845410.zip
media-libs/glew: set SYSTEM based on CHOST #595280
This avoids running the local (and old) copy of config.guess, and it fixes cross-compiling selection in a number of cases.
Diffstat (limited to 'media-libs/glew/glew-1.10.0-r100.ebuild')
-rw-r--r--media-libs/glew/glew-1.10.0-r100.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/media-libs/glew/glew-1.10.0-r100.ebuild b/media-libs/glew/glew-1.10.0-r100.ebuild
index 848143537767..94c237d34571 100644
--- a/media-libs/glew/glew-1.10.0-r100.ebuild
+++ b/media-libs/glew/glew-1.10.0-r100.ebuild
@@ -38,20 +38,30 @@ src_prepare() {
multilib_copy_sources
}
+glew_system() {
+ # Set the SYSTEM variable instead of probing. #523444 #595280
+ case ${CHOST} in
+ *linux*) echo "linux" ;;
+ *-freebsd*) echo "freebsd" ;;
+ *-darwin*) echo "darwin" ;;
+ *-solaris*) echo "solaris" ;;
+ mingw*|*-mingw*) echo "mingw" ;;
+ *) die "Unknown system ${CHOST}" ;;
+ esac
+}
+
set_opts() {
myglewopts=(
AR="$(tc-getAR)"
STRIP=true
CC="$(tc-getCC)"
LD="$(tc-getCC) ${LDFLAGS}"
+ SYSTEM="$(glew_system)"
M_ARCH=""
LDFLAGS.EXTRA=""
LDFLAGS.GL="-lGL" # Don't need X libs!
POPT="${CFLAGS}"
)
-
- # support MinGW targets (bug #523444)
- [[ ${CHOST} == *-mingw* ]] && myglewopts+=( SYSTEM=mingw )
}
multilib_src_compile() {