summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2020-01-08 08:33:05 +0100
committerTupone Alfredo <tupone@gentoo.org>2020-01-08 08:33:05 +0100
commit3f944f98d92107b26f7347aee359dd7bf2defb42 (patch)
tree6fcfa6c8f9c83dd32c79f82a3ea0737adeec2079 /media-libs/glm
parentnet-firewall/itval: EAPI=7 (diff)
downloadgentoo-3f944f98d92107b26f7347aee359dd7bf2defb42.tar.gz
gentoo-3f944f98d92107b26f7347aee359dd7bf2defb42.tar.bz2
gentoo-3f944f98d92107b26f7347aee359dd7bf2defb42.zip
media-libs/glm: Version bump to 0.9.9.7
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'media-libs/glm')
-rw-r--r--media-libs/glm/Manifest1
-rw-r--r--media-libs/glm/files/glm.pc.in7
-rw-r--r--media-libs/glm/glm-0.9.9.7.ebuild46
3 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/glm/Manifest b/media-libs/glm/Manifest
index b26407fe392b..ce1570fce00a 100644
--- a/media-libs/glm/Manifest
+++ b/media-libs/glm/Manifest
@@ -3,3 +3,4 @@ DIST glm-0.9.9.4.tar.gz 4578404 BLAKE2B 4c0bb64bb477ca46d45b4d25d7d992a39a82a7d7
DIST glm-0.9.9.5.tar.gz 4578601 BLAKE2B 9ce4dc7e638a651f958e2e0e1bfa0da121aefc382579838bfd810952bb8f4253e17caa6d743de713c86a4e8bd5f1afa38f8162e5f2d98ab141d94574d1103d40 SHA512 3b329acf5144aab1c0f47f8045d34e097699bd6685118ad8322c5ce23afdcb44ba2bb07e49301db06355b8eef7d4340b72251d55e113b533740d1e6ef6609911
DIST glm-0.9.9.6-install.patch.gz 7594 BLAKE2B a273e1e2adc6bdcaab2a3b66457b59e42384215c19b12ce6d27706d74c4d0ec5f010912c295dff4300a44ebc16cabc09c381df5dede01daf7ebe60cf8b95d060 SHA512 bf489673077dcfc821264cbda55d63cf7a01f4e27cdcadf3f6e0d73f016a24fe590142144e2fa5d074cbc518acf34164653c31a346ab6909cfbd7af6c294e79f
DIST glm-0.9.9.6.tar.gz 4354114 BLAKE2B e62af8d4fe22eced565a2703f5d02ad935a18a4c9352302fdb203c85149b9374066684246f940e417882d2700d13b93fc0232921151680ec58c9df80ee0be1fd SHA512 1bc8fc1da21e19f95d4a24259993c7932db328fdd2d0db68dbf60c07f372e19003a8df094fb4e153bb7f50df584c17cf0a540d3d3c38b7a287f3b55314ec2d70
+DIST glm-0.9.9.7.tar.gz 4357077 BLAKE2B 59746a8775e0fc20fe8a8c3ae01c48841066d6092ce3cd7fa93bbf29f5247c42645bc920a3dbf3f0b4b61eb1e47f46514d9cd98c4e6df133ced0072ba6a570ee SHA512 9c557788d6382777317c94f8b30bc3df7e533877705514fa5d384f97b076d6bc750e841acbecdec8113e21af07bd8850159f5f1e079aaa2cde25540b480f983b
diff --git a/media-libs/glm/files/glm.pc.in b/media-libs/glm/files/glm.pc.in
new file mode 100644
index 000000000000..fc5c7bb7f90c
--- /dev/null
+++ b/media-libs/glm/files/glm.pc.in
@@ -0,0 +1,7 @@
+prefix=@CMAKE_INSTALL_PREFIX@
+includedir=${prefix}/include
+
+Name: GLM
+Description: OpenGL Mathematics
+Version: @GLM_VERSION@
+Cflags: -I${includedir}
diff --git a/media-libs/glm/glm-0.9.9.7.ebuild b/media-libs/glm/glm-0.9.9.7.ebuild
new file mode 100644
index 000000000000..ac6c4ff427a1
--- /dev/null
+++ b/media-libs/glm/glm-0.9.9.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="OpenGL Mathematics"
+HOMEPAGE="http://glm.g-truc.net/"
+SRC_URI="https://github.com/g-truc/glm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( HappyBunny MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86_avx2"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/opengl"
+
+src_prepare() {
+ sed -e "s:@CMAKE_INSTALL_PREFIX@:${EPREFIX}/usr:" \
+ "${FILESDIR}"/glm.pc.in \
+ > glm.pc
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ if use test; then
+ local mycmakeargs=(
+ -DGLM_TEST_ENABLE=ON
+ -DGLM_TEST_ENABLE_SIMD_SSE2="$(usex cpu_flags_x86_sse2 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_SSE3="$(usex cpu_flags_x86_sse3 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX="$(usex cpu_flags_x86_avx ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX2="$(usex cpu_flags_x86_avx2 ON OFF)"
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ doheader -r glm
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins glm.pc
+ dodoc readme.md manual.md
+}