summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-07-31 01:27:13 +0300
committerMart Raudsepp <leio@gentoo.org>2018-07-31 01:58:00 +0300
commitae2bcceda76a189bdcb4cfa900be413e2bbecf80 (patch)
tree61a36b95dd42e05d8858abcbbf6ed23bad1dee96 /media-libs/gst-plugins-good
parentapp-emulation/lxc: remove old (diff)
downloadgentoo-ae2bcceda76a189bdcb4cfa900be413e2bbecf80.tar.gz
gentoo-ae2bcceda76a189bdcb4cfa900be413e2bbecf80.tar.bz2
gentoo-ae2bcceda76a189bdcb4cfa900be413e2bbecf80.zip
media-libs/gst-plugins-good: bump to 1.14.2 for upstream bug fixes
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/Manifest1
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.14.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/Manifest b/media-libs/gst-plugins-good/Manifest
index d8991980a8c0..a6ea6781a30d 100644
--- a/media-libs/gst-plugins-good/Manifest
+++ b/media-libs/gst-plugins-good/Manifest
@@ -1,3 +1,4 @@
DIST gst-plugins-good-0.10.31.tar.xz 2738016 BLAKE2B a015ef6993078f1c699badcc9911a835fe1d129b4e0dccb3937d49768d9202549204bbfb0d7ad575bcb77c75f73662a83912936b2664a2b1cd7c331e4d203c4f SHA512 d153dcd5bb846450e9d76fe247f2b2e627e760feaad1bfd4c503a39af2128fad3630788463ea0d50539209236c864df0b2172ab9dac52f49cadff69ac7346809
DIST gst-plugins-good-1.12.4.tar.xz 3489992 BLAKE2B 41715d3e9bda183706d87085bc8cca546720f20e32fd5ecf6e284814745f2fe8ba4cfcd244e50d0734e57dde26944539b8273879608d3042262bfc10f82cc2b9 SHA512 18f270c01be80fe5b026e2c26db3ec200117ffd99c1dca55a8a78f0bd6dcc4701126836e52a410f179779e363f11218413c7b4d13e96ef5ee1bfa82e79a81178
DIST gst-plugins-good-1.14.1.tar.xz 3776168 BLAKE2B 5b17ac49d5bae423ee887f1516ba8bfb542acb17e3f304f489dddbaa728761ee51a08e67bd10a9981f53b5b8424d8013d1723fcbbf6e06d34a39548868d34f85 SHA512 b52d3214f2d32f263637cb9f0838284483e15b8d20bf36d64c349e99b481095734a4dd2c2421176540dfe5129ecc1acc101b89cc898b4773f0f736e8e962b070
+DIST gst-plugins-good-1.14.2.tar.xz 3779912 BLAKE2B d49f82a6be7423d233ec15660470533d6bfc5da3d2ac5912ce7b3f97739b1540424c02593aff269aae3df7c6f15ca37b2d9d45fe85f3b36b910cdac4ba98f093 SHA512 26ff40d949ab95043ed717350fb344a616c72b049cd52c3e7debd9cc37f73eb9d4704b4f437ba257cecb9dba702ce451647279cb821e9405b36210b46ae9aa05
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.14.2.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.14.2.ebuild
new file mode 100644
index 000000000000..daf9c7a0a3b6
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.14.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-good"
+
+inherit flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ # Always enable optional bz2 support for matroska
+ # Always enable optional zlib support for qtdemux and matroska
+ # Many media files require these to work, as some container headers are often
+ # compressed, bug #291154
+ gstreamer_multilib_src_configure \
+ --enable-bz2 \
+ --enable-zlib \
+ --disable-examples \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}