summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-15 12:19:52 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-15 12:21:05 +0200
commit5f6c559f71e6a2270fc371891e97a570a8968935 (patch)
treed8a52f2d5e55933bbdf33d95f3faadd271378702 /media-libs/harfbuzz
parentpackage.mask: Last rite dev-lang/pasm (diff)
downloadgentoo-5f6c559f71e6a2270fc371891e97a570a8968935.tar.gz
gentoo-5f6c559f71e6a2270fc371891e97a570a8968935.tar.bz2
gentoo-5f6c559f71e6a2270fc371891e97a570a8968935.zip
media-libs/harfbuzz: Bump to version 2.6.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/harfbuzz')
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-2.6.0.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index 8d7d96ac37e8..15c80b243267 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -2,3 +2,4 @@ DIST harfbuzz-2.3.1.tar.bz2 17942960 BLAKE2B b1a29144b608463fa668bb66572c1530e90
DIST harfbuzz-2.4.0a.tar.bz2 17919355 BLAKE2B 4df7677966844481b707fe3133f4fddf3c5c41d7de8aca4e87019e88c928d66000e49117c795af69967f7c69532438ef5aa8f41ead276e7d05fdc4dd874daeb1 SHA512 daeaf029bd5d0d0674f930a8d0dcdc4e0b1253b2369c732c7b4fd130ab9438d0d9526967224a583ee58974c3b492874acaccdac13c71b58c950f0b3f031e505c
DIST harfbuzz-2.5.2.tar.xz 5674180 BLAKE2B 64f78f215ab840cda7000813362d886ca3244ffac9acc92ce29826991d4f4c71e4fda1b4da4f1ad13d62a4569fe4173948debbd6e2da5c4d67c7d9db9ecafc85 SHA512 4a295074b56ff77581f79eae918fe064c25f07dc2ada1c87a3b2ba29ebc1ef55fa357b74c935b40621267eb061221050b4671021900ad5417580a4c57eb4739f
DIST harfbuzz-2.5.3.tar.xz 5685712 BLAKE2B a9d8a46b6a0667c598ea011f020b09d8fd795105483a8b307ee2a9399de2b84bf3b29659f9a3f7500250879bbb412003ee6f68aaba01b68824bd489615f737e6 SHA512 a2e6cedbe0e505fa31b540e0d0bc6c0b07080bd39879c27e04d351103e21201d75a809dd2fad559bf994b82b311f67ad85778cbbfb670d7e2580beafa09e93ff
+DIST harfbuzz-2.6.0.tar.xz 5736808 BLAKE2B 3dcdf71cce8cdb4596d6e622f6fbaeae1a36cf17c219a1bafe077a472f9d25f0a8b8ea7eb36a1e20558d982b36479ce5d3e19f022a5b7dadd563a017b5037767 SHA512 ab055183ae248710f7baee7ef45ac1a6cbd3522eb1e26b78248ac7bc9e421f5495b8fbbd19a339a26bd119f33624eb8742c15c2053407fbb74cce8dcf6c4b3a2
diff --git a/media-libs/harfbuzz/harfbuzz-2.6.0.ebuild b/media-libs/harfbuzz/harfbuzz-2.6.0.ebuild
new file mode 100644
index 000000000000..f03429a61fe5
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-2.6.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/harfbuzz.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+
+IUSE="+cairo debug +glib +graphite icu +introspection static-libs test +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+# eautoreconf requires gobject-introspection-common
+# ragel needed if regenerating *.hh files from *.rl
+if [[ ${PV} = 9999 ]] ; then
+ DEPEND+="
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+ "
+fi
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
+ test/api/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for Solaris
+
+ # bug 618772
+ append-cxxflags -std=c++14
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ local myeconfargs=(
+ --without-coretext
+ --without-fontconfig #609300
+ --without-uniscribe
+ $(use_enable static-libs static)
+ $(multilib_native_use_with cairo)
+ $(use_with glib)
+ $(use_with introspection gobject)
+ $(use_with graphite graphite2)
+ $(use_with icu)
+ $(multilib_native_use_enable introspection)
+ $(use_with truetype freetype)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name "*.la" -delete || die
+}