summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-10 16:57:46 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-10 16:59:53 +0200
commitcea5273a360638e93492da145761a2fc061c9d54 (patch)
tree8942e1d452704a11040b7ff4e76c9848dfe7d8ac /media-libs/libcdr
parentmedia-libs/fontconfig: Removed old. (diff)
downloadgentoo-cea5273a360638e93492da145761a2fc061c9d54.tar.gz
gentoo-cea5273a360638e93492da145761a2fc061c9d54.tar.bz2
gentoo-cea5273a360638e93492da145761a2fc061c9d54.zip
media-libs/libcdr: Bump to version 0.1.3
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/libcdr')
-rw-r--r--media-libs/libcdr/Manifest1
-rw-r--r--media-libs/libcdr/libcdr-0.1.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/libcdr/Manifest b/media-libs/libcdr/Manifest
index 61a2e66a2248..f36fea2f5786 100644
--- a/media-libs/libcdr/Manifest
+++ b/media-libs/libcdr/Manifest
@@ -2,3 +2,4 @@ DIST libcdr-0.0.14.tar.xz 570728 SHA256 720b693ba5e777f099f41ecd40418a16674ab29d
DIST libcdr-0.0.16.tar.xz 569644 SHA256 4c8a6586920f7b040ce51fa375eb87507291e0de4f568469db25f52915bc1135 SHA512 59b65b95806bce3c97c1a0762bb80ce0845e444a23b7b4683c74d6c0c9155664e7a7e558d787f6cfa69460f657e4d7416ae8e8947e426f04e369b42fc5da4838 WHIRLPOOL a0021dc4b8640fc2c192ead7b34a9c98536dcfcc2d13b65028768cb61a0ed96a163e8189a1b16751a62bdb7853d210fdfd9d3343870140eb6fe9cd95011c24af
DIST libcdr-0.1.1.tar.xz 564668 SHA256 d0a6e0667e5a37fe059bcb81d5077fc2abffc7e7bac86fe302fbcf927d58df1f SHA512 a655b5390022fb5049d2f75fe836a693033943060d820942d59eb0a34548363ff183e0f32d22ec277d1f8b5c7ab89ab1fba933f17ef1239d14d053bd6a5cf624 WHIRLPOOL f7d5b6b1655f86ac3b843957e476ab17f2ef234bb5073678d182760cd6a370d24c98b14570474221d9f5ef9b24ffc76a5f4f82d596f466a7324dac95a04b9d77
DIST libcdr-0.1.2.tar.xz 602024 SHA256 6bdb20bcdec5ad1a115d0a3aada7d4b2758e9d22801d72b4ecc2e55fb3d5d42c SHA512 c5c08444fa28be13b60ba1aa515a47606de80b079cbabb0276f54064820fecb2a6ee50a8b33a6cc1b2f5f46323d3de7f00822aadec5c3058a14adebf5255da91 WHIRLPOOL bd3137e234bfa37e82f121b431bb47c5fe5844d3ccf3d73b1aa5660ee732a2705fca0280777111f22bac4056f2f82be7df1e93eb6668dc7c4062727635d89b10
+DIST libcdr-0.1.3.tar.xz 596772 SHA256 66e28e502abef7f6f494ce03de037d532f5e7888cfdee62c01203c8325b33f22 SHA512 9811efb13f7dd72c69a98e81b44a261e913ffe87200486c8e07200d75790004d4fdf30e29f779b0ddd2ad09e3d1e8813ef501e9448c1789f89256f71bdb5fadd WHIRLPOOL 6772ac928a66f21c689f39a3abc762d043baf89d009d86ce79d68aa8b1354a4965a2f489bf8bd754c4a76bee3ac3695658ee4ec14ed7cf19986e48c22b0e4f97
diff --git a/media-libs/libcdr/libcdr-0.1.3.ebuild b/media-libs/libcdr/libcdr-0.1.3.ebuild
new file mode 100644
index 000000000000..d818832699f5
--- /dev/null
+++ b/media-libs/libcdr/libcdr-0.1.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
+inherit eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing the Corel cdr documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ media-libs/lcms:2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ eapply_user
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}