summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-12-06 12:14:44 -0500
committerMatt Turner <mattst88@gentoo.org>2019-12-06 12:25:13 -0500
commit630f6f5ed9e3d1b80d0947a3a751578a862d6449 (patch)
treebc390d4cb8e651d00fd16292dbafdbca0631e291 /media-libs/libglvnd
parentmedia-tv/kodi: Fix compiling with >=dev-libs/libfmt-6.1.0 (diff)
downloadgentoo-630f6f5ed9e3d1b80d0947a3a751578a862d6449.tar.gz
gentoo-630f6f5ed9e3d1b80d0947a3a751578a862d6449.tar.bz2
gentoo-630f6f5ed9e3d1b80d0947a3a751578a862d6449.zip
media-libs/libglvnd: Fix a couple of mistakes
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/libglvnd')
-rw-r--r--media-libs/libglvnd/files/libglvnd-1.3.0-meson-Fix-the-PPC64-build.patch54
-rw-r--r--media-libs/libglvnd/files/libglvnd-1.3.0-meson-Fix-the-armv7-build.patch36
-rw-r--r--media-libs/libglvnd/libglvnd-1.3.0.ebuild5
3 files changed, 95 insertions, 0 deletions
diff --git a/media-libs/libglvnd/files/libglvnd-1.3.0-meson-Fix-the-PPC64-build.patch b/media-libs/libglvnd/files/libglvnd-1.3.0-meson-Fix-the-PPC64-build.patch
new file mode 100644
index 000000000000..51a26c8e0dc8
--- /dev/null
+++ b/media-libs/libglvnd/files/libglvnd-1.3.0-meson-Fix-the-PPC64-build.patch
@@ -0,0 +1,54 @@
+From 5ffb8df0ae243f611a0752950443e7a9877e502c Mon Sep 17 00:00:00 2001
+From: Kyle Brenneman <kbrenneman@nvidia.com>
+Date: Fri, 6 Dec 2019 07:27:54 -0700
+Subject: [PATCH 2/2] meson: Fix the PPC64 build.
+
+Check for a cpu_family value of 'ppc64', not 'ppc'. 'ppc' is for 32-bit power.
+
+In GLdispatch, fix the file list for the PPC64 entrypoints.
+---
+ meson.build | 4 ++--
+ src/GLdispatch/vnd-glapi/meson.build | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 44c7172..602e837 100644
+--- a/meson.build
++++ b/meson.build
+@@ -55,7 +55,7 @@ if not with_asm.disabled()
+ add_project_arguments('-DUSE_ARMV7_ASM', language : 'c')
+ elif host_machine.cpu_family() == 'aarch64'
+ add_project_arguments('-DUSE_AARCH64_ASM', language : 'c')
+- elif host_machine.cpu_family() == 'ppc' and host_machine.endian() == 'little'
++ elif host_machine.cpu_family() == 'ppc64' and host_machine.endian() == 'little'
+ add_project_arguments('-DUSE_PPC64LE_ASM', language : 'c')
+ elif with_asm.enabled()
+ error('No ASM available for @0@ (@1@ endian)'.format(host_machine.system(), host_machine.endian()))
+@@ -118,7 +118,7 @@ if use_asm
+ elif host_machine.cpu_family() == 'aarch64'
+ gl_dispatch_type = 'aarch64_tsd'
+ elif host_machine.cpu_family() == 'ppc64' and host_machine.endian() == 'little'
+- gl_dispatch_type = 'ppc64le_@1@'.format(have_tls ? 'tls' : 'tsd')
++ gl_dispatch_type = 'ppc64le_@0@'.format(have_tls ? 'tls' : 'tsd')
+ endif
+ endif
+ add_project_arguments('-DGLDISPATCH_TYPE_@0@'.format(gl_dispatch_type.to_upper()), language : ['c'])
+diff --git a/src/GLdispatch/vnd-glapi/meson.build b/src/GLdispatch/vnd-glapi/meson.build
+index ce20178..200d476 100644
+--- a/src/GLdispatch/vnd-glapi/meson.build
++++ b/src/GLdispatch/vnd-glapi/meson.build
+@@ -55,9 +55,9 @@ else
+ elif gl_dispatch_type == 'aarch64_tsd'
+ _entry_files += 'entry_aarch64_tsd.c'
+ elif gl_dispatch_type == 'ppc64le_tls'
+- _entry_files += 'entry_aarch64_tls.c'
++ _entry_files += 'entry_ppc64le_tls.c'
+ elif gl_dispatch_type == 'ppc64le_tsd'
+- _entry_files += 'entry_aarch64_tsd.c'
++ _entry_files += 'entry_ppc64le_tsd.c'
+ else
+ error('No matching ASM file for @0@'.format(gl_dispatch_type))
+ endif
+--
+2.23.0
+
diff --git a/media-libs/libglvnd/files/libglvnd-1.3.0-meson-Fix-the-armv7-build.patch b/media-libs/libglvnd/files/libglvnd-1.3.0-meson-Fix-the-armv7-build.patch
new file mode 100644
index 000000000000..e520ae7ff4a8
--- /dev/null
+++ b/media-libs/libglvnd/files/libglvnd-1.3.0-meson-Fix-the-armv7-build.patch
@@ -0,0 +1,36 @@
+From 9ccdb05cdd620c4ae9454010f419d7d11c0efcdc Mon Sep 17 00:00:00 2001
+From: Kyle Brenneman <kbrenneman@nvidia.com>
+Date: Fri, 6 Dec 2019 07:22:40 -0700
+Subject: [PATCH 1/2] meson: Fix the armv7 build.
+
+Fix the GLdispatch meson file so that it checks for the value "armv7_tsd" for
+gl_dispatch_type instead of "arm_tsd".
+---
+ src/GLdispatch/vnd-glapi/meson.build | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/GLdispatch/vnd-glapi/meson.build b/src/GLdispatch/vnd-glapi/meson.build
+index c5319fc..ce20178 100644
+--- a/src/GLdispatch/vnd-glapi/meson.build
++++ b/src/GLdispatch/vnd-glapi/meson.build
+@@ -39,7 +39,7 @@ if gl_dispatch_type == 'pure_c'
+ _entry_files += 'entry_pure_c.c'
+ else
+ _entry_files += 'entry_common.c'
+- if gl_dispatch_type != 'arm_tsd'
++ if gl_dispatch_type != 'armv7_tsd'
+ _entry_files += 'entry_simple_asm.c'
+ endif
+ if gl_dispatch_type == 'x86_tls'
+@@ -50,7 +50,7 @@ else
+ _entry_files += 'entry_x86_64_tls.c'
+ elif gl_dispatch_type == 'x86_64_tsd'
+ _entry_files += 'entry_x86_64_tsd.c'
+- elif gl_dispatch_type == 'arm_tsd'
++ elif gl_dispatch_type == 'armv7_tsd'
+ _entry_files += 'entry_armv7_tsd.c'
+ elif gl_dispatch_type == 'aarch64_tsd'
+ _entry_files += 'entry_aarch64_tsd.c'
+--
+2.23.0
+
diff --git a/media-libs/libglvnd/libglvnd-1.3.0.ebuild b/media-libs/libglvnd/libglvnd-1.3.0.ebuild
index b19c93a7923e..3998ef2e3b8a 100644
--- a/media-libs/libglvnd/libglvnd-1.3.0.ebuild
+++ b/media-libs/libglvnd/libglvnd-1.3.0.ebuild
@@ -41,6 +41,11 @@ RDEPEND="
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )"
+PATCHES=(
+ "${FILESDIR}"/${P}-meson-Fix-the-armv7-build.patch
+ "${FILESDIR}"/${P}-meson-Fix-the-PPC64-build.patch
+)
+
multilib_src_configure() {
local emesonargs=(
$(meson_feature X x11)