summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-06-05 12:20:59 +0200
committerPacho Ramos <pacho@gentoo.org>2017-06-05 12:21:41 +0200
commit36175d21171b68af965eae9353e737f51bfca7d6 (patch)
tree3e276f0ebd21e3e7c90d5fa246d22b47a79010ba /media-libs/libkate
parentapp-text/bibus: Use wxpython-3.0 with Debian patch (#601094) (diff)
downloadgentoo-36175d21171b68af965eae9353e737f51bfca7d6.tar.gz
gentoo-36175d21171b68af965eae9353e737f51bfca7d6.tar.bz2
gentoo-36175d21171b68af965eae9353e737f51bfca7d6.zip
media-libs/libkate: Use wxpython-3.0 (#601184), drop static libs (#514380)
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-libs/libkate')
-rw-r--r--media-libs/libkate/libkate-0.4.1-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/libkate/libkate-0.4.1-r2.ebuild b/media-libs/libkate/libkate-0.4.1-r2.ebuild
new file mode 100644
index 000000000000..a7a2d150f1cd
--- /dev/null
+++ b/media-libs/libkate/libkate-0.4.1-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit ltprune python-single-r1
+
+DESCRIPTION="Codec for karaoke and text encapsulation for Ogg"
+HOMEPAGE="https://code.google.com/p/libkate/"
+SRC_URI="https://libkate.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+IUSE="debug doc wxwidgets"
+REQUIRED_USE="wxwidgets? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ media-libs/libogg:=
+ media-libs/libpng:0=
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="${COMMON_DEPEND}
+ wxwidgets? (
+ ${PYTHON_DEPS}
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ media-libs/liboggz )
+"
+
+pkg_setup() {
+ use wxwidgets && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ if ! use wxwidgets; then
+ sed -i -e "s/HAVE_PYTHON=yes/HAVE_PYTHON=no/" configure || die
+ fi
+
+ econf --disable-static $(use_enable debug) $(use_enable doc)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ use wxwidgets && python_fix_shebang "${D}"
+}