summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libmp4v2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libmp4v2')
-rw-r--r--media-libs/libmp4v2/Manifest2
-rw-r--r--media-libs/libmp4v2/libmp4v2-1.9.1-r1.ebuild41
-rw-r--r--media-libs/libmp4v2/libmp4v2-2.0.0.ebuild42
-rw-r--r--media-libs/libmp4v2/metadata.xml11
4 files changed, 96 insertions, 0 deletions
diff --git a/media-libs/libmp4v2/Manifest b/media-libs/libmp4v2/Manifest
new file mode 100644
index 000000000000..096fd7ba9541
--- /dev/null
+++ b/media-libs/libmp4v2/Manifest
@@ -0,0 +1,2 @@
+DIST mp4v2-1.9.1.tar.bz2 432943 SHA256 5c381caeab2326fc48cfda0fe202bdb8ba0ae624d9c97ad7680a2b07e2c2e3b4 SHA512 28b6f96c1d44a1601980113767c38f5b5b058e1a1fae25c18632163e948c18fc884af9d146bb68e771303ab3c5c8ef9437f4fffa7d770d29157f2d455ee4b1c8 WHIRLPOOL 7ba33598287002d4227bcc4bfc1e8fe71241b95ed7151704b78a250d0f5f7d5c77cabf0195502d368571f5668f775fdecc09700bea12859c827d0d29aa654f5e
+DIST mp4v2-2.0.0.tar.bz2 495672 SHA256 0319b9a60b667cf10ee0ec7505eb7bdc0a2e21ca7a93db96ec5bd758e3428338 SHA512 15eb882f33d72d4209053b54c883b67715f539c33096705a0e7bc79015b93f6f3ac80ae29c65a0ffe9eab1bf0dedf07198bdee23fa6eafcd6ccb34f984484be0 WHIRLPOOL 754e239bd6f209454dc86f4632929b30ee1b5d782ea4e8b495ac5fbfef384b7a503d535294d5ab71e98fa9f5437c50fb5522f0bfac5f8a254690b4c78a8e96e0
diff --git a/media-libs/libmp4v2/libmp4v2-1.9.1-r1.ebuild b/media-libs/libmp4v2/libmp4v2-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..c209d32fb872
--- /dev/null
+++ b/media-libs/libmp4v2/libmp4v2-1.9.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# this ebuild is only for the libmp4v2.so.1 SONAME for ABI compat
+
+EAPI=4
+inherit libtool multilib
+
+DESCRIPTION="Functions for accessing ISO-IEC:14496-1:2001 MPEG-4 standard"
+HOMEPAGE="http://code.google.com/p/mp4v2/"
+SRC_URI="http://mp4v2.googlecode.com/files/${P/lib}.tar.bz2"
+
+LICENSE="MPL-1.1"
+SLOT="1"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RESTRICT="test"
+
+RDEPEND="!<=${CATEGORY}/${PN}-1.9.1:0"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+S=${WORKDIR}/${P/lib}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf --disable-gch --disable-util --disable-static
+}
+
+src_compile() {
+ emake ${PN}.la
+}
+
+src_install() {
+ newlib.so .libs/${PN}$(get_libname ${PV}) ${PN}$(get_libname ${PV%.*.*})
+}
diff --git a/media-libs/libmp4v2/libmp4v2-2.0.0.ebuild b/media-libs/libmp4v2/libmp4v2-2.0.0.ebuild
new file mode 100644
index 000000000000..079c26f31df4
--- /dev/null
+++ b/media-libs/libmp4v2/libmp4v2-2.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit libtool
+
+MY_P=${P/lib}
+
+DESCRIPTION="Functions for accessing ISO-IEC:14496-1:2001 MPEG-4 standard"
+HOMEPAGE="http://code.google.com/p/mp4v2/"
+SRC_URI="http://mp4v2.googlecode.com/files/${MY_P}.tar.bz2"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="static-libs test utils"
+
+RDEPEND=""
+DEPEND="sys-apps/sed
+ utils? ( sys-apps/help2man )
+ test? ( dev-util/dejagnu )"
+
+DOCS="doc/*.txt README"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gch \
+ $(use_enable utils util) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/media-libs/libmp4v2/metadata.xml b/media-libs/libmp4v2/metadata.xml
new file mode 100644
index 000000000000..2dbc62f18142
--- /dev/null
+++ b/media-libs/libmp4v2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <use>
+ <flag name="utils">Install command-line utilities</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">mp4v2</remote-id>
+ </upstream>
+</pkgmetadata>