summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-18 20:37:24 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-18 20:37:45 +0200
commit5eb18ea0987f2dff33bb7cebc6d03d0da886f575 (patch)
treeb10830db16fe51e0f832ffd8e67493b1aaaed8a0 /media-libs/libsdl2
parentmedia-libs/libsdl2: Drop old (diff)
downloadgentoo-5eb18ea0987f2dff33bb7cebc6d03d0da886f575.tar.gz
gentoo-5eb18ea0987f2dff33bb7cebc6d03d0da886f575.tar.bz2
gentoo-5eb18ea0987f2dff33bb7cebc6d03d0da886f575.zip
media-libs/libsdl2: 2.0.5 is stable on ia64
Package-Manager: Portage-2.3.28, Repoman-2.3.9 RepoMan-Options: --force
Diffstat (limited to 'media-libs/libsdl2')
-rw-r--r--media-libs/libsdl2/Manifest1
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.5.ebuild157
2 files changed, 158 insertions, 0 deletions
diff --git a/media-libs/libsdl2/Manifest b/media-libs/libsdl2/Manifest
index 6f3ef4735ad8..c053b3107aa3 100644
--- a/media-libs/libsdl2/Manifest
+++ b/media-libs/libsdl2/Manifest
@@ -1,2 +1,3 @@
DIST SDL2-2.0.4.tar.gz 4136230 BLAKE2B 374ba4c86f10d07f592dbeb6340b38e1360561fed4fa40d75c763adbfc3dd1605eed6841243ce14597814da5b0a86d7c6d4351198987919a3a7bc4db943f32b7 SHA512 dd0a95878639856c0f4b8a579ace8071379ab64519fa139b22d3ed857a0f0db87a75bc8480c7207e02fbffd1fdbd448e3c0b882c451675b0e2f1a945af02e1d6
+DIST SDL2-2.0.5.tar.gz 4209352 BLAKE2B c0a040e39117ac355e49950434a96b790dba2af13116071bdad6e50131b8f62f494463ec5fff5e4aff370733ac226888033ba189e431cc527cb3149076548159 SHA512 6401f5df08c08316c09bc6ac5b28345c5184bb25770baa5c94c0a582ae130ddf73bb736e44bb31f4e427c1ddbbeec4755a6a5f530b6b4c3d0f13ebc78ddc1750
DIST SDL2-2.0.8.tar.gz 4909017 BLAKE2B f6b365a6033e10ef0c5d56ee5e17cc1caada99a97b7ccc7b0eab4f7ca5fc513b78e71960a41a20319c5de1d9eb9eaeffb06b90d090e14e8d354a9b8315ab12f1 SHA512 673c6058b8692a36b4a3594456b10ef6051efe79e4fb644421fc5c76b11fd68b895840a2c8b72413418c378733e2993d33f19767d0d7ed101eda6310bd70c869
diff --git a/media-libs/libsdl2/libsdl2-2.0.5.ebuild b/media-libs/libsdl2/libsdl2-2.0.5.ebuild
new file mode 100644
index 000000000000..2f64a708de5d
--- /dev/null
+++ b/media-libs/libsdl2/libsdl2-2.0.5.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: convert FusionSound #484250
+
+EAPI=6
+inherit autotools flag-o-matic toolchain-funcs eutils multilib-minimal
+
+MY_P=SDL2-${PV}
+DESCRIPTION="Simple Direct Media Layer"
+HOMEPAGE="http://www.libsdl.org"
+SRC_URI="http://www.libsdl.org/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="cpu_flags_x86_3dnow alsa altivec custom-cflags dbus fusionsound gles haptic +joystick cpu_flags_x86_mmx nas opengl oss pulseaudio +sound cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs +threads tslib udev +video wayland X xinerama xscreensaver"
+REQUIRED_USE="
+ alsa? ( sound )
+ fusionsound? ( sound )
+ gles? ( video )
+ nas? ( sound )
+ opengl? ( video )
+ pulseaudio? ( sound )
+ wayland? ( gles )
+ xinerama? ( X )
+ xscreensaver? ( X )"
+
+RDEPEND="
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ fusionsound? ( >=dev-libs/DirectFB-1.7.1[fusionsound] )
+ gles? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
+ nas? ( >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}] )
+ opengl? (
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
+ )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ tslib? ( >=x11-libs/tslib-1.0-r3[${MULTILIB_USEDEP}] )
+ udev? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
+ wayland? (
+ >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}]
+ >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},egl,gles2,wayland]
+ >=x11-libs/libxkbcommon-0.2.0[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXcursor-1.1.14[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}]
+ xinerama? ( >=x11-libs/libXinerama-1.1.3[${MULTILIB_USEDEP}] )
+ xscreensaver? ( >=x11-libs/libXScrnSaver-1.2.2-r1[${MULTILIB_USEDEP}] )
+ )"
+DEPEND="${RDEPEND}
+ X? (
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ )
+ virtual/pkgconfig"
+
+PATCHES=(
+ # https://bugzilla.libsdl.org/show_bug.cgi?id=1431
+ "${FILESDIR}"/${PN}-2.0.5-static-libs.patch
+)
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ sed -i -e 's/configure.in/configure.ac/' Makefile.in || die
+ mv configure.{in,ac} || die
+ AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf
+}
+
+multilib_src_configure() {
+ use custom-cflags || strip-flags
+
+ # sorted by `./configure --help`
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ --enable-atomic \
+ $(use_enable sound audio) \
+ $(use_enable video) \
+ --enable-render \
+ --enable-events \
+ $(use_enable joystick) \
+ $(use_enable haptic) \
+ --enable-power \
+ --enable-filesystem \
+ $(use_enable threads) \
+ --enable-timers \
+ --enable-file \
+ --disable-loadso \
+ --enable-cpuinfo \
+ --enable-assembly \
+ $(use_enable cpu_flags_x86_sse ssemath) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_3dnow 3dnow) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable altivec) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ --disable-alsa-shared \
+ --disable-esd \
+ $(use_enable pulseaudio) \
+ --disable-pulseaudio-shared \
+ --disable-arts \
+ $(use_enable nas) \
+ --disable-nas-shared \
+ --disable-sndio \
+ --disable-sndio-shared \
+ $(use_enable sound diskaudio) \
+ $(use_enable sound dummyaudio) \
+ $(use_enable wayland video-wayland) \
+ --disable-wayland-shared \
+ --disable-video-mir \
+ $(use_enable X video-x11) \
+ --disable-x11-shared \
+ $(use_enable X video-x11-xcursor) \
+ $(use_enable X video-x11-xdbe) \
+ $(use_enable xinerama video-x11-xinerama) \
+ $(use_enable X video-x11-xinput) \
+ $(use_enable X video-x11-xrandr) \
+ $(use_enable xscreensaver video-x11-scrnsaver) \
+ $(use_enable X video-x11-xshape) \
+ $(use_enable X video-x11-vm) \
+ --disable-video-cocoa \
+ --disable-video-directfb \
+ $(multilib_native_use_enable fusionsound) \
+ --disable-fusionsound-shared \
+ $(use_enable video video-dummy) \
+ $(use_enable opengl video-opengl) \
+ $(use_enable gles video-opengles) \
+ $(use_enable udev libudev) \
+ $(use_enable dbus) \
+ --disable-ibus \
+ $(use_enable tslib input-tslib) \
+ --disable-directx \
+ --disable-rpath \
+ --disable-render-d3d \
+ $(use_with X x)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ dodoc {BUGS,CREDITS,README,README-SDL,TODO,WhatsNew}.txt docs/README*.md
+}