summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-05-26 22:36:28 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-05-26 22:37:55 +0100
commitd4ac42c0809428ada79ce54d2dae32860d73af50 (patch)
tree9ae26c74652cf44ff634323fb2cdba43a5c124ca /media-libs/libsdl2
parentprofiles: Mask media-libs/libsdl2[kms] on bsd (diff)
downloadgentoo-d4ac42c0809428ada79ce54d2dae32860d73af50.tar.gz
gentoo-d4ac42c0809428ada79ce54d2dae32860d73af50.tar.bz2
gentoo-d4ac42c0809428ada79ce54d2dae32860d73af50.zip
media-libs/libsdl2: Add kms and video_cards_vc4 USE flags
I haven't managed to get this to work but this is probably an upstream issue so I'm adding the flag anyway. It may even work on slightly older Mesa verions. See our bug report for details. No revbump as few people will want this. Closes: https://bugs.gentoo.org/656000 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-libs/libsdl2')
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.8-r2.ebuild12
-rw-r--r--media-libs/libsdl2/metadata.xml1
2 files changed, 11 insertions, 2 deletions
diff --git a/media-libs/libsdl2/libsdl2-2.0.8-r2.ebuild b/media-libs/libsdl2/libsdl2-2.0.8-r2.ebuild
index 4708e54718be..53817491c9cf 100644
--- a/media-libs/libsdl2/libsdl2-2.0.8-r2.ebuild
+++ b/media-libs/libsdl2/libsdl2-2.0.8-r2.ebuild
@@ -13,7 +13,7 @@ LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="cpu_flags_x86_3dnow alsa altivec aqua custom-cflags dbus gles haptic libsamplerate +joystick cpu_flags_x86_mmx nas opengl oss pulseaudio +sound cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs +threads tslib udev +video wayland X xinerama xscreensaver"
+IUSE="cpu_flags_x86_3dnow alsa altivec aqua custom-cflags dbus gles haptic libsamplerate +joystick kms cpu_flags_x86_mmx nas opengl oss pulseaudio +sound cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs +threads tslib udev +video video_cards_vc4 wayland X xinerama xscreensaver"
REQUIRED_USE="
alsa? ( sound )
gles? ( video )
@@ -28,10 +28,15 @@ RDEPEND="
alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
gles? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
+ kms? (
+ >=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ >=media-libs/mesa-9.0.0[${MULTILIB_USEDEP},gbm]
+ )
libsamplerate? ( media-libs/libsamplerate[${MULTILIB_USEDEP}] )
nas? (
>=media-libs/nas-1.9.4[${MULTILIB_USEDEP}]
- >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}] )
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ )
opengl? (
>=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
>=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
@@ -125,6 +130,7 @@ multilib_src_configure() {
$(use_enable wayland video-wayland)
--disable-wayland-shared
--disable-video-mir
+ $(use_enable video_cards_vc4 video-rpi)
$(use_enable X video-x11)
--disable-x11-shared
$(use_enable X video-x11-xcursor)
@@ -139,6 +145,8 @@ multilib_src_configure() {
--disable-video-directfb
--disable-fusionsound
--disable-fusionsound-shared
+ $(use_enable kms video-kmsdrm)
+ --disable-kmsdrm-shared
$(use_enable video video-dummy)
$(use_enable opengl video-opengl)
--disable-video-opengles1
diff --git a/media-libs/libsdl2/metadata.xml b/media-libs/libsdl2/metadata.xml
index d72b5fdb4d5c..f10ebbd6297d 100644
--- a/media-libs/libsdl2/metadata.xml
+++ b/media-libs/libsdl2/metadata.xml
@@ -28,6 +28,7 @@
<flag name="gles">include OpenGL ES support</flag>
<flag name="haptic">Enable the haptic (force feedback) subsystem</flag>
<flag name="joystick">Control joystick support (disable at your own risk)</flag>
+ <flag name="kms">Build the KMSDRM video driver</flag>
<flag name="sound">Control audio support (disable at your own risk)</flag>
<flag name="tslib">Build with tslib support for touchscreen devices</flag>
<flag name="video">Control video support (disable at your own risk)</flag>