summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-17 14:43:20 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-03-17 14:43:30 +0100
commit8b027a1630d19999f03a141f7d1be13d285571f6 (patch)
tree6ff5a10acf1063657a4a076420cc2ac7db37fdba /media-libs/libvorbis/libvorbis-1.3.6.ebuild
parentdev-java/lucene: Drop dependencies on obsolete dev-java/ant-trax and dev-java... (diff)
downloadgentoo-8b027a1630d19999f03a141f7d1be13d285571f6.tar.gz
gentoo-8b027a1630d19999f03a141f7d1be13d285571f6.tar.bz2
gentoo-8b027a1630d19999f03a141f7d1be13d285571f6.zip
media-libs/libvorbis: bump to 1.3.6
Bug: https://bugs.gentoo.org/631632 Bug: https://bugs.gentoo.org/650654 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/libvorbis/libvorbis-1.3.6.ebuild')
-rw-r--r--media-libs/libvorbis/libvorbis-1.3.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/libvorbis/libvorbis-1.3.6.ebuild b/media-libs/libvorbis/libvorbis-1.3.6.ebuild
new file mode 100644
index 000000000000..92e37324f12b
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.3.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib
+
+DESCRIPTION="The Ogg Vorbis sound file format library"
+HOMEPAGE="https://xiph.org/vorbis/"
+SRC_URI="https://downloads.xiph.org/releases/vorbis/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS/s:-O20::' \
+ -e '/CFLAGS/s:-mcpu=750::' \
+ -e '/CFLAGS/s:-mno-ieee-fp::' \
+ configure.ac || die
+
+ # Un-hack docdir redefinition.
+ find -name 'Makefile.am' \
+ -exec sed -i \
+ -e 's:$(datadir)/doc/$(PACKAGE)-$(VERSION):@docdir@/html:' \
+ {} + || die
+
+ AT_M4DIR="m4" \
+ autotools-multilib_src_prepare
+}