summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-09 23:24:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-10 00:08:35 +0100
commit1513c21b7365ba12d7d334f859f19b36626487c5 (patch)
tree5edbe85b1ab1dfc860c6bcd7ac91ab9ebddf81cb /media-libs/mediastreamer
parentapp-editors/kile: Add 2.9.91_p20180208 snapshot (diff)
downloadgentoo-1513c21b7365ba12d7d334f859f19b36626487c5.tar.gz
gentoo-1513c21b7365ba12d7d334f859f19b36626487c5.tar.bz2
gentoo-1513c21b7365ba12d7d334f859f19b36626487c5.zip
media-libs/mediastreamer: Drop old
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/mediastreamer')
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.7.3-ffmpeg-0.11.patch94
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.7.3-sdl-build.patch220
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.7.3-v4l-automagic.patch40
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.7.3-videoenc_282.patch130
-rw-r--r--media-libs/mediastreamer/mediastreamer-2.7.3-r3.ebuild129
-rw-r--r--media-libs/mediastreamer/mediastreamer-2.9.0.ebuild171
6 files changed, 0 insertions, 784 deletions
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.7.3-ffmpeg-0.11.patch b/media-libs/mediastreamer/files/mediastreamer-2.7.3-ffmpeg-0.11.patch
deleted file mode 100644
index c242b5fe139c..000000000000
--- a/media-libs/mediastreamer/files/mediastreamer-2.7.3-ffmpeg-0.11.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-Fix build with recent ffmpeg releases.
-https://bugs.gentoo.org/show_bug.cgi?id=419453
-
-Index: mediastreamer-2.7.3/src/videoenc.c
-===================================================================
---- mediastreamer-2.7.3.orig/src/videoenc.c
-+++ mediastreamer-2.7.3/src/videoenc.c
-@@ -53,7 +53,6 @@ void ms_ffmpeg_log_callback(void* ptr, i
-
- void ms_ffmpeg_check_init(){
- if(!avcodec_initialized){
-- avcodec_init();
- avcodec_register_all();
- avcodec_initialized=TRUE;
- #ifdef ENABLE_LOG_FFMPEG
-@@ -107,6 +106,7 @@ typedef struct EncState{
- uint32_t framenum;
- VideoStarter starter;
- bool_t req_vfu;
-+ AVDictionary * ff_opts;
- }EncState;
-
- static int enc_set_fps(MSFilter *f, void *arg){
-@@ -214,6 +214,7 @@ static void enc_init(MSFilter *f, enum C
- s->req_vfu=FALSE;
- s->framenum=0;
- s->av_context.codec=NULL;
-+ s->ff_opts = NULL;
- }
-
- static void enc_h263_init(MSFilter *f){
-@@ -300,9 +301,9 @@ static void prepare_h263(EncState *s){
- if (s->profile==0){
- s->codec=CODEC_ID_H263;
- }else{
-- c->flags|=CODEC_FLAG_H263P_UMV;
-+ av_dict_set(&(s->ff_opts), "umv", "1", 0);
- c->flags|=CODEC_FLAG_AC_PRED;
-- c->flags|=CODEC_FLAG_H263P_SLICE_STRUCT;
-+ av_dict_set(&(s->ff_opts), "structured_slices", "1", 0);
- /*
- c->flags|=CODEC_FLAG_OBMC;
- c->flags|=CODEC_FLAG_AC_PRED;
-@@ -342,9 +343,9 @@ static void enc_preprocess(MSFilter *f){
- ms_error("could not find encoder for codec id %i",s->codec);
- return;
- }
-- error=avcodec_open(&s->av_context, s->av_codec);
-+ error=avcodec_open2(&s->av_context, s->av_codec, &(s->ff_opts));
- if (error!=0) {
-- ms_error("avcodec_open() failed: %i",error);
-+ ms_error("avcodec_open2() failed: %i",error);
- return;
- }
- video_starter_init(&s->starter);
-@@ -372,7 +373,7 @@ static void add_rfc2190_header(mblk_t **
- // assume video size is CIF or QCIF
- if (context->width == 352 && context->height == 288) header->b_wptr[1] = 0x60;
- else header->b_wptr[1] = 0x40;
-- if (context->coded_frame->pict_type != FF_I_TYPE) header->b_wptr[1] |= 0x10;
-+ if (context->coded_frame->pict_type != AV_PICTURE_TYPE_I) header->b_wptr[1] |= 0x10;
- header->b_wptr += 4;
- header->b_cont = *packet;
- *packet = header;
-@@ -779,7 +780,7 @@ static void process_frame(MSFilter *f, m
- s->req_vfu=TRUE;
- }
- if (s->req_vfu){
-- pict.pict_type=FF_I_TYPE;
-+ pict.pict_type=AV_PICTURE_TYPE_I;
- s->req_vfu=FALSE;
- }
- comp_buf->b_rptr=comp_buf->b_wptr=comp_buf->b_datap->db_base;
-@@ -799,7 +800,7 @@ static void process_frame(MSFilter *f, m
- if (s->framenum==1){
- video_starter_first_frame (&s->starter,f->ticker->time);
- }
-- if (c->coded_frame->pict_type==FF_I_TYPE){
-+ if (c->coded_frame->pict_type==AV_PICTURE_TYPE_I){
- ms_message("Emitting I-frame");
- }
- comp_buf->b_wptr+=error;
-Index: mediastreamer-2.7.3/src/h264dec.c
-===================================================================
---- mediastreamer-2.7.3.orig/src/h264dec.c
-+++ mediastreamer-2.7.3/src/h264dec.c
-@@ -46,7 +46,6 @@ typedef struct _DecData{
- static void ffmpeg_init(){
- static bool_t done=FALSE;
- if (!done){
-- avcodec_init();
- avcodec_register_all();
- done=TRUE;
- }
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.7.3-sdl-build.patch b/media-libs/mediastreamer/files/mediastreamer-2.7.3-sdl-build.patch
deleted file mode 100644
index 2f7207e27ab0..000000000000
--- a/media-libs/mediastreamer/files/mediastreamer-2.7.3-sdl-build.patch
+++ /dev/null
@@ -1,220 +0,0 @@
-commit c0ae6c3f9f78ae9e9e4c7030e7054dc5c0267e2c
-Author: Simon Morlat <simon.morlat@linphone.org>
-Date: Mon Apr 11 22:46:37 2011 +0200
-
- fix SDL output that wasn't compiling anymore and bugfix videodisplay test program
-
-diff --git a/src/msfilter.c b/src/msfilter.c
-index d8d84f3..4b84b8b 100644
---- a/src/msfilter.c
-+++ b/src/msfilter.c
-@@ -169,9 +169,7 @@ int ms_filter_link(MSFilter *f1, int pin1, MSFilter *f2, int pin2){
-
- int ms_filter_unlink(MSFilter *f1, int pin1, MSFilter *f2, int pin2){
- MSQueue *q;
-- ms_return_val_if_fail(f1, -1);
-- ms_return_val_if_fail(f2, -1);
-- ms_message("ms_filter_unlink: %s:%p,%i-->%s:%p,%i",f1->desc->name,f1,pin1,f2->desc->name,f2,pin2);
-+ ms_message("ms_filter_unlink: %s:%p,%i-->%s:%p,%i",f1 ? f1->desc->name : "!NULL!",f1,pin1,f2 ? f2->desc->name : "!NULL!",f2,pin2);
- ms_return_val_if_fail(pin1<f1->desc->noutputs, -1);
- ms_return_val_if_fail(pin2<f2->desc->ninputs, -1);
- ms_return_val_if_fail(f1->outputs[pin1]!=NULL,-1);
-diff --git a/src/videoout.c b/src/videoout.c
-index ca36b0f..5bdc6dd 100644
---- a/src/videoout.c
-+++ b/src/videoout.c
-@@ -114,8 +114,6 @@ void ms_display_destroy(MSDisplay *d);
- }
- #endif
-
--#include "ffmpeg-priv.h"
--
- #define SCALE_FACTOR 4.0f
- #define SELVIEW_POS_INACTIVE -100.0
-
-@@ -462,7 +460,7 @@ void ms_display_desc_set_default_window_id(MSDisplayDesc *desc, long id){
-
- typedef struct VideoOut
- {
-- AVRational ratio;
-+ struct Rational {int num; int den;} ratio;
- MSPicture fbuf;
- MSPicture fbuf_selfview;
- MSPicture local_pic;
-@@ -474,8 +472,8 @@ typedef struct VideoOut
- float sv_posx,sv_posy;
- int background_color[3];
-
-- struct ms_SwsContext *sws1;
-- struct ms_SwsContext *sws2;
-+ MSScalerContext *sws1;
-+ MSScalerContext *sws2;
- MSDisplay *display;
- bool_t own_display;
- bool_t ready;
-@@ -552,11 +550,11 @@ static void video_out_uninit(MSFilter *f){
- if (obj->display!=NULL && obj->own_display)
- ms_display_destroy(obj->display);
- if (obj->sws1!=NULL){
-- ms_sws_freeContext(obj->sws1);
-+ ms_scaler_context_free(obj->sws1);
- obj->sws1=NULL;
- }
- if (obj->sws2!=NULL){
-- ms_sws_freeContext(obj->sws2);
-+ ms_scaler_context_free(obj->sws2);
- obj->sws2=NULL;
- }
- if (obj->local_msg!=NULL) {
-@@ -581,11 +579,11 @@ static void video_out_prepare(MSFilter *f){
- obj->display=NULL;
- }
- if (obj->sws1!=NULL){
-- ms_sws_freeContext(obj->sws1);
-+ ms_scaler_context_free(obj->sws1);
- obj->sws1=NULL;
- }
- if (obj->sws2!=NULL){
-- ms_sws_freeContext(obj->sws2);
-+ ms_scaler_context_free(obj->sws2);
- obj->sws2=NULL;
- }
- if (obj->local_msg!=NULL) {
-@@ -665,13 +663,12 @@ static void video_out_process(MSFilter *f){
- if (ms_yuv_buf_init_from_mblk(&src,inm)==0){
-
- if (obj->sws2==NULL){
-- obj->sws2=ms_sws_getContext(src.w,src.h,PIX_FMT_YUV420P,
-- obj->fbuf_selfview.w,obj->fbuf_selfview.h,PIX_FMT_YUV420P,
-- SWS_FAST_BILINEAR, NULL, NULL, NULL);
-+ obj->sws2=ms_scaler_create_context(src.w,src.h,MS_YUV420P,
-+ obj->fbuf_selfview.w,obj->fbuf_selfview.h,MS_YUV420P,
-+ MS_SCALER_METHOD_BILINEAR);
- }
- ms_display_lock(obj->display);
-- if (ms_sws_scale(obj->sws2,src.planes,src.strides, 0,
-- src.h, obj->fbuf_selfview.planes, obj->fbuf_selfview.strides)<0){
-+ if (ms_scaler_process(obj->sws2,src.planes,src.strides,obj->fbuf_selfview.planes, obj->fbuf_selfview.strides)<0){
- ms_error("Error in ms_sws_scale().");
- }
- if (!mblk_get_precious_flag(inm)) ms_yuv_buf_mirror(&obj->fbuf_selfview);
-@@ -683,9 +680,9 @@ static void video_out_process(MSFilter *f){
- if (ms_yuv_buf_init_from_mblk(&src,inm)==0){
-
- if (obj->sws2==NULL){
-- obj->sws2=ms_sws_getContext(src.w,src.h,PIX_FMT_YUV420P,
-- obj->local_pic.w,obj->local_pic.h,PIX_FMT_YUV420P,
-- SWS_FAST_BILINEAR, NULL, NULL, NULL);
-+ obj->sws2=ms_scaler_create_context(src.w,src.h,MS_YUV420P,
-+ obj->local_pic.w,obj->local_pic.h,MS_YUV420P,
-+ MS_SCALER_METHOD_BILINEAR);
- }
- if (obj->local_msg==NULL){
- obj->local_msg=ms_yuv_buf_alloc(&obj->local_pic,
-@@ -693,8 +690,7 @@ static void video_out_process(MSFilter *f){
- }
- if (obj->local_pic.planes[0]!=NULL)
- {
-- if (ms_sws_scale(obj->sws2,src.planes,src.strides, 0,
-- src.h, obj->local_pic.planes, obj->local_pic.strides)<0){
-+ if (ms_scaler_process(obj->sws2,src.planes,src.strides,obj->local_pic.planes, obj->local_pic.strides)<0){
- ms_error("Error in ms_sws_scale().");
- }
- if (!mblk_get_precious_flag(inm)) ms_yuv_buf_mirror(&obj->local_pic);
-@@ -731,13 +727,12 @@ static void video_out_process(MSFilter *f){
- }
- }
- if (obj->sws1==NULL){
-- obj->sws1=ms_sws_getContext(src.w,src.h,PIX_FMT_YUV420P,
-- obj->fbuf.w,obj->fbuf.h,PIX_FMT_YUV420P,
-- SWS_FAST_BILINEAR, NULL, NULL, NULL);
-+ obj->sws1=ms_scaler_create_context(src.w,src.h,MS_YUV420P,
-+ obj->fbuf.w,obj->fbuf.h,MS_YUV420P,
-+ MS_SCALER_METHOD_BILINEAR);
- }
- ms_display_lock(obj->display);
-- if (ms_sws_scale(obj->sws1,src.planes,src.strides, 0,
-- src.h, obj->fbuf.planes, obj->fbuf.strides)<0){
-+ if (ms_scaler_process(obj->sws1,src.planes,src.strides,obj->fbuf.planes, obj->fbuf.strides)<0){
- ms_error("Error in ms_sws_scale().");
- }
- if (obj->mirror && !mblk_get_precious_flag(inm)) ms_yuv_buf_mirror(&obj->fbuf);
-@@ -943,3 +938,4 @@ MSFilterDesc ms_video_out_desc={
-
-
- MS_FILTER_DESC_EXPORT(ms_video_out_desc)
-+
-diff --git a/tests/videodisplay.c b/tests/videodisplay.c
-index 76f67a5..0828c6a 100644
---- a/tests/videodisplay.c
-+++ b/tests/videodisplay.c
-@@ -52,6 +52,7 @@ int main(int argc, char *argv[]){
- for(i=0;i<1;++i){
- int n;
- vs=video_preview_new();
-+ /*video_preview_set_display_filter_name(vs,"MSVideoOut");*/
- video_preview_set_size(vs,vsize);
- video_preview_start(vs, cam);
-
-@@ -79,11 +80,11 @@ int main(int argc, char *argv[]){
-
- vs->tee = ms_filter_new(MS_TEE_ID);
-
-- ms_filter_unlink(vs->pixconv,0, vs->output,0);
-+ ms_filter_unlink(vs->pixconv,0, vs->output2,0);
-
- ms_filter_link(vs->pixconv,0,vs->tee,0);
-- ms_filter_link(vs->tee,0,vs->output,0);
-- ms_filter_link(vs->tee,1,vs->output,1);
-+ ms_filter_link(vs->tee,0,vs->output2,0);
-+ ms_filter_link(vs->tee,1,vs->output2,1);
-
- //ms_filter_unlink(vs->tee,0,vs->output,0);
- ms_ticker_attach (vs->ticker, vs->source);
-@@ -92,34 +93,34 @@ int main(int argc, char *argv[]){
- if (n==500)
- {
- int corner=1;
-- ms_filter_call_method(vs->output,MS_VIDEO_DISPLAY_SET_LOCAL_VIEW_MODE,&corner);
-+ ms_filter_call_method(vs->output2,MS_VIDEO_DISPLAY_SET_LOCAL_VIEW_MODE,&corner);
- }
- if (n==600)
- {
- int corner=2;
-- ms_filter_call_method(vs->output,MS_VIDEO_DISPLAY_SET_LOCAL_VIEW_MODE,&corner);
-+ ms_filter_call_method(vs->output2,MS_VIDEO_DISPLAY_SET_LOCAL_VIEW_MODE,&corner);
- }
- if (n==700)
- {
- int corner=3;
-- ms_filter_call_method(vs->output,MS_VIDEO_DISPLAY_SET_LOCAL_VIEW_MODE,&corner);
-+ ms_filter_call_method(vs->output2,MS_VIDEO_DISPLAY_SET_LOCAL_VIEW_MODE,&corner);
- }
- if (n==800)
- {
- int corner=-1;
-- ms_filter_call_method(vs->output,MS_VIDEO_DISPLAY_SET_LOCAL_VIEW_MODE,&corner);
-+ ms_filter_call_method(vs->output2,MS_VIDEO_DISPLAY_SET_LOCAL_VIEW_MODE,&corner);
- }
- if (n==900)
- {
- ms_ticker_detach (vs->ticker, vs->source);
-
- ms_filter_unlink(vs->pixconv,0,vs->tee,0);
-- ms_filter_unlink(vs->tee,0,vs->output,0);
-- ms_filter_unlink(vs->tee,1,vs->output,1);
-+ ms_filter_unlink(vs->tee,0,vs->output2,0);
-+ ms_filter_unlink(vs->tee,1,vs->output2,1);
- ms_filter_destroy(vs->tee);
- vs->tee=NULL;
-
-- ms_filter_link(vs->pixconv,0, vs->output,0);
-+ ms_filter_link(vs->pixconv,0, vs->output2,0);
-
-
- ms_ticker_attach (vs->ticker, vs->source);
-@@ -129,3 +130,4 @@ int main(int argc, char *argv[]){
- }
- return 0;
- }
-+
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.7.3-v4l-automagic.patch b/media-libs/mediastreamer/files/mediastreamer-2.7.3-v4l-automagic.patch
deleted file mode 100644
index d103a07fd9af..000000000000
--- a/media-libs/mediastreamer/files/mediastreamer-2.7.3-v4l-automagic.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-=== modified file 'configure.ac'
---- configure.ac 2011-04-09 08:17:33 +0000
-+++ configure.ac 2011-04-09 08:31:18 +0000
-@@ -590,6 +590,15 @@
- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${package_prefix}/share" ,[path of data])
- AC_SUBST(PACKAGE_DATA_DIR)
-
-+AC_ARG_ENABLE(v4l,
-+ [ --disable-v4l Disable usage of v4l],
-+ [case "${enableval}" in
-+ yes) v4l=yes ;;
-+ no) v4l=no ;;
-+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-v4l) ;;
-+ esac],[v4l=yes])
-+
-+if test "$v4l" = "yes" ; then
- dnl check for video4linux headers
- AC_CHECK_HEADERS(linux/videodev.h linux/videodev2.h)
- if test "${ac_cv_header_linux_videodev_h}" = "yes" || \
-@@ -599,8 +608,6 @@
- found_v4l=no
- fi
-
--AM_CONDITIONAL(BUILD_V4L, test x$found_v4l = xyes )
--
- AC_ARG_ENABLE(libv4l,
- [ --disable-libv4l Disable usage of libv4l, really discouraged],
- [case "${enableval}" in
-@@ -632,6 +639,10 @@
- ])
- fi
- fi
-+fi
-+
-+AM_CONDITIONAL(BUILD_V4L, test x$found_v4l = xyes )
-+
-
- dnl ##################################################
- dnl # Check for doxygen
-
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.7.3-videoenc_282.patch b/media-libs/mediastreamer/files/mediastreamer-2.7.3-videoenc_282.patch
deleted file mode 100644
index 66d055ede084..000000000000
--- a/media-libs/mediastreamer/files/mediastreamer-2.7.3-videoenc_282.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-Update videoenc.c to the 2.8.2 version. Fixes some but not all problems with
-ffmpeg.
-
-
---- mediastreamer-2.7.3/src/videoenc.c 2010-12-17 05:59:50.000000000 -0300
-+++ mediastreamer-2.8.2/src/videoenc.c 2012-02-17 06:16:20.000000000 -0300
-@@ -164,6 +164,7 @@
- }else{
- ms_warning("unsupported video size %s",tmp);
- ret=FALSE;
-+ goto end;
- }
- divider=atoi(equal+1);
- if (divider!=0){
-@@ -174,6 +175,8 @@
- ret=FALSE;
- }
- }else ret=FALSE;
-+
-+end:
- ms_free(tmp);
- return ret;
- }
-@@ -231,11 +234,7 @@
-
- static void prepare(EncState *s){
- AVCodecContext *c=&s->av_context;
--#ifdef ANDROID
- const int max_br_vbv=128000;
--#else
-- const int max_br_vbv=256000;
--#endif
-
- avcodec_get_context_defaults(c);
- if (s->codec==CODEC_ID_MJPEG)
-@@ -315,13 +314,6 @@
- static void prepare_mpeg4(EncState *s){
- AVCodecContext *c=&s->av_context;
- c->max_b_frames=0; /*don't use b frames*/
-- c->flags|=CODEC_FLAG_AC_PRED;
-- c->flags|=CODEC_FLAG_H263P_UMV;
-- /*c->flags|=CODEC_FLAG_QPEL;*/ /*don't enable this one: this forces profile_level to advanced simple profile */
-- c->flags|=CODEC_FLAG_4MV;
-- c->flags|=CODEC_FLAG_GMC;
-- c->flags|=CODEC_FLAG_LOOP_FILTER;
-- c->flags|=CODEC_FLAG_H263P_SLICE_STRUCT;
- }
-
- static void enc_uninit(MSFilter *f){
-@@ -681,7 +673,7 @@
- uint8_t *pbuf_ptr=full_frame->b_rptr;
- uint8_t *buf_end=full_frame->b_wptr;
-
-- ms_message("image size: %i)", buf_end-pbuf_ptr);
-+ ms_message("image size: %li)", (long)(buf_end-pbuf_ptr));
-
- *lqt=NULL;
- *cqt=NULL;
-@@ -689,7 +681,7 @@
- err = find_marker(&pbuf_ptr, buf_end);
- while (err!=-1)
- {
-- ms_message("marker found: %x (offset from beginning%i)", err, pbuf_ptr-full_frame->b_rptr);
-+ ms_message("marker found: %x (offset from beginning %li)", err, (long)(pbuf_ptr-full_frame->b_rptr));
- if (err==0xdb)
- {
- /* copy DQT table */
-@@ -772,10 +764,12 @@
- int error;
- mblk_t *comp_buf=s->comp_buf;
- int comp_buf_sz=comp_buf->b_datap->db_lim-comp_buf->b_datap->db_base;
-+ YuvBuf yuv;
-
-+ ms_yuv_buf_init_from_mblk(&yuv, inm);
- /* convert image if necessary */
- avcodec_get_frame_defaults(&pict);
-- avpicture_fill((AVPicture*)&pict,(uint8_t*)inm->b_rptr,c->pix_fmt,c->width,c->height);
-+ avpicture_fill((AVPicture*)&pict,yuv.planes[0],c->pix_fmt,c->width,c->height);
-
- /* timestamp used by ffmpeg, unset here */
- pict.pts=AV_NOPTS_VALUE;
-@@ -796,7 +790,9 @@
- comp_buf->b_wptr+=4;
- comp_buf_sz-=4;
- }
-+
- error=avcodec_encode_video(c, (uint8_t*)comp_buf->b_wptr,comp_buf_sz, &pict);
-+
- if (error<=0) ms_warning("ms_AVencoder_process: error %i.",error);
- else{
- s->framenum++;
-@@ -837,6 +833,14 @@
- EncState *s=(EncState*)f->data;
- bool_t snow=s->codec==CODEC_ID_SNOW;
- s->maxbr=*(int*)arg;
-+ if (s->av_context.codec!=NULL){
-+ /*when we are processing, apply new settings immediately*/
-+ ms_filter_lock(f);
-+ enc_postprocess(f);
-+ enc_preprocess(f);
-+ ms_filter_unlock(f);
-+ return 0;
-+ }
- if (s->maxbr>=1024000 && s->codec!=CODEC_ID_H263P){
- s->vsize.width = MS_VIDEO_SIZE_SVGA_W;
- s->vsize.height = MS_VIDEO_SIZE_SVGA_H;
-@@ -854,7 +858,7 @@
- s->vsize.height=MS_VIDEO_SIZE_CIF_H;
- s->fps=17;
- s->qmin=3;
-- }else if (s->maxbr>=170000){
-+ }else if (s->maxbr>=170000 && s->codec!=CODEC_ID_H263P && s->codec!=CODEC_ID_H263){
- s->vsize.width=MS_VIDEO_SIZE_QVGA_W;
- s->vsize.height=MS_VIDEO_SIZE_QVGA_H;
- s->fps=15;
-@@ -875,14 +879,6 @@
- s->fps=5;
- s->qmin=5;
- }
--
-- if (s->av_context.codec!=NULL){
-- /*apply new settings dynamically*/
-- ms_filter_lock(f);
-- enc_postprocess(f);
-- enc_preprocess(f);
-- ms_filter_unlock(f);
-- }
- return 0;
- }
-
diff --git a/media-libs/mediastreamer/mediastreamer-2.7.3-r3.ebuild b/media-libs/mediastreamer/mediastreamer-2.7.3-r3.ebuild
deleted file mode 100644
index 24f960f98802..000000000000
--- a/media-libs/mediastreamer/mediastreamer-2.7.3-r3.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils autotools multilib
-
-DESCRIPTION="Mediastreaming library for telephony application"
-HOMEPAGE="http://www.linphone.org/"
-SRC_URI="mirror://nongnu/linphone/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~x64-macos ~x86-macos"
-# Many cameras will not work or will crash an application if mediastreamer2 is
-# not built with v4l2 support (taken from configure.ac)
-# TODO: run-time test for ipv6: does it really need ortp[ipv6] ?
-IUSE="+alsa amr bindist coreaudio debug examples gsm ilbc ipv6 jack oss portaudio
-pulseaudio sdl +speex static-libs theora v4l video x264 X"
-REQUIRED_USE="|| ( oss alsa jack portaudio coreaudio pulseaudio )
- video? ( || ( sdl X ) )
- theora? ( video )
- X? ( video )
- v4l? ( video )"
-
-RDEPEND=">=net-libs/ortp-0.16.2[ipv6?]
- alsa? ( media-libs/alsa-lib )
- gsm? ( media-sound/gsm )
- jack? ( >=media-libs/libsamplerate-0.0.13
- media-sound/jack-audio-connection-kit )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( >=media-sound/pulseaudio-0.9.21 )
- speex? ( >=media-libs/speex-1.2_beta3 )
- video? (
- virtual/ffmpeg
- v4l? ( media-libs/libv4l
- sys-kernel/linux-headers )
- theora? ( media-libs/libtheora )
- sdl? ( media-libs/libsdl[video,X] )
- X? ( x11-libs/libX11
- x11-libs/libXv ) )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-proto/videoproto"
-
-PDEPEND="amr? ( !bindist? ( media-plugins/mediastreamer-amr ) )
- ilbc? ( media-plugins/mediastreamer-ilbc )
- video? ( x264? ( media-plugins/mediastreamer-x264 ) )"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
-
-src_prepare() {
- # respect user's CFLAGS
- sed -i -e "s:-O2::;s: -g::" configure.ac || die "patching configure.ac failed"
-
- # change default paths
- sed -i -e "s:\(\${prefix}/\)lib:\1$(get_libdir):" \
- -e "s:\(prefix/share\):\1/${PN}:" configure.ac \
- || die "patching configure.ac failed"
-
- # fix html doc installation dir
- sed -i -e "s:\$(pkgdocdir):\$(docdir):" help/Makefile.am \
- || die "patching help/Makefile.am failed"
- sed -i -e "s:\(doc_htmldir=\).*:\1\$(htmldir):" help/Makefile.am \
- || die "patching help/Makefile.am failed"
-
- epatch "${FILESDIR}/${PN}-2.7.3-v4l-automagic.patch"
- epatch "${FILESDIR}/${P}-sdl-build.patch"
- epatch "${FILESDIR}/${P}-videoenc_282.patch"
- epatch "${FILESDIR}/${P}-ffmpeg-0.11.patch"
-
- # linux/videodev.h dropped in 2.6.38
- sed -i -e 's:msv4l.c::' src/Makefile.am || die
- sed -i -e 's:linux/videodev.h ::' configure.ac || die
- eautoreconf
-
- # don't build examples in tests/
- sed -i -e "s:\(SUBDIRS = .*\) tests \(.*\):\1 \2:" Makefile.in \
- || die "patching Makefile.in failed"
-}
-
-src_configure() {
- # Mac OS X Audio Queue is an audio recording facility, available on
- # 10.5 (Leopard, Darwin9) and onward
- local macaqsnd="--disable-macaqsnd"
- if use coreaudio && [[ ${CHOST} == *-darwin* && ${CHOST##*-darwin} -ge 9 ]];
- then
- macaqsnd="--enable-macaqsnd"
- fi
-
- # strict: don't want -Werror
- # external-ortp: don't use bundled libs
- # arts: arts is deprecated
- econf \
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
- --datadir="${EPREFIX}"/usr/share/${PN} \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --disable-strict \
- --enable-external-ortp \
- --disable-artsc \
- $(use_enable alsa) \
- $(use_enable pulseaudio) \
- $(use_enable coreaudio macsnd) ${macaqsnd} \
- $(use_enable debug) \
- $(use_enable gsm) \
- $(use_enable ipv6) \
- $(use_enable jack) \
- $(use_enable oss) \
- $(use_enable portaudio) \
- $(use_enable speex) \
- $(use_enable static-libs static) \
- $(use_enable theora) \
- $(use_enable video) \
- $(use_enable v4l) \
- $(use_enable v4l libv4l) \
- $(use_enable sdl) \
- $(use_enable X x11) \
- $(use_enable X xv)
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -exec rm -f {} +
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins tests/*.c
- fi
-}
diff --git a/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild b/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild
deleted file mode 100644
index 68ed29238df3..000000000000
--- a/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild
+++ /dev/null
@@ -1,171 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils
-
-DESCRIPTION="Mediastreaming library for telephony application"
-HOMEPAGE="http://www.linphone.org/"
-SRC_URI="mirror://nongnu/linphone/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/3"
-KEYWORDS="amd64 ppc ppc64 x86"
-# Many cameras will not work or will crash an application if mediastreamer2 is
-# not built with v4l2 support (taken from configure.ac)
-# TODO: run-time test for ipv6: does it really need ortp[ipv6] ?
-IUSE="+alsa amr bindist coreaudio debug doc examples +filters g726 g729 gsm ilbc
- ipv6 ntp-timestamp opengl opus +ortp oss pcap portaudio pulseaudio sdl silk +speex
- static-libs test theora upnp v4l video x264 X"
-
-REQUIRED_USE="|| ( oss alsa portaudio coreaudio pulseaudio )
- video? ( || ( opengl sdl X ) )
- theora? ( video )
- X? ( video )
- v4l? ( video )
- opengl? ( video )"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- g726? ( >=media-libs/spandsp-0.0.6_pre1 )
- gsm? ( media-sound/gsm )
- opus? ( media-libs/opus )
- ortp? ( >=net-libs/ortp-0.21.0[ipv6?] )
- pcap? ( sys-libs/libcap )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( >=media-sound/pulseaudio-0.9.21 )
- speex? ( >=media-libs/speex-1.2_beta3 )
- upnp? ( net-libs/libupnp )
- video? (
- virtual/ffmpeg
- opengl? ( media-libs/glew
- virtual/opengl
- x11-libs/libX11 )
- v4l? ( media-libs/libv4l
- sys-kernel/linux-headers )
- theora? ( media-libs/libtheora )
- sdl? ( media-libs/libsdl[video,X] )
- X? ( x11-libs/libX11
- x11-libs/libXv ) )"
-DEPEND="${RDEPEND}
- dev-util/intltool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- opengl? ( dev-util/xxdi )
- test? ( >=dev-util/cunit-2.1_p2[ncurses] )
- X? ( x11-proto/videoproto )"
-
-PDEPEND="amr? ( !bindist? ( media-plugins/mediastreamer-amr ) )
- g729? ( !bindist? ( media-plugins/mediastreamer-bcg729 ) )
- ilbc? ( media-plugins/mediastreamer-ilbc )
- video? ( x264? ( media-plugins/mediastreamer-x264 ) )
- silk? ( !bindist? ( media-plugins/mediastreamer-silk ) )"
-
-src_prepare() {
- # variable causes "command not found" warning and is not
- # needed anyway
- sed -i \
- -e 's/$(ACLOCAL_MACOS_FLAGS)//' \
- Makefile.am || die
-
- # respect user's CFLAGS
- sed -i \
- -e "s:-O2::;s: -g::" \
- configure.ac || die "patching configure.ac failed"
-
- # change default paths
- sed -i \
- -e "s:\(prefix/share\):\1/${PN}:" \
- configure.ac || die "patching configure.ac failed"
-
- # fix doc installation dir
- sed -i \
- -e "s:\$(pkgdocdir):\$(docdir):" \
- help/Makefile.am || die "patching help/Makefile.am failed"
-
- # fix html installation dir
- sed -i \
- -e "s:\(doc_htmldir=\).*:\1\$(htmldir):" \
- help/Makefile.am || die "patching help/Makefile.am failed"
-
- # linux/videodev.h dropped in 2.6.38
- sed -i \
- -e 's:linux/videodev.h ::' \
- configure.ac || die
-
- epatch "${FILESDIR}/${P}-v4l-automagic.patch" \
- "${FILESDIR}/${P}-libav9.patch" \
- "${FILESDIR}/${P}-underlinking.patch" \
- "${FILESDIR}/${P}-tests.patch" \
- "${FILESDIR}/${P}-xxd.patch"
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
- --datadir="${EPREFIX}"/usr/share/${PN}
- # arts is deprecated
- --disable-artsc
- # don't want -Werror
- --disable-strict
- --disable-libv4l1
- # don't use bundled libs
- --enable-external-ortp
- $(use_enable alsa)
- $(use_enable pulseaudio)
- $(use_enable coreaudio macsnd)
- $(use_enable debug)
- $(use_enable filters)
- $(use_enable g726 spandsp)
- $(use_enable gsm)
- $(use_enable ipv6)
- $(use_enable ntp-timestamp)
- $(use_enable opengl glx)
- $(use_enable opus)
- $(use_enable ortp)
- $(use_enable oss)
- $(use_enable pcap)
- $(use_enable portaudio)
- $(use_enable speex)
- $(use_enable static-libs static)
- $(use_enable theora)
- $(use_enable upnp)
- $(use_enable video)
- $(use_enable v4l)
- $(use_enable v4l libv4l2)
- $(use_enable sdl)
- $(use_enable X x11)
- $(use_enable X xv)
-
- $(use doc || echo ac_cv_path_DOXYGEN=false)
- )
-
- # Mac OS X Audio Queue is an audio recording facility, available on
- # 10.5 (Leopard, Darwin9) and onward
- if use coreaudio && [[ ${CHOST} == *-darwin* && ${CHOST##*-darwin} -ge 9 ]]
- then
- myeconfargs+=( --enable-macaqsnd )
- else
- myeconfargs+=( --disable-macaqsnd )
- fi
-
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- default
- cd tester || die
- ./mediastreamer2_tester || die
-}
-
-src_install() {
- default
- prune_libtool_files
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins tester/*.c
- fi
-}