summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-02-24 12:44:36 +0200
committerMart Raudsepp <leio@gentoo.org>2018-02-24 12:56:49 +0200
commit3df07552decade334030ee8b793e40a34a9a2688 (patch)
treee2a12ab75a262adc19b5753c8e4042954c1ead33 /media-libs/mesa
parentnet-libs/nodejs: Old. (diff)
downloadgentoo-3df07552decade334030ee8b793e40a34a9a2688.tar.gz
gentoo-3df07552decade334030ee8b793e40a34a9a2688.tar.bz2
gentoo-3df07552decade334030ee8b793e40a34a9a2688.zip
media-libs/mesa: depend on xdg-utils for USE=openmax to not break XDG specs
This is currently necessary due to the installation of 99mesaxdgomx with USE=openmax. Ideally we wouldn't depend on xdg-utils as a whole with its perl deps, but that's pending changed there. Unbreak things for the not so common case of mesa USE=openmax for the time being. Bug: https://bugs.gentoo.org/635040 Bug: https://bugs.gentoo.org/264647 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-17.1.10.ebuild7
-rw-r--r--media-libs/mesa/mesa-17.2.8.ebuild5
-rw-r--r--media-libs/mesa/mesa-17.3.5.ebuild5
-rw-r--r--media-libs/mesa/mesa-18.0.0_rc4.ebuild5
-rw-r--r--media-libs/mesa/mesa-9999.ebuild5
5 files changed, 21 insertions, 6 deletions
diff --git a/media-libs/mesa/mesa-17.1.10.ebuild b/media-libs/mesa/mesa-17.1.10.ebuild
index 1f6c50859094..68cc4007b978 100644
--- a/media-libs/mesa/mesa-17.1.10.ebuild
+++ b/media-libs/mesa/mesa-17.1.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -113,7 +113,10 @@ RDEPEND="
dev-libs/libclc
virtual/libelf:0=[${MULTILIB_USEDEP}]
)
- openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
+ openmax? (
+ >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}]
+ x11-misc/xdg-utils
+ )
vaapi? (
>=x11-libs/libva-1.7.3:=[${MULTILIB_USEDEP}]
video_cards_nouveau? ( !<=x11-libs/libva-vdpau-driver-0.7.4-r3 )
diff --git a/media-libs/mesa/mesa-17.2.8.ebuild b/media-libs/mesa/mesa-17.2.8.ebuild
index dc6df51c7224..0e1c9e9c9f4a 100644
--- a/media-libs/mesa/mesa-17.2.8.ebuild
+++ b/media-libs/mesa/mesa-17.2.8.ebuild
@@ -111,7 +111,10 @@ RDEPEND="
dev-libs/libclc
virtual/libelf:0=[${MULTILIB_USEDEP}]
)
- openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
+ openmax? (
+ >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}]
+ x11-misc/xdg-utils
+ )
vaapi? (
>=x11-libs/libva-1.7.3:=[${MULTILIB_USEDEP}]
video_cards_nouveau? ( !<=x11-libs/libva-vdpau-driver-0.7.4-r3 )
diff --git a/media-libs/mesa/mesa-17.3.5.ebuild b/media-libs/mesa/mesa-17.3.5.ebuild
index bf3fa77a49cd..b0b6cdc11380 100644
--- a/media-libs/mesa/mesa-17.3.5.ebuild
+++ b/media-libs/mesa/mesa-17.3.5.ebuild
@@ -111,7 +111,10 @@ RDEPEND="
dev-libs/libclc
virtual/libelf:0=[${MULTILIB_USEDEP}]
)
- openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
+ openmax? (
+ >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}]
+ x11-misc/xdg-utils
+ )
vaapi? (
>=x11-libs/libva-1.7.3:=[${MULTILIB_USEDEP}]
video_cards_nouveau? ( !<=x11-libs/libva-vdpau-driver-0.7.4-r3 )
diff --git a/media-libs/mesa/mesa-18.0.0_rc4.ebuild b/media-libs/mesa/mesa-18.0.0_rc4.ebuild
index e2f425d49acd..eb358442541e 100644
--- a/media-libs/mesa/mesa-18.0.0_rc4.ebuild
+++ b/media-libs/mesa/mesa-18.0.0_rc4.ebuild
@@ -111,7 +111,10 @@ RDEPEND="
dev-libs/libclc
virtual/libelf:0=[${MULTILIB_USEDEP}]
)
- openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
+ openmax? (
+ >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}]
+ x11-misc/xdg-utils
+ )
vaapi? (
>=x11-libs/libva-1.7.3:=[${MULTILIB_USEDEP}]
video_cards_nouveau? ( !<=x11-libs/libva-vdpau-driver-0.7.4-r3 )
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index e2f425d49acd..eb358442541e 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -111,7 +111,10 @@ RDEPEND="
dev-libs/libclc
virtual/libelf:0=[${MULTILIB_USEDEP}]
)
- openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
+ openmax? (
+ >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}]
+ x11-misc/xdg-utils
+ )
vaapi? (
>=x11-libs/libva-1.7.3:=[${MULTILIB_USEDEP}]
video_cards_nouveau? ( !<=x11-libs/libva-vdpau-driver-0.7.4-r3 )