summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-08-30 09:44:52 -0700
committerMatt Turner <mattst88@gentoo.org>2018-08-30 10:49:40 -0700
commita630c85b702d55a873b2c61f50a715f537dcf07f (patch)
treef0c210a2e24c59792b1c590d241098bc8f55adbf /media-libs/mesa
parentx11-themes/numix-icon-theme: Initial import (diff)
downloadgentoo-a630c85b702d55a873b2c61f50a715f537dcf07f.tar.gz
gentoo-a630c85b702d55a873b2c61f50a715f537dcf07f.tar.bz2
gentoo-a630c85b702d55a873b2c61f50a715f537dcf07f.zip
media-libs/mesa: Allow USE=xa with VIDEO_CARDS=vmware
Closes: https://bugs.gentoo.org/664524
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 229179f667aa..dd53f7a46a23 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -281,8 +281,9 @@ pkg_pretend() {
if use xa; then
if ! use video_cards_freedreno &&
- ! use video_cards_nouveau; then
- ewarn "Ignoring USE=xa since VIDEO_CARDS does not contain freedreno or nouveau"
+ ! use video_cards_nouveau &&
+ ! use video_cards_vmware; then
+ ewarn "Ignoring USE=xa since VIDEO_CARDS does not contain freedreno, nouveau, or vmware"
fi
fi
@@ -387,7 +388,8 @@ multilib_src_configure() {
fi
if use video_cards_freedreno ||
- use video_cards_nouveau; then
+ use video_cards_nouveau ||
+ use video_cards_vmware; then
emesonargs+=($(meson_use xa gallium-xa))
else
emesonargs+=(-Dgallium-xa=false)