summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-17 11:05:51 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-28 15:15:12 +0200
commitae0bee46cc42b41d815f809178560a3d4729ea6b (patch)
tree15c851921406066a4377c8e12057f755173182b4 /media-libs/mesa
parentmedia-libs/mesa: Move clang dep for [opencl] to RDEP (diff)
downloadgentoo-ae0bee46cc42b41d815f809178560a3d4729ea6b.tar.gz
gentoo-ae0bee46cc42b41d815f809178560a3d4729ea6b.tar.bz2
gentoo-ae0bee46cc42b41d815f809178560a3d4729ea6b.zip
media-libs/mesa: Require LLVM 3.9.0+
Now that LLVM 3.9 is stable, the older versions are on the cleanup list and there is really no reason to create overcomplex dependencies to account for them. Furthermore, according to configure.ac all of the Radeon drivers & swrast require 3.9 anyway.
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 4aef2f2d5a80..495b5a5e0b61 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -143,22 +143,16 @@ RDEPEND="${RDEPEND}
RDEPEND="${RDEPEND}
llvm? (
video_cards_radeonsi? (
- vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
- || (
- sys-devel/llvm[llvm_targets_AMDGPU]
- sys-devel/llvm[video_cards_radeon]
- )
+ >=sys-devel/llvm-3.9.0[llvm_targets_AMDGPU(-)]
)
- >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
+ >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}]
)
opencl? (
- >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
- >=sys-devel/clang-3.6.0:=[${MULTILIB_USEDEP}]
+ >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}]
+ >=sys-devel/clang-3.9.0:=[${MULTILIB_USEDEP}]
)
"
-# FIXME: kill the sys-devel/llvm[video_cards_radeon] compat once
-# LLVM < 3.9 is out of the game
DEPEND="${RDEPEND}
${PYTHON_DEPS}
opencl? (