summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-04-27 22:57:37 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-04-27 22:58:46 +0100
commit3d10b959f86e43d9b1a79ade53f3c08ac5940e8a (patch)
treeac0478b4ca014d20d162ca6042182ba0dad3fd20 /media-libs/munt-mt32emu/munt-mt32emu-2.6.3.ebuild
parentmedia-sound/munt-mt32emu-alsadrv: Drop old 2.3.0 (diff)
downloadgentoo-3d10b959f86e43d9b1a79ade53f3c08ac5940e8a.tar.gz
gentoo-3d10b959f86e43d9b1a79ade53f3c08ac5940e8a.tar.bz2
gentoo-3d10b959f86e43d9b1a79ade53f3c08ac5940e8a.zip
media-libs/munt-mt32emu: Version bump to 2.6.3
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/munt-mt32emu/munt-mt32emu-2.6.3.ebuild')
-rw-r--r--media-libs/munt-mt32emu/munt-mt32emu-2.6.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/munt-mt32emu/munt-mt32emu-2.6.3.ebuild b/media-libs/munt-mt32emu/munt-mt32emu-2.6.3.ebuild
new file mode 100644
index 000000000000..4a07225533b4
--- /dev/null
+++ b/media-libs/munt-mt32emu/munt-mt32emu-2.6.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P="libmt32emu_${PV//./_}"
+DESCRIPTION="Library for emulating the Roland MT-32, CM-32L, CM-64 and LAPC-I"
+HOMEPAGE="https://github.com/munt/munt"
+SRC_URI="https://github.com/munt/munt/archive/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/munt-${MY_P}/mt32emu"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.1-docs.patch
+)
+
+src_configure() {
+ local libdir=${EPREFIX}/usr/$(get_libdir)
+
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="${libdir}"
+ -Dlibmt32emu_PKGCONFIG_INSTALL_PREFIX="${libdir}"
+ )
+
+ cmake_src_configure
+}