summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2016-10-22 18:22:17 +0100
committerDavid Seifert <soap@gentoo.org>2016-10-23 01:25:21 +0200
commit8e68c375c5637e926b7a16c2b3196ee7bf0cee38 (patch)
treeae800e96d2e6711e16c6d4cbb4f5c54dac0e40dd /media-libs/opensubdiv/files
parentmedia-libs/ptex: New package (diff)
downloadgentoo-8e68c375c5637e926b7a16c2b3196ee7bf0cee38.tar.gz
gentoo-8e68c375c5637e926b7a16c2b3196ee7bf0cee38.tar.bz2
gentoo-8e68c375c5637e926b7a16c2b3196ee7bf0cee38.zip
media-libs/opensubdiv: New package
OpenSubdiv is a set of open source libraries that implement high performance subdivision surface (subdiv) evaluation on massively parallel CPU and GPU architectures. This code path is optimized for drawing deforming surfaces with static topology at interactive framerates. OpenSubdiv is an API ready to be integrated into 3rd party digital content creation tools. It is not an application, nor a tool that can be used directly to create digital assets. Gentoo-Bug: 586380 Signed off by: Jonathan Scruggs (j.scruggs@gmail.com, irc: Dracwyrm) Signed off by: Adrian Grigo (agrigo2001@yahoo.com.au) Closes: https://github.com/gentoo/gentoo/pull/2531 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs/opensubdiv/files')
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch b/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch
new file mode 100644
index 000000000000..2ebb638e3838
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch
@@ -0,0 +1,34 @@
+diff -purN a/regression/CMakeLists.txt b/regression/CMakeLists.txt
+--- a/regression/CMakeLists.txt 2016-03-25 22:15:29.000000000 +0000
++++ b/regression/CMakeLists.txt 2016-06-05 14:09:19.202849569 +0100
+@@ -32,30 +32,4 @@ if (NOT NO_REGRESSION)
+
+ add_subdirectory(far_perf)
+
+- if(OPENGL_FOUND AND (GLEW_FOUND OR APPLE) AND GLFW_FOUND)
+- add_subdirectory(osd_regression)
+- else()
+- set(MISSING "")
+-
+- if (NOT OPENGL_FOUND)
+- list(APPEND MISSING OpenGL)
+- endif()
+-
+- if (NOT GLEW_FOUND)
+- list(APPEND MISSING glew)
+- endif()
+-
+- if (NOT GLFW_FOUND)
+- list(APPEND MISSING glfw)
+- endif()
+-
+- message(WARNING
+- "The following libraries could not be found : ${MISSING}. "
+- "The osd regression test will not be available. "
+- "If you have these libraries installed, please specify their "
+- "path to cmake (through the GLEW_LOCATION and GLFW_LOCATION "
+- "command line arguments or environment variables)."
+- )
+- endif()
+-
+ endif()