summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2016-05-27 14:56:37 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-05-28 15:41:48 +0000
commit8ad1b24dc129b22afce1d63a9e9a83daab0cf2ac (patch)
treecdc300d66e9a63dbcdbc7c007d0b6ba9a3943fa6 /media-libs/pyliblo
parentmedia-sound/klick: Initial ebuild. (diff)
downloadgentoo-8ad1b24dc129b22afce1d63a9e9a83daab0cf2ac.tar.gz
gentoo-8ad1b24dc129b22afce1d63a9e9a83daab0cf2ac.tar.bz2
gentoo-8ad1b24dc129b22afce1d63a9e9a83daab0cf2ac.zip
media-libs/pyliblo: Initial ebuild.
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1549 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-libs/pyliblo')
-rw-r--r--media-libs/pyliblo/Manifest1
-rw-r--r--media-libs/pyliblo/metadata.xml12
-rw-r--r--media-libs/pyliblo/pyliblo-0.10.0.ebuild22
3 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/pyliblo/Manifest b/media-libs/pyliblo/Manifest
new file mode 100644
index 000000000000..6496c02bbc23
--- /dev/null
+++ b/media-libs/pyliblo/Manifest
@@ -0,0 +1 @@
+DIST pyliblo-0.10.0.tar.gz 29702 SHA256 fc67f1950b827272b00f9f0dc4ed7113c0ccef0c1c09e9976dead40ebbf1798f SHA512 d2a3d47f6c52d310104256d33fbd5d652ae6bc8cde32c2d3b2f3f407b8a4aba99028e57cd466804d266f63468a6c792760f28a43dbabcfa3330e0a852ee4d4e3 WHIRLPOOL 4f22ac7559251fbf81c7a7cfc1e32f2f3dd981471cd15d7a0b308c3f528f3c53c5f174a3938906b48ce29d0bda8f2291a84fa4e74e069f6ab7dfd4cf5cd8297b
diff --git a/media-libs/pyliblo/metadata.xml b/media-libs/pyliblo/metadata.xml
new file mode 100644
index 000000000000..321269421243
--- /dev/null
+++ b/media-libs/pyliblo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Karl Linden</name>
+ <email>karl.j.linden@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-libs/pyliblo/pyliblo-0.10.0.ebuild b/media-libs/pyliblo/pyliblo-0.10.0.ebuild
new file mode 100644
index 000000000000..4e4ce82a74dc
--- /dev/null
+++ b/media-libs/pyliblo/pyliblo-0.10.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="A Python wrapper for the liblo OSC library"
+HOMEPAGE="http://das.nasophon.de/pyliblo"
+SRC_URI="http://das.nasophon.de/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=media-libs/liblo-0.27
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"