summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-15 00:52:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-06 23:20:59 +0200
commit64e49bf02c10178003bd87bd27ad303bd3e118da (patch)
tree2e5ce882384e0a1def2d495d5f9d497373832c62 /media-libs/qimageblitz
parentprofiles: Mask kde-plasma/plasma-sdk[plasmate] on arm (diff)
downloadgentoo-64e49bf02c10178003bd87bd27ad303bd3e118da.tar.gz
gentoo-64e49bf02c10178003bd87bd27ad303bd3e118da.tar.bz2
gentoo-64e49bf02c10178003bd87bd27ad303bd3e118da.zip
media-libs/qimageblitz: Add Qt5-based snapshot
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/qimageblitz')
-rw-r--r--media-libs/qimageblitz/Manifest1
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-gcc.patch16
-rw-r--r--media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild43
3 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/qimageblitz/Manifest b/media-libs/qimageblitz/Manifest
index c4e3a063d5bf..8b2de06d2e24 100644
--- a/media-libs/qimageblitz/Manifest
+++ b/media-libs/qimageblitz/Manifest
@@ -1 +1,2 @@
DIST qimageblitz-0.0.6.tar.bz2 57617 SHA256 9f102269dec50641440e23a449df215a0db9efef9a3969939d618c5e78a5010f SHA512 dbd506c01622824efdec69640eb95e737d7848fa15d33351084a6499ca2321d7bc08e080d1e443f8ab9015cd2967c10d9b5aa2f3c6eaa7558153821c46133af9 WHIRLPOOL e13f5c11e2094296af558de4e9054d3c5a162be5e40a0418c5a505e222fe749c8dac319defc25bc2a2b6a5238e5d1fefb966fd64198d43b6b8af99d608362b45
+DIST qimageblitz-0.0.6_p20131029.tar.xz 43428 SHA256 256e7b4d7cfb6f061c6957ebdc6066e3a7fbf1d62b9ced35dc9c5467e5551622 SHA512 2a32105aed52ea33fbd46702a2b7cdd9671efef9bb52209ede534abc95ac40dd9ae2bd22cf09b30a309337653c4a754c50ef3fe4ad0aad7d4ffd0b5994a85981 WHIRLPOOL fd1593c7f77a334be4189bc6c3bdf365dd54363023318f3e25b0dd1aa53231b8d915582352ca29da35dd8a0d30958d120dd67cd4aaf2c81af79eb0e8388776cd
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-gcc.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-gcc.patch
new file mode 100644
index 000000000000..922a26298351
--- /dev/null
+++ b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-gcc.patch
@@ -0,0 +1,16 @@
+--- a/blitz/CMakeLists.txt
++++ b/blitz/CMakeLists.txt
+@@ -31,12 +31,8 @@
+
+ if(HAVE_MMX)
+ if(NOT APPLE AND NOT WIN32)
++ enable_language(ASM)
+ set( blitz_LIB_SRCS ${blitz_LIB_SRCS} asm_scale.S )
+- add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/asm_scale.o
+- COMMAND ${CMAKE_C_COMPILER} -c ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S
+- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S )
+- set( blitz_LIB_EXTRA_SRCS ${CMAKE_CURRENT_BINARY_DIR}/asm_scale.o )
+- set(HAVE_EXTERNAL_ASM TRUE)
+ endif(NOT APPLE AND NOT WIN32)
+ endif(HAVE_MMX)
+ configure_file (config-processor.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-processor.h )
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
new file mode 100644
index 000000000000..edeaa2ce759c
--- /dev/null
+++ b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Graphical effect and filter library by KDE"
+HOMEPAGE="https://websvn.kde.org/trunk/kdesupport/qimageblitz/"
+SRC_URI="http://dev.gentoo.org/~asturm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+SLOT="0"
+IUSE="altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 debug qt5"
+
+DEPEND="
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-gcc.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT4_BUILD=$(usex !qt5)
+ -DHAVE_3DNOW=$(usex cpu_flags_x86_3dnow)
+ -DHAVE_MMX=$(usex cpu_flags_x86_mmx)
+ -DHAVE_SSE=$(usex cpu_flags_x86_sse)
+ -DHAVE_SSE2=$(usex cpu_flags_x86_sse2)
+ )
+ use ppc && mycmakeargs+=( -DHAVE_ALTIVEC=$(usex altivec) )
+
+ cmake-utils_src_configure
+}