summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-03-22 21:28:55 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-03-22 21:28:55 +0100
commitdb07893c7e7f4a8bbde34135874c6be39b1a5826 (patch)
treeff91358e67dfd3b4b801cafbd133c4e538be4637 /media-libs/quvi
parentpackage.mask: Masked sys-devel/autoconf:2.71 (diff)
downloadgentoo-db07893c7e7f4a8bbde34135874c6be39b1a5826.tar.gz
gentoo-db07893c7e7f4a8bbde34135874c6be39b1a5826.tar.bz2
gentoo-db07893c7e7f4a8bbde34135874c6be39b1a5826.zip
media-libs/quvi: Fixed build with >=sys-devel/autoconf-2.70
Closes: https://bugs.gentoo.org/777768 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/quvi')
-rw-r--r--media-libs/quvi/files/quvi-0.9.5-autoconf-2.70.patch13
-rw-r--r--media-libs/quvi/quvi-0.9.5.ebuild15
2 files changed, 23 insertions, 5 deletions
diff --git a/media-libs/quvi/files/quvi-0.9.5-autoconf-2.70.patch b/media-libs/quvi/files/quvi-0.9.5-autoconf-2.70.patch
new file mode 100644
index 000000000000..55d9854a7acb
--- /dev/null
+++ b/media-libs/quvi/files/quvi-0.9.5-autoconf-2.70.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/777768
+
+--- quvi-0.9.5/configure.ac
++++ quvi-0.9.5/configure.ac
+@@ -6,7 +6,7 @@
+ AC_INIT([quvi], m4_esyscmd([./gen-ver.sh -c | tr -d '\n']),
+ [http://quvi.sf.net/bugs/],[],[http://quvi.sf.net/])
+
+-AC_DEFINE_UNQUOTED([BUILD_OPTS], "$@",
++AC_DEFINE_UNQUOTED([BUILD_OPTS], "$*",
+ [Define to configure invocation command line options])
+
+ AC_CONFIG_SRCDIR([src/main.c])
diff --git a/media-libs/quvi/quvi-0.9.5.ebuild b/media-libs/quvi/quvi-0.9.5.ebuild
index a5e505fb63dd..1c6ddec915e6 100644
--- a/media-libs/quvi/quvi-0.9.5.ebuild
+++ b/media-libs/quvi/quvi-0.9.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,7 +27,10 @@ BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )"
-PATCHES=( "${FILESDIR}"/${PN}-0.9.1-automagic.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.1-automagic.patch
+ "${FILESDIR}"/${PN}-0.9.5-autoconf-2.70.patch #777768
+)
src_prepare() {
default
@@ -35,8 +38,10 @@ src_prepare() {
}
src_configure() {
- econf \
- --with-manual \
- $(use_enable json) \
+ local myeconfargs=(
+ --with-manual
+ $(use_enable json)
$(use_enable xml)
+ )
+ econf "${myeconfargs[@]}"
}