summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-04-24 20:47:45 +0200
committerJeroen Roovers <jer@gentoo.org>2017-04-24 20:58:35 +0200
commitbaac7ebc97dcaf1f3df4a7b9d44aba497f425be3 (patch)
treeea8dacc9fad0eb8b0ac732d4721e54c4ee7209db /media-libs/resid
parentdev-db/redis: remove proxy-maint from the metadata, no proxied maintainer (diff)
downloadgentoo-baac7ebc97dcaf1f3df4a7b9d44aba497f425be3.tar.gz
gentoo-baac7ebc97dcaf1f3df4a7b9d44aba497f425be3.tar.bz2
gentoo-baac7ebc97dcaf1f3df4a7b9d44aba497f425be3.zip
media-libs/resid: Add multilib support.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-libs/resid')
-rw-r--r--media-libs/resid/resid-0.16_p2-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/resid/resid-0.16_p2-r1.ebuild b/media-libs/resid/resid-0.16_p2-r1.ebuild
new file mode 100644
index 000000000000..aff86979f431
--- /dev/null
+++ b/media-libs/resid/resid-0.16_p2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils multilib-minimal versionator
+
+MY_MAJ=$(get_version_component_range 1-2)
+
+DESCRIPTION="C++ library to emulate the C64 SID chip"
+HOMEPAGE="http://sidplay2.sourceforge.net"
+SRC_URI="mirror://sourceforge/sidplay2/${P/_p/-p}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+S=${WORKDIR}/${PN}-${MY_MAJ}
+
+DOCS=(
+ AUTHORS ChangeLog NEWS README THANKS TODO VC_CC_SUPPORT.txt
+)
+
+src_prepare() {
+ default
+
+ # This is required, otherwise the shared libraries get installed as
+ # libresid.0.0.0 instead of libresid.so.0.0.0.
+ eautoreconf
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-dependency-tracking \
+ --enable-resid-install \
+ --enable-shared
+}
+
+multilib_src_install() {
+ default
+
+ prune_libtool_files
+}