summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-02 10:00:25 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-02 10:00:52 +0100
commitc9996364e0fc6014365fcc138d13737603915610 (patch)
treec1c7dc4fa2c5e9d490a4fd2b7b9ef3ca0377b8b2 /media-libs/rply
parentmedia-gfx/krita: revision bump adapts to upstream build system changes (diff)
downloadgentoo-c9996364e0fc6014365fcc138d13737603915610.tar.gz
gentoo-c9996364e0fc6014365fcc138d13737603915610.tar.bz2
gentoo-c9996364e0fc6014365fcc138d13737603915610.zip
media-libs/rply: EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/rply')
-rw-r--r--media-libs/rply/rply-1.01-r1.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/media-libs/rply/rply-1.01-r1.ebuild b/media-libs/rply/rply-1.01-r1.ebuild
index f29daf7d1ed4..5bfefd584150 100644
--- a/media-libs/rply/rply-1.01-r1.ebuild
+++ b/media-libs/rply/rply-1.01-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=6
-inherit cmake-utils eutils
+inherit cmake-utils
DESCRIPTION="A library to read and write PLY files"
HOMEPAGE="http://w3.impa.br/~diego/software/rply/"
@@ -20,6 +20,13 @@ IUSE="doc"
DEPEND=""
RDEPEND="${DEPEND}"
+PATCHES=(
+ # Use int16_t and int32_t instead of assuming e.g. that sizeof(long) == 4
+ "${FILESDIR}/${P}-stdint.h.patch"
+ # Switch LC_NUMERIC locale to "C" to ensure "." is the decimal separator
+ "${FILESDIR}/${P}-lc_numeric.patch"
+)
+
pkg_setup() {
use doc && HTML_DOCS="manual/*"
}
@@ -27,12 +34,8 @@ pkg_setup() {
src_prepare() {
# rply doesn't have *any* build system - not even a Makefile!
# For simplicity, use the cmake file that Fedora maintainers have created
- cp "${FILESDIR}/rply_CMakeLists.txt" CMakeLists.txt
- mkdir -p CMake/export
+ cp "${FILESDIR}/rply_CMakeLists.txt" CMakeLists.txt || die
+ mkdir -p CMake/export || die
- # Use int16_t and int32_t instead of assuming e.g. that sizeof(long) == 4
- epatch "${FILESDIR}/${P}-stdint.h.patch"
-
- # Switch LC_NUMERIC locale to "C" to ensure "." is the decimal separator
- epatch "${FILESDIR}/${P}-lc_numeric.patch"
+ cmake-utils_src_prepare
}