summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-05-22 15:30:56 -0700
committerMatt Turner <mattst88@gentoo.org>2017-05-22 15:32:13 -0700
commit028c50a850c742179f8a5bd143f3acdb8e876a0f (patch)
tree992e92ec5a88143aa88ac22d419f8be4e4f830c5 /media-libs
parentmedia-libs/libepoxy: Drop empty KEYWORDS assignment (diff)
downloadgentoo-028c50a850c742179f8a5bd143f3acdb8e876a0f.tar.gz
gentoo-028c50a850c742179f8a5bd143f3acdb8e876a0f.tar.bz2
gentoo-028c50a850c742179f8a5bd143f3acdb8e876a0f.zip
media-libs/libepoxy: Version bump to 1.4.2
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libepoxy/Manifest1
-rw-r--r--media-libs/libepoxy/libepoxy-1.4.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/libepoxy/Manifest b/media-libs/libepoxy/Manifest
index 202b3f512b82..8d22cf3d00a7 100644
--- a/media-libs/libepoxy/Manifest
+++ b/media-libs/libepoxy/Manifest
@@ -1 +1,2 @@
DIST libepoxy-1.4.1.tar.gz 309759 SHA256 da8f42c355b62c2c3ff6bc534c2a24099707b249c2af6eaf8db54b94c364a504 SHA512 6656df4d447bd581b7701931070e03accb5b105426248f2b3360ba59bf50e09ce8be4c9691904b517b92fbfe241f8f3f435de116ca77ea2a0ecf1c121fb24a11 WHIRLPOOL c44047342a43306fa72fe6e4b21142064a42e6d1b079a386d929f3b9244e3cd664bf406cb98f8cb68a508b363f9c8a794b4f6f98a4bf82ffa739b4be00401b2f
+DIST libepoxy-1.4.2.tar.gz 309973 SHA256 61613b2cdc0167917229aa308d6eab2473f0408f84f3ccbd77d8677b42e89e39 SHA512 b94e1fe749c63a82f38369ff62b7d0d8cf1c55884159f030dc2919c17daf5811dd71cfd6a663edb38df66ff4ca53120a6a53501568cc8a582f08d4ae82fe9d89 WHIRLPOOL 83a6519ccc46126038b14a51eef36663dcf434f094685bca5e7a55f539d8ab2502eeab44d1471d8ecb1fe09156ccf04b0f9c7dc005c824feebe46ae342df4714
diff --git a/media-libs/libepoxy/libepoxy-1.4.2.ebuild b/media-libs/libepoxy/libepoxy-1.4.2.ebuild
new file mode 100644
index 000000000000..e68473e91a59
--- /dev/null
+++ b/media-libs/libepoxy/libepoxy-1.4.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="git://github.com/anholt/libepoxy.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE='xml(+)'
+inherit autotools ${GIT_ECLASS} multilib-minimal python-any-r1
+
+DESCRIPTION="Epoxy is a library for handling OpenGL function pointer management for you"
+HOMEPAGE="https://github.com/anholt/libepoxy"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://github.com/anholt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test +X"
+
+DEPEND="${PYTHON_DEPS}
+ media-libs/mesa[egl,${MULTILIB_USEDEP}]
+ x11-misc/util-macros
+ X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable X glx)
+}