summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-16 16:28:07 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-16 16:28:07 +0100
commit09912d918f80af86ca29e8791b51107847768ff1 (patch)
tree4b86d6ac7fc7caf22ed880e49808ddb5739bc1b7 /media-libs
parentmedia-libs/tiff: Patch to fix type (CVE-2017-9935) (diff)
downloadgentoo-09912d918f80af86ca29e8791b51107847768ff1.tar.gz
gentoo-09912d918f80af86ca29e8791b51107847768ff1.tar.bz2
gentoo-09912d918f80af86ca29e8791b51107847768ff1.zip
media-libs/tiff: Minor ebuild adjustments.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/tiff/tiff-4.0.9-r2.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/media-libs/tiff/tiff-4.0.9-r2.ebuild b/media-libs/tiff/tiff-4.0.9-r2.ebuild
index aafbb8871029..26a1889a21c7 100644
--- a/media-libs/tiff/tiff-4.0.9-r2.ebuild
+++ b/media-libs/tiff/tiff-4.0.9-r2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-inherit autotools eutils libtool multilib-minimal
+EAPI=6
+
+inherit autotools libtool ltprune multilib-minimal
DESCRIPTION="Tag Image File Format (TIFF) library"
HOMEPAGE="http://libtiff.maptools.org"
@@ -47,14 +48,16 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable static-libs static) \
- $(use_enable zlib) \
- $(use_enable jpeg) \
- $(use_enable jbig) \
- $(use_enable lzma) \
- $(use_enable cxx) \
+ local myeconfargs=(
--without-x
+ $(use_enable cxx)
+ $(use_enable jbig)
+ $(use_enable jpeg)
+ $(use_enable lzma)
+ $(use_enable static-libs static)
+ $(use_enable zlib)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
# remove useless subdirs
if ! multilib_is_native_abi ; then
@@ -76,5 +79,5 @@ multilib_src_test() {
multilib_src_install_all() {
prune_libtool_files --all
- rm -f "${ED}"/usr/share/doc/${PF}/{COPYRIGHT,README*,RELEASE-DATE,TODO,VERSION}
+ rm -f "${ED%/}"/usr/share/doc/${PF}/{COPYRIGHT,README*,RELEASE-DATE,TODO,VERSION}
}