summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-30 23:01:26 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-30 23:44:02 +0200
commit09fadf3ec3ead6c7b1dcd9c98988c473d43e942d (patch)
treed84a1314274e9ccbe79632b3c9e36f7ac56c0b29 /media-libs
parentmedia-libs/mlt: fix crash with filters not supporting preview scale (diff)
downloadgentoo-09fadf3ec3ead6c7b1dcd9c98988c473d43e942d.tar.gz
gentoo-09fadf3ec3ead6c7b1dcd9c98988c473d43e942d.tar.bz2
gentoo-09fadf3ec3ead6c7b1dcd9c98988c473d43e942d.zip
media-libs/mlt: fix crash in composite when PGM luma fails to load
Upstream commit 46a226217d8ec5bbf66a4fa3da138fd6924dd13b Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mlt/files/mlt-6.20.0-crash-in-composite.patch34
-rw-r--r--media-libs/mlt/mlt-6.20.0-r2.ebuild1
2 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/mlt/files/mlt-6.20.0-crash-in-composite.patch b/media-libs/mlt/files/mlt-6.20.0-crash-in-composite.patch
new file mode 100644
index 000000000000..e5ae5f01c9d0
--- /dev/null
+++ b/media-libs/mlt/files/mlt-6.20.0-crash-in-composite.patch
@@ -0,0 +1,34 @@
+From 46a226217d8ec5bbf66a4fa3da138fd6924dd13b Mon Sep 17 00:00:00 2001
+From: Dan Dennedy <dan@dennedy.org>
+Date: Wed, 25 Mar 2020 16:06:34 -0700
+Subject: [PATCH] fix #535 crash in composite when PGM luma fails to load
+
+---
+ src/modules/core/transition_composite.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/modules/core/transition_composite.c b/src/modules/core/transition_composite.c
+index e6d078e36..24a0d30c7 100644
+--- a/src/modules/core/transition_composite.c
++++ b/src/modules/core/transition_composite.c
+@@ -1,6 +1,6 @@
+ /*
+ * transition_composite.c -- compose one image over another using alpha channel
+- * Copyright (C) 2003-2019 Meltytech, LLC
++ * Copyright (C) 2003-2020 Meltytech, LLC
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+@@ -697,10 +697,10 @@ static uint16_t* get_luma( mlt_transition self, mlt_properties properties, int w
+ {
+ luma_width = 0;
+ luma_height = 0;
+- }
++ }
+ }
+ }
+- if ( luma_width > 0 && luma_height > 0 )
++ if ( orig_bitmap && luma_width > 0 && luma_height > 0 )
+ {
+ // Scale luma map
+ luma_bitmap = mlt_pool_alloc( width * height * sizeof( uint16_t ) );
diff --git a/media-libs/mlt/mlt-6.20.0-r2.ebuild b/media-libs/mlt/mlt-6.20.0-r2.ebuild
index d261114c2002..745d49592280 100644
--- a/media-libs/mlt/mlt-6.20.0-r2.ebuild
+++ b/media-libs/mlt/mlt-6.20.0-r2.ebuild
@@ -89,6 +89,7 @@ PATCHES=(
"${FILESDIR}"/${P}-opencv4.patch
"${FILESDIR}"/${P}-nullpointer-crash.patch
"${FILESDIR}"/${P}-crash-w-unsupported-preview-scale.patch
+ "${FILESDIR}"/${P}-crash-in-composite.patch
)
pkg_setup() {