summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-06-27 23:52:29 +0300
committerMart Raudsepp <leio@gentoo.org>2020-06-27 23:52:43 +0300
commitb0b8a70d3a37aaa99eb518c3ce19cbbcde8d2093 (patch)
tree97e01ce256f0da0d221c0a45f188388739f8a2a1 /media-libs
parentmedia-plugins/vdr-xineliboutput: add missing flag-o-matic eclass (diff)
downloadgentoo-b0b8a70d3a37aaa99eb518c3ce19cbbcde8d2093.tar.gz
gentoo-b0b8a70d3a37aaa99eb518c3ce19cbbcde8d2093.tar.bz2
gentoo-b0b8a70d3a37aaa99eb518c3ce19cbbcde8d2093.zip
media-libs/graphene: bump to 1.10.2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/graphene/Manifest1
-rw-r--r--media-libs/graphene/graphene-1.10.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/graphene/Manifest b/media-libs/graphene/Manifest
index 822338fa4caf..f817526f08bf 100644
--- a/media-libs/graphene/Manifest
+++ b/media-libs/graphene/Manifest
@@ -1,2 +1,3 @@
DIST graphene-1.10.0.tar.xz 289452 BLAKE2B 41af96ffcdb2d8ad2fce7a242cef74cead09ce444514f85a97ac609c6518c60cbd5fb44b58b24973fe9a372f898ca99b79cfd776c968d53b72fc20c5d076a230 SHA512 842ac2c9c2046f07f8421b99292cac348276bb1e025250c7e0dc3ec7f90cb33094b765034862f325dd78f93aa5484ad75a4ad6139fe13330d9e41e3a7cb830d0
+DIST graphene-1.10.2.tar.xz 292372 BLAKE2B 94553a32dc57216402a9676e11525552c010d970caeb1256dde50ca842b4d673ad78d004d57e7c7a017b8c6e64ad75fc3b03603cba746027ab10befa76d32955 SHA512 a8a8ef1e4ccffee2313a18b9b8dda06c7ede6d49fdde8578694500634e3c90278fd30af7d88938d5ecb08c519cc3e09d21fe69d0f21cb766e056ceedbb3eafb0
DIST graphene-1.8.6.tar.xz 127984 BLAKE2B 7f67b99796cca1a47324674b1871ddfbcce1193ded5f0a37c8c2894d52b6b5823b0fb1909018ea6adb90f7ed53ad6b09eeda9b1606a22a8b85cd0d661d500195 SHA512 ef6e9b5587bd540099216a7e3f7c86eb62368d49876dcd380c9767c6740c8267c9d510c5025dbe56402f3cd15084ef8fc634d3abe486b516f4f5328b87df277c
diff --git a/media-libs/graphene/graphene-1.10.2.ebuild b/media-libs/graphene/graphene-1.10.2.ebuild
new file mode 100644
index 000000000000..672030936169
--- /dev/null
+++ b/media-libs/graphene/graphene-1.10.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit xdg-utils meson multilib-minimal python-any-r1
+
+DESCRIPTION="A thin layer of types for graphic libraries"
+HOMEPAGE="https://ebassi.github.io/graphene/"
+SRC_URI="https://github.com/ebassi/graphene/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup, as meson uses it too anyway
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
+ local emesonargs=(
+ -Dgtk_doc=$(multilib_native_usex doc true false)
+ -Dgobject_types=true
+ -Dintrospection=$(multilib_native_usex introspection true false)
+ -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
+ $(meson_use cpu_flags_x86_sse2 sse2)
+ $(meson_use cpu_flags_arm_neon arm_neon)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}