summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-08 21:27:33 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-09 00:04:41 +0200
commitc2ba61f77034815605f470745da96bb979d4004f (patch)
treec55c1f307d00f865e2b9f67b0254c5644ffe2cec /media-libs
parentmail-client/mutt: stable 1.10.1 for ppc, bug #661436 (diff)
downloadgentoo-c2ba61f77034815605f470745da96bb979d4004f.tar.gz
gentoo-c2ba61f77034815605f470745da96bb979d4004f.tar.bz2
gentoo-c2ba61f77034815605f470745da96bb979d4004f.zip
media-libs/libde265: update live ebuild
- Bump to EAPI=7 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libde265/libde265-9999.ebuild40
1 files changed, 30 insertions, 10 deletions
diff --git a/media-libs/libde265/libde265-9999.ebuild b/media-libs/libde265/libde265-9999.ebuild
index 5fd5bc2676da..271e443495b1 100644
--- a/media-libs/libde265/libde265-9999.ebuild
+++ b/media-libs/libde265/libde265-9999.ebuild
@@ -1,15 +1,22 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI="7"
-AUTOTOOLS_IN_SOURCE_BUILD=1
-AUTOTOOLS_AUTORECONF=1
-inherit git-r3 autotools-multilib
+inherit autotools multilib-minimal
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.2-qtbindir.patch" )
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="Open h.265 video codec implementation"
HOMEPAGE="https://github.com/strukturag/libde265"
-EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
LICENSE="GPL-3"
SLOT="0"
@@ -27,9 +34,16 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-1.0.2-qtbindir.patch" )
+src_prepare() {
+ default
+
+ eautoreconf
-src_configure() {
+ # without this, headers would be missing and make would fail
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
local myeconfargs=(
$(use_enable cpu_flags_x86_sse sse)
$(use_enable static-libs static)
@@ -38,8 +52,14 @@ src_configure() {
$(use_enable debug log-trace)
$(use_enable qt5 dec265)
$(use_enable qt5 sherlock265)
- --disable-silent-rules
--enable-log-error
)
- autotools-multilib_src_configure "${myeconfargs[@]}"
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
}