summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Ammann <philipp.ammann@posteo.de>2019-06-26 19:30:45 +0000
committerMatt Turner <mattst88@gentoo.org>2019-08-17 15:59:01 -0700
commit97c3d2d26f9cc06c46d0c479f67b446214177463 (patch)
tree0c8372ee8786e3b710cba84500675089743fbb0a /media-plugins/gst-plugins-vaapi
parentx11-base/xorg-server: Depend on media-libs/mesa[X] (diff)
downloadgentoo-97c3d2d26f9cc06c46d0c479f67b446214177463.tar.gz
gentoo-97c3d2d26f9cc06c46d0c479f67b446214177463.tar.bz2
gentoo-97c3d2d26f9cc06c46d0c479f67b446214177463.zip
*/*: Depend on media-libs/mesa[X(+)]
This changes any package that depends on media-libs/mesa (though not virtual/opengl) to depend on media-libs/mesa[X(+)] instead. Bug: https://bugs.gentoo.org/560096 Signed-off-by: Philipp Ammann <philipp.ammann@posteo.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-vaapi')
-rw-r--r--media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.1.ebuild2
-rw-r--r--media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.3.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.1.ebuild b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.1.ebuild
index d4dbc76c468..c3c7c035b24 100644
--- a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.1.ebuild
+++ b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.1.ebuild
@@ -44,7 +44,7 @@ REQUIRED_USE="
GST_REQ="1.14.1"
GL_DEPS="
>=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[egl?,gles2?,opengl?,wayland?,X?]
- media-libs/mesa[gles2?,egl?,${MULTILIB_USEDEP}]
+ media-libs/mesa[gles2?,egl?,X(+),${MULTILIB_USEDEP}]
"
RDEPEND="
>=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}]
diff --git a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.3.ebuild b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.3.ebuild
index 940d685060f..79f8f43c479 100644
--- a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.3.ebuild
+++ b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.3.ebuild
@@ -44,7 +44,7 @@ REQUIRED_USE="
GST_REQ="${PV}"
GL_DEPS="
>=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[egl?,gles2?,opengl?,wayland?,X?]
- media-libs/mesa[gles2?,egl?,${MULTILIB_USEDEP}]
+ media-libs/mesa[gles2?,egl?,X(+),${MULTILIB_USEDEP}]
"
RDEPEND="
>=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}]