summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJouni Kosonen <jouni.kosonen@tukesoft.com>2016-10-21 22:38:50 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-11-25 22:40:36 +0100
commit8a4cbcabf84526ca02327bdd8f2fb53b5b94e583 (patch)
treea6a883005e66c7f0c2d76ced38a513313a83a4f1 /media-plugins/gst-transcoder
parentnet-mail/dbmail: Migrate to /run and EAPI 6 (diff)
downloadgentoo-8a4cbcabf84526ca02327bdd8f2fb53b5b94e583.tar.gz
gentoo-8a4cbcabf84526ca02327bdd8f2fb53b5b94e583.tar.bz2
gentoo-8a4cbcabf84526ca02327bdd8f2fb53b5b94e583.zip
media-plugins/gst-transcoder: Ensure sane libdir value and add prefix support.
Gentoo-Bug: https://bugs.gentoo.org/591564 Closes: https://github.com/gentoo/gentoo/pull/2624 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-plugins/gst-transcoder')
-rw-r--r--media-plugins/gst-transcoder/gst-transcoder-1.8.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-plugins/gst-transcoder/gst-transcoder-1.8.2-r1.ebuild b/media-plugins/gst-transcoder/gst-transcoder-1.8.2-r1.ebuild
new file mode 100644
index 000000000000..c72095dd500e
--- /dev/null
+++ b/media-plugins/gst-transcoder/gst-transcoder-1.8.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit python-any-r1 xdg
+
+DESCRIPTION="GStreamer Transcoding API"
+HOMEPAGE="https://github.com/pitivi/gst-transcoder"
+SRC_URI="https://github.com/pitivi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/gobject-introspection:=
+ dev-libs/glib:2
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/meson-0.28.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Not a normal configure
+ # --buildtype=plain needed for honoring CFLAGS/CXXFLAGS and not
+ # defaulting to debug
+ ./configure --prefix="${EPREFIX}/usr" --libdir="$(get_libdir)" --buildtype=plain || die
+}
+
+src_compile() {
+ addpredict /dev #590848
+ # We cannot use 'make' as it won't allow us to build verbosely
+ cd mesonbuild || die
+ ninja -v || die
+}