summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-01-09 15:24:47 -0500
committerDavid Seifert <soap@gentoo.org>2017-01-09 22:25:55 +0200
commit2825b6e93761621c6162913df20b21169df024c8 (patch)
tree9bad032591663c2da65d9c2f00b06ff74e2cc45c /media-plugins/kodi-audiodecoder-stsound
parentdev-python/ansicolor: add missing dev-python/setuptools DEPEND (diff)
downloadgentoo-2825b6e93761621c6162913df20b21169df024c8.tar.gz
gentoo-2825b6e93761621c6162913df20b21169df024c8.tar.bz2
gentoo-2825b6e93761621c6162913df20b21169df024c8.zip
media-plugins/kodi-*: add live ebuilds for all add-ons currently available in kodi upstream
Gentoo-bug: 555792 Closes: https://github.com/gentoo/gentoo/pull/3195
Diffstat (limited to 'media-plugins/kodi-audiodecoder-stsound')
-rw-r--r--media-plugins/kodi-audiodecoder-stsound/Manifest1
-rw-r--r--media-plugins/kodi-audiodecoder-stsound/kodi-audiodecoder-stsound-1.1.0.ebuild36
-rw-r--r--media-plugins/kodi-audiodecoder-stsound/kodi-audiodecoder-stsound-9999.ebuild36
-rw-r--r--media-plugins/kodi-audiodecoder-stsound/metadata.xml16
4 files changed, 89 insertions, 0 deletions
diff --git a/media-plugins/kodi-audiodecoder-stsound/Manifest b/media-plugins/kodi-audiodecoder-stsound/Manifest
new file mode 100644
index 000000000000..49f7bc58630e
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-stsound/Manifest
@@ -0,0 +1 @@
+DIST kodi-audiodecoder-stsound-1.1.0.tar.gz 62033 SHA256 c9b6e98d544712f7cec3cf18f866ccaed2fbcd20410179259ae0455ffa967ca4 SHA512 462403bc3221cef4b64b12f25765fe89567e873a0aa9df7dfb4e649132500b5fec43f0551f7d359c2b4ee38ab8fcf03bc010e84d20bdd4b8665ad254568f9f60 WHIRLPOOL 83442b5941ab61f0a16359d70b863b71dae70bff63593b64ac2f6b52653f530e2d7b88d682ddc2d70e590b13f99c8599bb4bae9742bdb71f2f08b24a5b7a22a4
diff --git a/media-plugins/kodi-audiodecoder-stsound/kodi-audiodecoder-stsound-1.1.0.ebuild b/media-plugins/kodi-audiodecoder-stsound/kodi-audiodecoder-stsound-1.1.0.ebuild
new file mode 100644
index 000000000000..3f911fcc7a5e
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-stsound/kodi-audiodecoder-stsound-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="SPC decoder addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/audiodecoder.stsound"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/notspiff/audiodecoder.stsound.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/audiodecoder.stsound/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/audiodecoder.stsound-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ media-tv/kodi
+ media-libs/kodi-platform
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-audiodecoder-stsound/kodi-audiodecoder-stsound-9999.ebuild b/media-plugins/kodi-audiodecoder-stsound/kodi-audiodecoder-stsound-9999.ebuild
new file mode 100644
index 000000000000..3f911fcc7a5e
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-stsound/kodi-audiodecoder-stsound-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="SPC decoder addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/audiodecoder.stsound"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/notspiff/audiodecoder.stsound.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/audiodecoder.stsound/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/audiodecoder.stsound-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ media-tv/kodi
+ media-libs/kodi-platform
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-audiodecoder-stsound/metadata.xml b/media-plugins/kodi-audiodecoder-stsound/metadata.xml
new file mode 100644
index 000000000000..f67174f3e0dc
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-stsound/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@integralblue.com</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>YM decoder addon for Kodi</longdescription>
+ <upstream>
+ <remote-id type="github">notspiff/audiodecoder.stsound</remote-id>
+ </upstream>
+</pkgmetadata>