summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-07-22 00:46:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-07-22 02:01:54 +0200
commit9aeb7b0d3fe18e7362fa1536086d7b9ab33f19d8 (patch)
tree3d2eee5f0fc9128b0681b83a4040dde4493ec49b /media-plugins/mythplugins
parentmedia-tv/mythtv: 0.28.1 version bump (diff)
downloadgentoo-9aeb7b0d3fe18e7362fa1536086d7b9ab33f19d8.tar.gz
gentoo-9aeb7b0d3fe18e7362fa1536086d7b9ab33f19d8.tar.bz2
gentoo-9aeb7b0d3fe18e7362fa1536086d7b9ab33f19d8.zip
media-plugins/mythplugins: 0.28.1 version bump
Drop bogus subslots Cleanup whitespace Sort dependencies Switch HOMEPAGE to https Thanks-to: Andreas Steinmetz <ast@domdv.de> Gentoo-bug: 608998 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'media-plugins/mythplugins')
-rw-r--r--media-plugins/mythplugins/Manifest1
-rw-r--r--media-plugins/mythplugins/mythplugins-0.28.1.ebuild163
2 files changed, 164 insertions, 0 deletions
diff --git a/media-plugins/mythplugins/Manifest b/media-plugins/mythplugins/Manifest
index d6cf058bb27a..292f59c42857 100644
--- a/media-plugins/mythplugins/Manifest
+++ b/media-plugins/mythplugins/Manifest
@@ -1,2 +1,3 @@
DIST mythtv-0.27.6_p20160318.tar.gz 85676387 SHA256 d0b8c03d95e082e87e0fab8656358e9f3991cd08b2ec5edcbb10a9a91b1e4162 SHA512 7e94d07b4f99a15b978b42d8be11f329a938842b02ad99c9628ab6dda2fa802ca7148c5db9e6f7fae40f44027f55e69f1cdb6879ee83400934025f18ac68468f WHIRLPOOL d0f040c1ecb35e5c526477134d756a67d978aeefbf478b624eaa16e4ca1639e3b8f038507052b7d05e3a18fb85fd4e1eaeeb1a185ccfdf0fb2255fdc657be6c1
+DIST mythtv-0.28.1.tar.gz 104477892 SHA256 73dd4de0de6fe5688c290781b76de6380b256a87159f2c6e3dad66870389da1f SHA512 67a81858cd19b90f519113b234119ecc248366d8545c862d887755f256cddf04d9ca16a7bf67f63e06f7628730e7dbde2a2099ca8aaeb9061b2e55a5a0b7d5e7 WHIRLPOOL 370f3a528438d50d302ab6adadba5089b32749f8127cbf270b85ef16d35ca15026e0947e292920a3dd6acf2ed65de68af8754d985944bd59f3310a42b03551de
DIST mythtv-0.28.tar.gz 104364066 SHA256 9d640ab0551b300dab9b633f969efc6f1987f9bdedbef5997a44ddf97d863171 SHA512 7087fa69b89a7166ddfa96a5a65f48e0ee1858bc150376b2ac2309707b4d1fb9cc544d60b114227284fd0d4891eabded6edc31215fb8f11d1df304fe77ff8f85 WHIRLPOOL f593ab2c232c4f5361b3997d35ba631c845d0f12399a772fdfc296a9e120f5a03a7ba22dbe26b972c522f46a13907fc09b2619e84874cd952095b72df54d53e1
diff --git a/media-plugins/mythplugins/mythplugins-0.28.1.ebuild b/media-plugins/mythplugins/mythplugins-0.28.1.ebuild
new file mode 100644
index 000000000000..3f901e40b892
--- /dev/null
+++ b/media-plugins/mythplugins/mythplugins-0.28.1.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+BACKPORTS="03f44039848bd09444ff4baa8dc158bd61454079"
+MY_P=${P%_p*}
+
+inherit eutils python-single-r1 vcs-snapshot
+
+DESCRIPTION="Official MythTV plugins"
+HOMEPAGE="https://www.mythtv.org"
+SRC_URI="https://github.com/MythTV/mythtv/archive/${BACKPORTS}.tar.gz -> mythtv-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+MYTHPLUGINS="+mytharchive +mythbrowser +mythgallery +mythgame \
++mythmusic +mythnetvision +mythnews +mythweather +mythzoneminder"
+IUSE="${MYTHPLUGINS} alsa cdda cdr exif fftw +hls ieee1394 libass raw +theora +vorbis +xml xvid"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/openssl:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsql:5
+ media-libs/freetype:2
+ media-libs/libpng:0=
+ ~media-tv/mythtv-${PV}:=[alsa=,hls=,ieee1394=,libass=,python,theora=,vorbis=,xml=,xvid=]
+ sys-apps/util-linux
+ sys-libs/zlib
+ virtual/libudev:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+ alsa? ( >=media-libs/alsa-lib-1.0.24 )
+ fftw? ( sci-libs/fftw:3.0= )
+ hls? (
+ media-libs/faac
+ media-libs/libvpx:=
+ >=media-libs/x264-0.0.20111220:=
+ >=media-sound/lame-3.93.1
+ )
+ ieee1394? (
+ >=media-libs/libiec61883-1.0.0
+ >=sys-libs/libavc1394-0.5.3
+ >=sys-libs/libraw1394-1.2.0
+ )
+ libass? ( >=media-libs/libass-0.9.11:= )
+ mytharchive? (
+ app-cdr/dvd+rw-tools
+ dev-python/pillow
+ media-video/dvdauthor
+ media-video/mjpegtools[png]
+ media-video/transcode
+ virtual/cdrtools
+ )
+ mythbrowser? ( dev-qt/qtwebkit:5 )
+ mythgallery? (
+ media-libs/tiff:0
+ virtual/opengl
+ exif? ( >media-libs/libexif-0.6.9:= )
+ raw? ( media-gfx/dcraw )
+ )
+ mythmusic? (
+ >=media-libs/flac-1.1.2
+ media-libs/libogg
+ >=media-libs/libvorbis-1.0
+ >=media-libs/taglib-1.6
+ >=media-sound/lame-3.93.1
+ virtual/opengl
+ cdda? (
+ dev-libs/libcdio:=
+ cdr? ( virtual/cdrtools )
+ )
+ )
+ mythnetvision? (
+ ${PYTHON_DEPS}
+ dev-python/lxml
+ dev-python/mysql-python
+ dev-python/oauth
+ dev-python/pycurl
+ )
+ mythweather? (
+ dev-perl/Date-Manip
+ dev-perl/DateTime
+ dev-perl/DateTime-Format-ISO8601
+ dev-perl/Image-Size
+ dev-perl/JSON
+ dev-perl/SOAP-Lite
+ dev-perl/XML-Parser
+ dev-perl/XML-SAX
+ dev-perl/XML-Simple
+ dev-perl/XML-XPath
+ )
+ mythzoneminder? ( virtual/mysql )
+ theora? (
+ media-libs/libogg
+ media-libs/libtheora
+ )
+ xml? ( >=dev-libs/libxml2-2.6.0:= )
+ xvid? ( >=media-libs/xvid-1.1.0 )
+"
+RDEPEND="${DEPEND}
+ !media-plugins/mytharchive
+ !media-plugins/mythbrowser
+ !media-plugins/mythgallery
+ !media-plugins/mythgame
+ !media-plugins/mythmovies
+ !media-plugins/mythmusic
+ !media-plugins/mythnetvision
+ !media-plugins/mythnews
+ !media-plugins/mythweather
+"
+REQUIRED_USE="
+ cdda? ( mythmusic )
+ cdr? ( mythmusic cdda )
+ exif? ( mythgallery )
+ fftw? ( mythmusic )
+ mythmusic? ( vorbis )
+ mythnetvision? ( ${PYTHON_REQUIRED_USE} )
+ mythnews? ( mythbrowser )
+ raw? ( mythgallery )
+"
+
+S="${WORKDIR}/mythtv-${PV}/mythplugins"
+
+src_prepare() {
+ default
+ sed -i '1i#define OF(x) x' mythgame/mythgame/external/ioapi.h
+}
+
+src_configure() {
+ econf \
+ --prefix=/usr \
+ --python=${EPYTHON} \
+ --enable-opengl \
+ $(use_enable cdda cdio) \
+ $(use_enable exif) \
+ $(use_enable exif new-exif) \
+ $(use_enable raw dcraw) \
+ $(use_enable mytharchive) \
+ $(use_enable mythbrowser) \
+ $(use_enable mythgallery) \
+ $(use_enable mythgame) \
+ $(use_enable mythmusic) \
+ $(use_enable mythnetvision) \
+ $(use_enable mythnews) \
+ $(use_enable mythweather) \
+ $(use_enable mythzoneminder)
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+}