summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2020-08-26 14:07:53 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2020-08-26 14:08:57 +0200
commitd56ed57b70b755a60c373293bae7549ec6726d8b (patch)
tree43adbe80561fbe26b7a8b1207fce82441ea9630b /media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420-r1.ebuild
parentx11-drivers/nvidia-drivers: Old (diff)
downloadgentoo-d56ed57b70b755a60c373293bae7549ec6726d8b.tar.gz
gentoo-d56ed57b70b755a60c373293bae7549ec6726d8b.tar.bz2
gentoo-d56ed57b70b755a60c373293bae7549ec6726d8b.zip
media-plugins/vdr-dvbhddevice: fixed SRC_URI, moved from hg to git
Thanks to Azamat H. Hackimov to point this out and provide a fixed ebuild. Closes: https://bugs.gentoo.org/738756 Closes: https://github.com/gentoo/gentoo/pull/17246 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420-r1.ebuild')
-rw-r--r--media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420-r1.ebuild b/media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420-r1.ebuild
new file mode 100644
index 000000000000..a09c42eaa3b1
--- /dev/null
+++ b/media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+# 2018/04/20
+REVISION="6a3e75484d90"
+
+DESCRIPTION="VDR Plugin: output device for the 'Full Featured' TechnoTrend S2-6400 DVB Card"
+HOMEPAGE="https://bitbucket.org/powARman/dvbhddevice"
+SRC_URI="https://bitbucket.org/powARman/dvbhddevice/get/${REVISION}.tar.bz2 ->
+ ${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=media-video/vdr-2.0.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/convert-bool-fix.patch"
+ "${FILESDIR}/define_AUDIO_GET_PTS.patch" )
+QA_FLAGS_IGNORED="
+ usr/lib/vdr/plugins/libvdr-dvbhddevice.*
+ usr/lib64/vdr/plugins/libvdr-dvbhddevice.*"
+
+S="${WORKDIR}/powARman-${VDRPLUGIN}-${REVISION}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ fix_vdr_libsi_include dvbhdffdevice.c
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ doheader dvbhdffdevice.h hdffcmd.h
+ insinto /usr/include/libhdffcmd
+ doins libhdffcmd/*.h
+}