summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-02-16 17:57:09 +0200
committerMart Raudsepp <leio@gentoo.org>2019-02-16 17:57:41 +0200
commit1a1c945a4a2221f91a2f9a9e13bf8d4687563995 (patch)
tree43632df75cd583b45e0159201dfe417de3d1cff6 /media-plugins
parentmedia-libs/grilo: bump to 0.3.7 (diff)
downloadgentoo-1a1c945a4a2221f91a2f9a9e13bf8d4687563995.tar.gz
gentoo-1a1c945a4a2221f91a2f9a9e13bf8d4687563995.tar.bz2
gentoo-1a1c945a4a2221f91a2f9a9e13bf8d4687563995.zip
media-plugins/grilo-plugins: bump to 0.3.8
Instead of gmime, totem-pl-parser is now used for that, moving the non-optional dep to that. Due to that, various optional plugins are now just always built, as they only had pl-parser missing. libsoup is also more widely needed (by a plugin that wasn't optional before); just hard depend on that too, making some more plugins always built, as option would be redundant. Help files are installed with slot suffix now, instead of messing with the XML filenames. It doesn't look like they are properly usable in yelp either way (only seems to work if opened up with full path). Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/grilo-plugins/Manifest1
-rw-r--r--media-plugins/grilo-plugins/files/0.3.8-meson-goa.patch44
-rw-r--r--media-plugins/grilo-plugins/grilo-plugins-0.3.8.ebuild104
3 files changed, 149 insertions, 0 deletions
diff --git a/media-plugins/grilo-plugins/Manifest b/media-plugins/grilo-plugins/Manifest
index 39fe541c6b54..29c073c6bbd9 100644
--- a/media-plugins/grilo-plugins/Manifest
+++ b/media-plugins/grilo-plugins/Manifest
@@ -1 +1,2 @@
DIST grilo-plugins-0.3.7.tar.xz 1892848 BLAKE2B 9894a01dc555f20c3119208e2ee875898c918f8d81e36571a777f7f1776c284d5fa5b4ac9126a352dc812b0f5ba9c15e0e81a2381ef9cb636afb66e272a77cec SHA512 9e69835b3b8f6e2974d799480e2c8c55a084d2089ead6b37112a8c3c79b6bd2142b8fd66952493b7118e09eb5070789408b59bd28784bd9f6bf5ea5a7bc5695d
+DIST grilo-plugins-0.3.8.tar.xz 1408952 BLAKE2B 3375275189a25289406b5d9fd6dd42b6c0ad92779b081ce2f480b464929302af7b52fc758f2f6277c94fad38a2b0bbfc8fe9fd668ff98fc0ac7fbeda69a5ac42 SHA512 c5a0a80fd7c871ce69a06bdcab2b3d8986708e4e6b9c9020d7e938d4450655f962db7f84da0b40ed38ba197f65fc2a561e06a92cdca593620d66c2b153eb4879
diff --git a/media-plugins/grilo-plugins/files/0.3.8-meson-goa.patch b/media-plugins/grilo-plugins/files/0.3.8-meson-goa.patch
new file mode 100644
index 000000000000..fc3241085acb
--- /dev/null
+++ b/media-plugins/grilo-plugins/files/0.3.8-meson-goa.patch
@@ -0,0 +1,44 @@
+From ecee1d8099447b2639d9c38acc344428877d4799 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sat, 16 Feb 2019 14:44:44 +0200
+Subject: [PATCH] build: Support controlling gnome-online-accounts dependency
+
+---
+ meson.build | 4 ++--
+ meson_options.txt | 1 +
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 83a83a0..e79e84f 100644
+--- a/meson.build
++++ b/meson.build
+@@ -13,7 +13,7 @@ project('grilo-plugins', 'c',
+ 'warning_level=1'
+ ],
+ license: 'LGPL 2.1',
+- meson_version: '>= 0.37.0')
++ meson_version: '>= 0.47.0')
+
+ plugin_version = meson.project_version()
+ version_array = plugin_version.split('.')
+@@ -51,7 +51,7 @@ avahi_glib_dep = dependency('avahi-glib', required: false)
+ avahi_gobject_dep = dependency('avahi-gobject', required: false)
+ gio_dep = dependency('gio-2.0', required: false)
+ gio_unix_dep = dependency('gio-unix-2.0', required: false)
+-goa_dep = dependency('goa-1.0', version: '>= 3.17.91', required: false)
++goa_dep = dependency('goa-1.0', version: '>= 3.17.91', required: get_option('goa'))
+ gom_dep = dependency('gom-1.0', version: '>= 0.3.2', required: false)
+ grilo_net_dep = dependency('grilo-net-0.3', version: '>= 0.3.0', required: false)
+ grilo_pls_dep = dependency('grilo-pls-0.3', version: '>= 0.3.0', required: false)
+diff --git a/meson_options.txt b/meson_options.txt
+index 7d96a74..32b51d2 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -21,3 +21,4 @@ option('enable-tmdb', type: 'combo', choices: [ 'auto', 'yes', 'no' ], value: 'a
+ option('enable-tracker', type: 'combo', choices: [ 'auto', 'yes', 'no' ], value: 'auto', description: 'Enable Tracker plugin')
+ option('enable-vimeo', type: 'combo', choices: [ 'auto', 'yes', 'no' ], value: 'auto', description: 'Enable Vimeo plugin')
+ option('enable-youtube', type: 'combo', choices: [ 'auto', 'yes', 'no' ], value: 'auto', description: 'Enable YouTube plugin')
++option('goa', type: 'feature', value: 'auto', description: 'Enable gnome-online-accounts usage')
+--
+2.17.0
+
diff --git a/media-plugins/grilo-plugins/grilo-plugins-0.3.8.ebuild b/media-plugins/grilo-plugins/grilo-plugins-0.3.8.ebuild
new file mode 100644
index 000000000000..79aa402290f8
--- /dev/null
+++ b/media-plugins/grilo-plugins/grilo-plugins-0.3.8.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="A collection of plugins for the Grilo framework"
+HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="daap chromaprint flickr freebox gnome-online-accounts lua test thetvdb tracker upnp-av +youtube"
+
+# GOA is only optionally used by flickr and lua-factory plugins (checked at v0.3.8)
+# json-glib used by tmdb and lua; tmdb currently non-optional
+# TODO: validate upnp-av dleyna deps
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=media-libs/grilo-0.3.6:${SLOT}=[network,playlist]
+ freebox? (
+ net-dns/avahi )
+ >=dev-libs/gom-0.3.2
+ chromaprint? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-plugins/gst-plugins-chromaprint:1.0 )
+ dev-libs/json-glib
+ daap? (
+ >=net-libs/libdmapsharing-2.9.12:3.0 )
+ media-libs/libmediaart:2.0
+ net-libs/libsoup:2.4
+ dev-libs/libxml2:2
+ flickr? (
+ net-libs/liboauth )
+ dev-db/sqlite:3
+ >=dev-libs/totem-pl-parser-3.4.1
+ tracker? (
+ >=app-misc/tracker-0.10.5:= )
+ upnp-av? (
+ net-libs/dleyna-connector-dbus
+ net-misc/dleyna-server )
+ lua? (
+ >=dev-lang/lua-5.3
+ app-arch/libarchive
+ dev-libs/libxml2:2 )
+ thetvdb? (
+ app-arch/libarchive )
+ youtube? (
+ >=dev-libs/libgdata-0.9.1:= )
+
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.17.91:= )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.5
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ upnp-av? ( >=dev-util/gdbus-codegen-2.44 )
+ virtual/pkgconfig
+ lua? ( dev-util/gperf )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-meson-goa.patch # Support controlling g-o-a dep via 'goa' meson_options
+)
+
+src_prepare() {
+ xdg_src_prepare
+ sed -i -e "s:'GETTEXT_PACKAGE', meson.project_name():'GETTEXT_PACKAGE', 'grilo-plugins-${SLOT%/*}':" meson.build || die
+ sed -i -e "s:meson.project_name():'grilo-plugins-${SLOT%/*}':" po/meson.build || die
+ sed -i -e "s:meson.project_name():'grilo-plugins-${SLOT%/*}':" help/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable-bookmarks=yes
+ -Denable-chromaprint=$(usex chromaprint yes no)
+ -Denable-dleyna=$(usex upnp-av yes no)
+ -Denable-dmap=$(usex daap yes no)
+ -Denable-filesystem=yes
+ -Denable-flickr=$(usex flickr yes no)
+ -Denable-freebox=$(usex freebox yes no)
+ -Denable-gravatar=yes
+ -Denable-jamendo=yes
+ -Denable-local-metadata=yes
+ -Denable-lua-factory=$(usex lua yes no)
+ -Denable-magnatune=yes
+ -Denable-metadata-store=yes
+ -Denable-opensubtitles=yes
+ -Denable-optical-media=yes
+ -Denable-podcasts=yes
+ -Denable-raitv=yes
+ -Denable-shoutcast=yes
+ -Denable-thetvdb=$(usex thetvdb yes no)
+ -Denable-tmdb=yes
+ -Denable-tracker=$(usex tracker yes no)
+ -Denable-vimeo=yes
+ -Denable-youtube=$(usex youtube yes no)
+ -Dgoa=$(usex gnome-online-accounts enabled disabled)
+ )
+ meson_src_configure
+}