summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-30 19:13:13 +0100
committerSam James <sam@gentoo.org>2023-05-30 19:20:53 +0100
commit745f8cdffa1f4049d6893dda4645b1d9373dd472 (patch)
treefd1b119f7fe7fea917698bd15634b34cd127ddd7 /media-plugins
parentmedia-plugins/gst-plugins-sidplay: add 1.20.6 (diff)
downloadgentoo-745f8cdffa1f4049d6893dda4645b1d9373dd472.tar.gz
gentoo-745f8cdffa1f4049d6893dda4645b1d9373dd472.tar.bz2
gentoo-745f8cdffa1f4049d6893dda4645b1d9373dd472.zip
media-plugins/gst-plugins-smoothstreaming: add 1.20.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/Manifest1
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.20.6.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-smoothstreaming/Manifest b/media-plugins/gst-plugins-smoothstreaming/Manifest
index be652e5ab7de..ea94574dc23b 100644
--- a/media-plugins/gst-plugins-smoothstreaming/Manifest
+++ b/media-plugins/gst-plugins-smoothstreaming/Manifest
@@ -1,4 +1,5 @@
DIST gst-plugins-bad-1.20.3.tar.xz 6222824 BLAKE2B 01aae59adbe76b8e50a49fb8bb8037e6f3aa93cbc2b658aab05ebbf30f8d1aef98c1981712caa39e3c9d08f1e0c9d76f2f874f7d2fdd994b3a0735b2809eafdf SHA512 cfcf126eabff550455decd7054a269b73489708c10a6b6090dddb5fde29bfba07ed330c339927ff170e025fa3a08d2ffb822322dc3798679366207a54132c71b
DIST gst-plugins-bad-1.20.4.tar.xz 6229992 BLAKE2B 2cd276cec9991e2ca7367a43024d7aee43adaa185a4a06ec08d1e736e72333f7f38cb54257120b9a313feb1fdc285a50d456b4c1fb33627d83acfcd3ece20687 SHA512 31b28d4a1bbecf021a90f2aa49dd344ccea12533b65f3bf3a8426ca2175469fff7b7f8e08af7d3d22c18db2fe48b9d5fbea2b325d296aee04b019cebef1eaec4
DIST gst-plugins-bad-1.20.5.tar.xz 6237720 BLAKE2B bf379da420d1f7f148cf51373f6f2d0800685487c8bdb7a768e79e0a2e4f1721053922be9321958b4ce318de12ea390de4cd89c345329ac41dd0425815e0e7f6 SHA512 4b4603d755d17a0fa072d771521bdcbf554fc9abdc8105b9d9189062e5725ae2989f430e1de77363a69d8c969ecbf15e73e9c478fabe8efac83b2d9b1b0a4a0a
+DIST gst-plugins-bad-1.20.6.tar.xz 6244344 BLAKE2B 50c8d62b486541c0ee71d69f1debb18c7dcd02afe562f6d337f8648cf69a492ac47dcf250e4e6b1c6a7d518237431639c25601f9935996724cb9f73beffa27e8 SHA512 c1f2be9351dc12d9290f715ac529dc03572617fb65c50755927e01cb9307b9e806b6204b5b2f85c29a8fc3d8ca7695767a316fb387eac465e9e93bcae5d39ff5
DIST gst-plugins-bad-1.22.3.tar.xz 5523924 BLAKE2B 8015098ac2d19546de58cebdbe29fd7fbb2c7f076bf775564d7b862ed99a59968a2f751ff1137534d178fea5cf1c2022e53e4159ca2e5d3bf71c9fa4663be4f5 SHA512 1512e26111174ea4a9da26203a635e7ec7673ea5b6ca8dae8aaa8a20ffae36c9b68904d669344a8efc31f751093a00e22d2a1f1affcdd037f162493441c77628
diff --git a/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.20.6.ebuild b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.20.6.ebuild
new file mode 100644
index 000000000000..8c8924b1ed90
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.20.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer-meson
+
+DESCRIPTION="Smooth Streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ gstreamer_system_library gstadaptivedemux_dep:gstadaptivedemux
+ gstreamer_system_package gstcodecparsers_dep:gstreamer-codecparsers
+ gstreamer_system_library gstisoff_dep:gstisoff
+ gstreamer_system_library gsturidownloader_dep:gsturidownloader
+}