summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-01-09 00:33:15 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-01-09 00:43:10 +0100
commite057488745fe242621ca0cf172ea9e063100ab07 (patch)
tree5e8e5deebe615f14242b12d8434592356f675f75 /media-plugins
parentmedia-sound/alsa-utils: Bump to version 1.1.8 (diff)
downloadgentoo-e057488745fe242621ca0cf172ea9e063100ab07.tar.gz
gentoo-e057488745fe242621ca0cf172ea9e063100ab07.tar.bz2
gentoo-e057488745fe242621ca0cf172ea9e063100ab07.zip
media-plugins/alsa-plugins: Bump to version 1.1.8
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsa-plugins/Manifest1
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.1.8.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/media-plugins/alsa-plugins/Manifest b/media-plugins/alsa-plugins/Manifest
index bd1119bea817..bb7a532bfc03 100644
--- a/media-plugins/alsa-plugins/Manifest
+++ b/media-plugins/alsa-plugins/Manifest
@@ -1,3 +1,4 @@
DIST alsa-plugins-1.1.1.tar.bz2 366193 BLAKE2B 02892b0c241cf34d3bfce6cf580dbb6bedbce9253c3e57f04d3093a6cbb1d5b5e9b92566945962b875de20ba3e556e9c1fc4bb4e970502e3c03fc821e5e264fe SHA512 9dd277cb5cce144ce4e5e0010cebcba0f8634c783e7bcd80ce6d04b198d6de5150a2764df3087a39a468b5fb7c4578de2e252095568e811dedaa5e7ffdbeb7c9
DIST alsa-plugins-1.1.6.tar.bz2 367485 BLAKE2B efe8b8447db4f68761060e4f48c86c76f821fd7795d8edec0c8f5a03f7406a422f630f012433ac12c3af3222b7b587820a92e937c80dba6bb8766deb854b9706 SHA512 f01633cd7166a2fba4c5b4d5d786b5a2122f6a810f5b5b7209c42033759d116a4515174e7ee57973d5de716be88a246d733dc5a2daf92b72377c274b04db401b
DIST alsa-plugins-1.1.7.tar.bz2 369866 BLAKE2B 8305f17a7e72e159f1710168cc3a4f0c7deb870c813a8a48b335911717422ac584b6846b047a29880448bdc0597a80881b87e5df1ff018a1e174aea490d3e9df SHA512 c3bb22ec3c5a167fb246cfc94131d53800e321b486ab743c3395a9d91dee0ff9703f6e4a2feaea5a4ee42a7e486d835d48ab880c784c5c34bb4eb5e9ded06d8e
+DIST alsa-plugins-1.1.8.tar.bz2 375346 BLAKE2B 65c161ee375e7aed85dbe918a39bc2aa4818bbcfbaadf405f5f0170d9944ff55b5a9da3690e3cd78bd7ffff74ecf235f49cfc3a5dfe18b627c5a9cb0dc1eb207 SHA512 bb1a4411921ec332f47b43515f6d3b4c03a01568854950b9b5c3f0d8172d9a0c4a5b3652bc64c62eae5ea3aaa5d95fe3d32c0a213fe99adf490a9807bcb58ecd
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.1.8.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.1.8.ebuild
new file mode 100644
index 000000000000..0e6f55c85fa1
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.1.8.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic multilib multilib-minimal
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
+IUSE="arcam_av debug ffmpeg jack libav libsamplerate +mix oss pulseaudio speex +usb_stream"
+
+RDEPEND="
+ >=media-libs/alsa-lib-${PV}:=[${MULTILIB_USEDEP}]
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:0= )
+ )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.8-r1:=[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ speex? (
+ >=media-libs/speex-1.2.0:=[${MULTILIB_USEDEP}]
+ media-libs/speexdsp[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i \
+ -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ pulse/Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ use debug || append-cppflags -DNDEBUG
+
+ local myeconfargs=(
+ --with-speex="$(usex speex lib no)"
+ $(use_enable arcam_av arcamav)
+ $(use_enable ffmpeg libav)
+ $(use_enable jack)
+ $(use_enable libsamplerate samplerate)
+ $(use_enable mix)
+ $(use_enable oss)
+ $(use_enable pulseaudio)
+ $(use_enable speex speexdsp)
+ $(use_enable usb_stream usbstream)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ cd doc || die
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use ffmpeg && dodoc lavrate.txt a52.txt
+
+ if use pulseaudio; then
+ dodoc README-pulse
+ # install ALSA configuration files
+ # making PA to be used by alsa clients
+ insinto /usr/share/alsa
+ doins "${FILESDIR}"/pulse-default.conf
+ insinto /usr/share/alsa/alsa.conf.d
+ doins "${FILESDIR}"/51-pulseaudio-probe.conf
+ # bug #410261, comment 5+
+ # seems to work fine without any path
+ sed -i \
+ -e "s:/usr/lib/alsa-lib/::" \
+ "${ED%/}"/usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf || die #410261
+ fi
+
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}
+
+pkg_postinst() {
+ if use pulseaudio; then
+ einfo "The PulseAudio device is now set as the default device if the"
+ einfo "PulseAudio server is found to be running. Any custom"
+ einfo "configuration in /etc/asound.conf or ~/.asoundrc for this"
+ einfo "purpose should now be unnecessary."
+ fi
+}