summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-radio/ax25-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-radio/ax25-tools')
-rw-r--r--media-radio/ax25-tools/Manifest1
-rw-r--r--media-radio/ax25-tools/ax25-tools-0.0.10_rc4.ebuild45
-rw-r--r--media-radio/ax25-tools/files/ax25d.rc20
-rw-r--r--media-radio/ax25-tools/files/mheardd.rc20
-rw-r--r--media-radio/ax25-tools/files/netromd.rc20
-rw-r--r--media-radio/ax25-tools/files/rip98d.rc20
-rw-r--r--media-radio/ax25-tools/files/rxecho.rc20
-rw-r--r--media-radio/ax25-tools/files/ttylinkd.rc20
-rw-r--r--media-radio/ax25-tools/metadata.xml11
9 files changed, 177 insertions, 0 deletions
diff --git a/media-radio/ax25-tools/Manifest b/media-radio/ax25-tools/Manifest
new file mode 100644
index 000000000000..609e756fff4a
--- /dev/null
+++ b/media-radio/ax25-tools/Manifest
@@ -0,0 +1 @@
+DIST ax25-tools-0.0.10-rc4.tar.gz 364332 SHA256 d36ad473f8261ea91dbef105d7493890774f2d1d03a485b86ddd23cbed597e20 SHA512 874d1ad0097f589af0b0a72ac33d6c7d64586df25779ef1b4c0a832fdf5e528ae5101e56ded736cb2a1ad1b284d6c10fe3a77ecb43df04dccc3d80875f403612 WHIRLPOOL d8268bc596df968f7c7f6fe8da90155462d20c9ead1d4099c7d1d7082a3a887fb3c6a227c13309d6aa9f815cccf7db61e976f97e1d45714ed7a470864d671b5a
diff --git a/media-radio/ax25-tools/ax25-tools-0.0.10_rc4.ebuild b/media-radio/ax25-tools/ax25-tools-0.0.10_rc4.ebuild
new file mode 100644
index 000000000000..2c25b197a99a
--- /dev/null
+++ b/media-radio/ax25-tools/ax25-tools-0.0.10_rc4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Basic AX.25 (Amateur Radio) administrative tools and daemons"
+HOMEPAGE="http://www.linux-ax25.org/"
+SRC_URI="http://www.linux-ax25.org/pub/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="X"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-libs/libax25
+ X? ( x11-libs/libX11
+ media-libs/mesa )"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ econf $(use_with X x)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install installconf
+
+ # Package does not respect --docdir
+ rm -rf "${D}"/usr/share/doc/ax25-tools || die
+ dodoc AUTHORS ChangeLog NEWS README tcpip/ttylinkd.README \
+ user_call/README.user_call yamdrv/README.yamdrv dmascc/README.dmascc \
+ tcpip/ttylinkd.INSTALL
+
+ newinitd "${FILESDIR}"/ax25d.rc ax25d
+ newinitd "${FILESDIR}"/mheardd.rc mheardd
+ newinitd "${FILESDIR}"/netromd.rc netromd
+ newinitd "${FILESDIR}"/rip98d.rc rip98d
+ newinitd "${FILESDIR}"/rxecho.rc rxecho
+ newinitd "${FILESDIR}"/ttylinkd.rc ttylinkd
+}
diff --git a/media-radio/ax25-tools/files/ax25d.rc b/media-radio/ax25-tools/files/ax25d.rc
new file mode 100644
index 000000000000..4086a2bd71f6
--- /dev/null
+++ b/media-radio/ax25-tools/files/ax25d.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ax25d"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/ax25d
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ax25d"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ax25d
+ eend $?
+}
diff --git a/media-radio/ax25-tools/files/mheardd.rc b/media-radio/ax25-tools/files/mheardd.rc
new file mode 100644
index 000000000000..47f3534eefce
--- /dev/null
+++ b/media-radio/ax25-tools/files/mheardd.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting mheardd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/mheardd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping mheardd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/mheardd
+ eend $?
+}
diff --git a/media-radio/ax25-tools/files/netromd.rc b/media-radio/ax25-tools/files/netromd.rc
new file mode 100644
index 000000000000..c6ffbb43b75c
--- /dev/null
+++ b/media-radio/ax25-tools/files/netromd.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting netromd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/netromd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping netromd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/netromd
+ eend $?
+}
diff --git a/media-radio/ax25-tools/files/rip98d.rc b/media-radio/ax25-tools/files/rip98d.rc
new file mode 100644
index 000000000000..098437ffae99
--- /dev/null
+++ b/media-radio/ax25-tools/files/rip98d.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting rip98d"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/rip98d
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rip98d"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/rip98d
+ eend $?
+}
diff --git a/media-radio/ax25-tools/files/rxecho.rc b/media-radio/ax25-tools/files/rxecho.rc
new file mode 100644
index 000000000000..56d6e20c40da
--- /dev/null
+++ b/media-radio/ax25-tools/files/rxecho.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting rxecho"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/rxecho
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rxecho"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/rxecho
+ eend $?
+}
diff --git a/media-radio/ax25-tools/files/ttylinkd.rc b/media-radio/ax25-tools/files/ttylinkd.rc
new file mode 100644
index 000000000000..d6ca4ed34d1c
--- /dev/null
+++ b/media-radio/ax25-tools/files/ttylinkd.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ttylinkd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/ttylinkd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ttylinkd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ttylinkd
+ eend $?
+}
diff --git a/media-radio/ax25-tools/metadata.xml b/media-radio/ax25-tools/metadata.xml
new file mode 100644
index 000000000000..c0e910e25810
--- /dev/null
+++ b/media-radio/ax25-tools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+ <use>
+ <flag name='X'>Enable some X based configuration tools.</flag>
+ </use>
+</pkgmetadata>