summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/alsamixer-app
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/alsamixer-app')
-rw-r--r--media-sound/alsamixer-app/Manifest1
-rw-r--r--media-sound/alsamixer-app/alsamixer-app-0.1.ebuild42
-rw-r--r--media-sound/alsamixer-app/files/alsamixer-app-0.1-Makefile.patch32
-rw-r--r--media-sound/alsamixer-app/metadata.xml6
4 files changed, 81 insertions, 0 deletions
diff --git a/media-sound/alsamixer-app/Manifest b/media-sound/alsamixer-app/Manifest
new file mode 100644
index 000000000000..202b2f40b4ce
--- /dev/null
+++ b/media-sound/alsamixer-app/Manifest
@@ -0,0 +1 @@
+DIST AlsaMixer.app-0.1.tar.gz 26939 RMD160 788bc921e3dfb3e294cdc8363d44cf277724536b SHA1 33a2192e3e5bfe621b0ef2a7bc40d13496e794a6 SHA256 7d55d3ba5ffd82bcddcb546e0aa33ab8638df5d1418aa170e91c42e35c0c8c15
diff --git a/media-sound/alsamixer-app/alsamixer-app-0.1.ebuild b/media-sound/alsamixer-app/alsamixer-app-0.1.ebuild
new file mode 100644
index 000000000000..44fd48ad62ee
--- /dev/null
+++ b/media-sound/alsamixer-app/alsamixer-app-0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+MY_PN=AlsaMixer.app
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="AlsaMixer.app is a simple mixer dockapp"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/253"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/517/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ tc-export CXX
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${MY_PN} || die "dobin failed."
+ dodoc README
+}
diff --git a/media-sound/alsamixer-app/files/alsamixer-app-0.1-Makefile.patch b/media-sound/alsamixer-app/files/alsamixer-app-0.1-Makefile.patch
new file mode 100644
index 000000000000..c260ad1c88bf
--- /dev/null
+++ b/media-sound/alsamixer-app/files/alsamixer-app-0.1-Makefile.patch
@@ -0,0 +1,32 @@
+diff -ur AlsaMixer.app-0.1.orig/Makefile AlsaMixer.app-0.1/Makefile
+--- AlsaMixer.app-0.1.orig/Makefile 2004-09-30 23:44:06.000000000 +0300
++++ AlsaMixer.app-0.1/Makefile 2008-06-28 08:40:28.000000000 +0300
+@@ -4,22 +4,22 @@
+
+ DESTDIR =
+ GNUSTEP_BINDIR = /usr/local/GNUstep/Apps/AlsaMixer.app
+-X11_BINDIR = /usr/X11R6/bin
++X11_BINDIR = /usr/bin
+
+-CXX=c++
+-CXXFLAGS += -Wall -pedantic -fno-rtti -fno-exceptions -O2 -I/usr/X11R6/include
+-LDFLAGS += -L/usr/X11R6/lib -lXpm -lXext -lX11 -lasound
++CXX ?= g++
++CXXFLAGS += -Wall -pedantic -fno-rtti -fno-exceptions
++LIBS = -lXpm -lXext -lX11 -lasound
+
+ OBJECTS = Main.o Mixer.o Xpm.o AMixer/AMixer.o AMixer/AItem.o AMixer/AChannel.o
+
+ all: AlsaMixer.app
+
+ AlsaMixer.app: $(OBJECTS)
+- $(CXX) $(OBJECTS) -o $@ $(LDFLAGS)
++ $(CXX) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $@
+
+ .PHONY: install clean distclean
+
+-install: install-gnustep
++install: install-x11
+
+ install-gnustep: all
+ install -d $(DESTDIR)$(GNUSTEP_BINDIR)
diff --git a/media-sound/alsamixer-app/metadata.xml b/media-sound/alsamixer-app/metadata.xml
new file mode 100644
index 000000000000..06a7d236d552
--- /dev/null
+++ b/media-sound/alsamixer-app/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<herd>sound</herd>
+</pkgmetadata>