summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/amarok
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/Manifest1
-rw-r--r--media-sound/amarok/amarok-2.8.0-r3.ebuild138
-rw-r--r--media-sound/amarok/files/amarok-2.8.0-gmock-1.7.patch35
-rw-r--r--media-sound/amarok/files/amarok-2.8.0-mysqld-rpath.patch12
-rw-r--r--media-sound/amarok/metadata.xml28
5 files changed, 214 insertions, 0 deletions
diff --git a/media-sound/amarok/Manifest b/media-sound/amarok/Manifest
new file mode 100644
index 000000000000..5ab676dd7751
--- /dev/null
+++ b/media-sound/amarok/Manifest
@@ -0,0 +1 @@
+DIST amarok-2.8.0.tar.bz2 39950028 SHA256 f4b89b28f217a6d947e55fb0890de22fad8c404794c6beeb2dcaf2711b4f8ec6 SHA512 09f7f675f1223d36fb9df2f8c88923c6616524e022ad83b12bcb770dfbf60cb6b191e4035633f2ea2eee5fb7b38e6d5092cf69fe222ef9c3f3c46ba8f157a62d WHIRLPOOL 108cfd95d65e74f28f85a846f605bc349e5b2962b7f9a357415225f3e48ff87148d7f50a642665cc3c809bb2cb4c22f339ad049cdeb4659bb7c0a48e798833ad
diff --git a/media-sound/amarok/amarok-2.8.0-r3.ebuild b/media-sound/amarok/amarok-2.8.0-r3.ebuild
new file mode 100644
index 000000000000..ee3035b6cb50
--- /dev/null
+++ b/media-sound/amarok/amarok-2.8.0-r3.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bs ca ca@valencia cs da de el en_GB es et eu fi fr ga gl hu it ja
+lt lv nb nl pa pl pt pt_BR ro ru sl sr sr@ijekavian sr@ijekavianlatin sr@latin
+sv tr uk zh_CN zh_TW"
+KDE_REQUIRED="never"
+KDE_HANDBOOK="optional"
+KDE_MINIMAL="4.13.1"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+inherit flag-o-matic kde4-base pax-utils
+
+DESCRIPTION="Advanced audio player based on KDE framework"
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} != *9999* ]]; then
+ if [[ $PV == *[6-9][0-9]* ]]; then
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
+ else
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+ fi
+ KEYWORDS="amd64 ppc x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="cdda debug +embedded ipod lastfm mp3tunes mtp nepomuk ofa opengl test +utils"
+
+if [[ ${KDE_BUILD_TYPE} == live ]]; then
+ RESTRICT="test"
+fi
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+COMMONDEPEND="
+ app-crypt/qca:2[qt4(+)]
+ $(add_kdebase_dep kdelibs 'nepomuk?,opengl?' 4.8.4)
+ $(add_kdeapps_dep kdebase-kioslaves)
+ >=media-libs/taglib-1.7[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ sys-libs/zlib
+ >=virtual/mysql-5.1[embedded?]
+ >=dev-qt/qtcore-4.8:4
+ >=dev-qt/qtdbus-4.8:4
+ >=dev-qt/qtscript-4.8:4
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ $(add_kdeapps_dep libkcddb)
+ $(add_kdeapps_dep libkcompactdisc)
+ $(add_kdeapps_dep audiocd-kio)
+ )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-1.0.3 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ >=dev-qt/qtcore-4.8.4:4[glib]
+ )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ nepomuk? ( >=kde-base/nepomuk-core-4.9.0 )
+ ofa? ( >=media-libs/libofa-0.9.0 )
+ opengl? ( virtual/opengl )
+"
+DEPEND="${COMMONDEPEND}
+ dev-util/automoc
+ virtual/pkgconfig
+ test? ( dev-cpp/gmock )
+"
+RDEPEND="${COMMONDEPEND}
+ !media-sound/amarok-utils
+ || ( kde-apps/phonon-kde:4
+ $(add_kdeapps_dep phonon-kde) )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gmock-1.7.patch"
+ "${FILESDIR}/${P}-mysqld-rpath.patch"
+)
+
+src_configure() {
+ # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
+ use ppc64 && append-flags -mminimal-toc
+
+ local mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_Libgcrypt=OFF
+ -DWITH_SPECTRUM_ANALYZER=OFF
+ $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with nepomuk Soprano)
+ $(cmake-utils_use_with ofa LibOFA)
+ $(cmake-utils_use_with utils UTILITIES)
+ )
+
+ # Add libmysqld location for rpath patch; bug 508824
+ use embedded && mycmakeargs+=(-DMYSQLD_DIR="${EPREFIX}/usr/$(get_libdir)/mysql")
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+
+ # bug 481592
+ pax-mark m "${ED}"/usr/bin/amarok
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amarok.kde.org/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "virtual/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
+}
diff --git a/media-sound/amarok/files/amarok-2.8.0-gmock-1.7.patch b/media-sound/amarok/files/amarok-2.8.0-gmock-1.7.patch
new file mode 100644
index 000000000000..1c0a7f45d25b
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.8.0-gmock-1.7.patch
@@ -0,0 +1,35 @@
+commit 5b3c84b29c16931e46bf7e1ddba16095245ce070
+Author: Mark Kretschmann <kretschmann@kde.org>
+Date: Sat Dec 14 10:25:45 2013 +0100
+
+ Fix compilation with unit tests enabled.
+
+ The problem was clashing symbols between KDE's kWarning macro and gmock.
+ Thanks go to Edward for help with fixing.
+
+ CCMAIL: amarok-devel@kde.org
+
+diff --git a/tests/core/collections/MockCollectionLocationDelegate.h b/tests/core/collections/MockCollectionLocationDelegate.h
+index 019b096..a2f4504 100644
+--- a/tests/core/collections/MockCollectionLocationDelegate.h
++++ b/tests/core/collections/MockCollectionLocationDelegate.h
+@@ -23,6 +23,7 @@
+
+ #include "core/collections/CollectionLocationDelegate.h"
+
++#undef kWarning // WORKAROUND: Prevent symbols clash with KDE's kWarning macro
+ #include <gmock/gmock.h>
+
+ namespace Collections {
+diff --git a/tests/mocks/MockTrack.h b/tests/mocks/MockTrack.h
+index 9f47956..fec6ef2 100644
+--- a/tests/mocks/MockTrack.h
++++ b/tests/mocks/MockTrack.h
+@@ -17,6 +17,7 @@
+ #ifndef META_MOCKTRACK_H
+ #define META_MOCKTRACK_H
+
++#undef kWarning // WORKAROUND: Prevent symbols clash with KDE's kWarning macro
+ #include <gmock/gmock.h>
+
+ #include "core/meta/Meta.h"
diff --git a/media-sound/amarok/files/amarok-2.8.0-mysqld-rpath.patch b/media-sound/amarok/files/amarok-2.8.0-mysqld-rpath.patch
new file mode 100644
index 000000000000..80dc93dc6b14
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.8.0-mysqld-rpath.patch
@@ -0,0 +1,12 @@
+--- src/core-impl/collections/db/sql/mysqlecollection/CMakeLists.txt.orig 2014-06-15 18:31:07.362415065 -0400
++++ src/core-impl/collections/db/sql/mysqlecollection/CMakeLists.txt 2014-06-15 18:33:19.612419882 -0400
+@@ -28,6 +28,9 @@
+ ${ZLIB_LIBRARIES}
+ )
+
++SET_TARGET_PROPERTIES(amarok_collection-mysqlecollection PROPERTIES BUILD_WITH_INSTALL_RPATH TRUE)
++SET_TARGET_PROPERTIES(amarok_collection-mysqlecollection PROPERTIES INSTALL_RPATH "${MYSQLD_DIR}")
++
+ if(NOT WIN32 AND NOT APPLE)
+ target_link_libraries( amarok_collection-mysqlecollection crypt pthread )
+ endif(NOT WIN32 AND NOT APPLE)
diff --git a/media-sound/amarok/metadata.xml b/media-sound/amarok/metadata.xml
new file mode 100644
index 000000000000..e4da6b0d2ef6
--- /dev/null
+++ b/media-sound/amarok/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<herd>sound</herd>
+<maintainer>
+ <email>jmbsvicetto@gentoo.org</email>
+ <name>Jorge Manuel B. S. Vicetto</name>
+</maintainer>
+<use>
+ <flag name="embedded">Use libmysqld, MySQL embedded server library.
+ Try disabling this if you encounter -PIC related in amarok,
+ it will make amarok rely only on standalone MySQL server.
+ </flag>
+ <flag name="lastfm">Enable Last.fm streaming services support through
+ <pkg>media-libs/liblastfm</pkg>
+ </flag>
+ <flag name="mp3tunes">Enable mp3tunes integration</flag>
+ <flag name="mtp">Enable support for libMTP (Plays4Sure) devices access through libmtp
+ </flag>
+ <flag name="nepomuk">Enable Nepomuk based semantic desktop support (deprecated)</flag>
+ <flag name="ofa">Use <pkg>media-libs/libofa</pkg> to compute MusicDNS acoustic
+ fingerprints (used by MusicBrainz)
+ </flag>
+ <flag name="utils">Build the utils - old <pkg>media-sound/amarok-utils</pkg>
+ </flag>
+</use>
+</pkgmetadata>