summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/awesfx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/awesfx')
-rw-r--r--media-sound/awesfx/Manifest2
-rw-r--r--media-sound/awesfx/awesfx-0.5.1d.ebuild39
-rw-r--r--media-sound/awesfx/awesfx-0.5.1e.ebuild39
-rw-r--r--media-sound/awesfx/files/sfxload.confd7
-rw-r--r--media-sound/awesfx/files/sfxload.initd20
-rw-r--r--media-sound/awesfx/metadata.xml5
6 files changed, 112 insertions, 0 deletions
diff --git a/media-sound/awesfx/Manifest b/media-sound/awesfx/Manifest
new file mode 100644
index 000000000000..5c283d6cf418
--- /dev/null
+++ b/media-sound/awesfx/Manifest
@@ -0,0 +1,2 @@
+DIST awesfx-0.5.1d.tar.bz2 282981 SHA256 4d5e57f18d9b353b08cdbd6bd4277843f14efb1a6175344bb1f7e64384a65a61
+DIST awesfx-0.5.1e.tar.bz2 307929 SHA256 27a9b0090474ff9a0a6fb3ceb95422e9e36ecb3cf4dbf1b6720aa486e8c7f812 SHA512 f70e631b6ab6ec6dcbde7773c1da5cba72763d2198c2ac51f4bde0fee80f057f296cabc915aed805e744f7b2323b4e2b20b6d894c79cf5682457a3fc6a9be11d WHIRLPOOL abe1716f42aca14ffd92d99fe774c0561290aef10cbf44802ef4cddd2ce116d9551a96bbf6b81d99256c6719afc5e5ecb5cc08f1a6974f3eabbe58a5b53f9b96
diff --git a/media-sound/awesfx/awesfx-0.5.1d.ebuild b/media-sound/awesfx/awesfx-0.5.1d.ebuild
new file mode 100644
index 000000000000..e17ac16861bb
--- /dev/null
+++ b/media-sound/awesfx/awesfx-0.5.1d.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="AWE32 Sound Driver Utility Programs"
+HOMEPAGE="http://ftp.suse.com/pub/people/tiwai/awesfx"
+SRC_URI="http://ftp.suse.com/pub/people/tiwai/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+
+BANK_LOC="${EPREFIX}/usr/share/sounds/sf2"
+
+DOCS=( AUTHORS ChangeLog README SBKtoSF2.txt samples/README-bank )
+
+src_configure() {
+ econf \
+ --with-sfpath=${BANK_LOC}
+}
+
+src_install() {
+ default
+
+ rm -f "${ED}"/usr/share/sounds/sf2/README-bank
+ newinitd "${FILESDIR}"/sfxload.initd sfxload
+ newconfd "${FILESDIR}"/sfxload.confd sfxload
+}
+
+pkg_postinst() {
+ elog "Copy your SoundFont files from the original CDROM"
+ elog "shipped with your soundcard to ${BANK_LOC}."
+}
diff --git a/media-sound/awesfx/awesfx-0.5.1e.ebuild b/media-sound/awesfx/awesfx-0.5.1e.ebuild
new file mode 100644
index 000000000000..5b85e966dbc8
--- /dev/null
+++ b/media-sound/awesfx/awesfx-0.5.1e.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="AWE32 Sound Driver Utility Programs"
+HOMEPAGE="http://ftp.suse.com/pub/people/tiwai/awesfx"
+SRC_URI="http://ftp.suse.com/pub/people/tiwai/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+
+BANK_LOC="${EPREFIX}/usr/share/sounds/sf2"
+
+DOCS=( AUTHORS ChangeLog README SBKtoSF2.txt samples/README-bank )
+
+src_configure() {
+ econf \
+ --with-sfpath=${BANK_LOC}
+}
+
+src_install() {
+ default
+
+ rm -f "${ED}"/usr/share/sounds/sf2/README-bank
+ newinitd "${FILESDIR}"/sfxload.initd sfxload
+ newconfd "${FILESDIR}"/sfxload.confd sfxload
+}
+
+pkg_postinst() {
+ elog "Copy your SoundFont files from the original CDROM"
+ elog "shipped with your soundcard to ${BANK_LOC}."
+}
diff --git a/media-sound/awesfx/files/sfxload.confd b/media-sound/awesfx/files/sfxload.confd
new file mode 100644
index 000000000000..e44815a7c71b
--- /dev/null
+++ b/media-sound/awesfx/files/sfxload.confd
@@ -0,0 +1,7 @@
+# /etc/conf.d/sfxload
+
+# sfxload or asfxload
+sfxload="asfxload"
+
+# Example location of sound bank for sfxload init script
+sfxbank="/usr/share/sounds/sf2/foobar.bin"
diff --git a/media-sound/awesfx/files/sfxload.initd b/media-sound/awesfx/files/sfxload.initd
new file mode 100644
index 000000000000..087e83d0c7ba
--- /dev/null
+++ b/media-sound/awesfx/files/sfxload.initd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need alsasound
+}
+
+start() {
+ ebegin "Loading sound font bank"
+ ${sfxload} -q "${sfxbank}"
+ eend $? "Error at loading sound font bank ${sfxbank}"
+}
+
+stop() {
+ ebegin "Unloading sound font bank"
+ ${sfxload} -i -q
+ eend $? "Error at unloading sound font bank"
+}
diff --git a/media-sound/awesfx/metadata.xml b/media-sound/awesfx/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/awesfx/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>