summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/cdcd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/cdcd')
-rw-r--r--media-sound/cdcd/Manifest1
-rw-r--r--media-sound/cdcd/cdcd-0.6.6-r2.ebuild28
-rw-r--r--media-sound/cdcd/files/cdcd-0.6.6-acinclude.m4405
-rw-r--r--media-sound/cdcd/files/cdcd-0.6.6-configure.patch76
-rw-r--r--media-sound/cdcd/metadata.xml8
5 files changed, 518 insertions, 0 deletions
diff --git a/media-sound/cdcd/Manifest b/media-sound/cdcd/Manifest
new file mode 100644
index 000000000000..8444a937da34
--- /dev/null
+++ b/media-sound/cdcd/Manifest
@@ -0,0 +1 @@
+DIST cdcd-0.6.6.tar.gz 246286 SHA256 06ae2508926b7d1f811d9ce9a53991f8886aef078db4cde617125bda24fbf717 SHA512 841f2d7f85c81a8cc9e88bc13515959a911e22fe9cff7fd272bab63fccb3e6bbf44e9d66fc2524f1670da20568d6e10434de8143a5e94fc576c7193b4a68f418 WHIRLPOOL 9cc8f718f67f60fc20dafed83749e8542b1f6dee43e2e78ef94323ee21eaad79314c873ba32f6ebdcf2eb77aa630e774a21aed2b232d030f6e032785a7a25bad
diff --git a/media-sound/cdcd/cdcd-0.6.6-r2.ebuild b/media-sound/cdcd/cdcd-0.6.6-r2.ebuild
new file mode 100644
index 000000000000..3fbc5e7b9b69
--- /dev/null
+++ b/media-sound/cdcd/cdcd-0.6.6-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="a simple yet powerful command line cd player"
+HOMEPAGE="http://libcdaudio.sourceforge.net"
+SRC_URI="mirror://sourceforge/libcdaudio/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ppc64 sparc x86 ~x86-fbsd"
+
+RDEPEND="
+ >=sys-libs/readline-4.2
+ >=media-libs/libcdaudio-0.99.4
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cp "${FILESDIR}"/${P}-acinclude.m4 "${S}"/acinclude.m4 || die
+ epatch "${FILESDIR}"/${P}-configure.patch
+ eautoreconf
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
diff --git a/media-sound/cdcd/files/cdcd-0.6.6-acinclude.m4 b/media-sound/cdcd/files/cdcd-0.6.6-acinclude.m4
new file mode 100644
index 000000000000..bce268a78c71
--- /dev/null
+++ b/media-sound/cdcd/files/cdcd-0.6.6-acinclude.m4
@@ -0,0 +1,405 @@
+# Configure paths for GLIB
+# Owen Taylor 97-11-3
+
+dnl AM_PATH_GLIB([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
+dnl Test for GLIB, and define GLIB_CFLAGS and GLIB_LIBS, if "gmodule" or
+dnl gthread is specified in MODULES, pass to glib-config
+dnl
+AC_DEFUN(AM_PATH_GLIB,
+[dnl
+dnl Get the cflags and libraries from the glib-config script
+dnl
+AC_ARG_WITH(glib-prefix,[ --with-glib-prefix=PFX Prefix where GLIB is installed (optional)],
+ glib_config_prefix="$withval", glib_config_prefix="")
+AC_ARG_WITH(glib-exec-prefix,[ --with-glib-exec-prefix=PFX Exec prefix where GLIB is installed (optional)],
+ glib_config_exec_prefix="$withval", glib_config_exec_prefix="")
+AC_ARG_ENABLE(glibtest, [ --disable-glibtest Do not try to compile and run a test GLIB program],
+ , enable_glibtest=yes)
+
+ if test x$glib_config_exec_prefix != x ; then
+ glib_config_args="$glib_config_args --exec-prefix=$glib_config_exec_prefix"
+ if test x${GLIB_CONFIG+set} != xset ; then
+ GLIB_CONFIG=$glib_config_exec_prefix/bin/glib-config
+ fi
+ fi
+ if test x$glib_config_prefix != x ; then
+ glib_config_args="$glib_config_args --prefix=$glib_config_prefix"
+ if test x${GLIB_CONFIG+set} != xset ; then
+ GLIB_CONFIG=$glib_config_prefix/bin/glib-config
+ fi
+ fi
+
+ for module in . $4
+ do
+ case "$module" in
+ gmodule)
+ glib_config_args="$glib_config_args gmodule"
+ ;;
+ gthread)
+ glib_config_args="$glib_config_args gthread"
+ ;;
+ esac
+ done
+
+ AC_PATH_PROG(GLIB_CONFIG, glib-config, no)
+ min_glib_version=ifelse([$1], ,0.99.7,$1)
+ AC_MSG_CHECKING(for GLIB - version >= $min_glib_version)
+ no_glib=""
+ if test "$GLIB_CONFIG" = "no" ; then
+ no_glib=yes
+ else
+ GLIB_CFLAGS=`$GLIB_CONFIG $glib_config_args --cflags`
+ GLIB_LIBS=`$GLIB_CONFIG $glib_config_args --libs`
+ glib_config_major_version=`$GLIB_CONFIG $glib_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+ glib_config_minor_version=`$GLIB_CONFIG $glib_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+ glib_config_micro_version=`$GLIB_CONFIG $glib_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+ if test "x$enable_glibtest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $GLIB_CFLAGS"
+ LIBS="$GLIB_LIBS $LIBS"
+dnl
+dnl Now check if the installed GLIB is sufficiently new. (Also sanity
+dnl checks the results of glib-config to some extent
+dnl
+ rm -f conf.glibtest
+ AC_TRY_RUN([
+#include <glib.h>
+#include <stdio.h>
+#include <stdlib.h>
+
+int
+main ()
+{
+ int major, minor, micro;
+ char *tmp_version;
+
+ system ("touch conf.glibtest");
+
+ /* HP/UX 9 (%@#!) writes to sscanf strings */
+ tmp_version = g_strdup("$min_glib_version");
+ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
+ printf("%s, bad version string\n", "$min_glib_version");
+ exit(1);
+ }
+
+ if ((glib_major_version != $glib_config_major_version) ||
+ (glib_minor_version != $glib_config_minor_version) ||
+ (glib_micro_version != $glib_config_micro_version))
+ {
+ printf("\n*** 'glib-config --version' returned %d.%d.%d, but GLIB (%d.%d.%d)\n",
+ $glib_config_major_version, $glib_config_minor_version, $glib_config_micro_version,
+ glib_major_version, glib_minor_version, glib_micro_version);
+ printf ("*** was found! If glib-config was correct, then it is best\n");
+ printf ("*** to remove the old version of GLIB. You may also be able to fix the error\n");
+ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
+ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
+ printf("*** required on your system.\n");
+ printf("*** If glib-config was wrong, set the environment variable GLIB_CONFIG\n");
+ printf("*** to point to the correct copy of glib-config, and remove the file config.cache\n");
+ printf("*** before re-running configure\n");
+ }
+ else if ((glib_major_version != GLIB_MAJOR_VERSION) ||
+ (glib_minor_version != GLIB_MINOR_VERSION) ||
+ (glib_micro_version != GLIB_MICRO_VERSION))
+ {
+ printf("*** GLIB header files (version %d.%d.%d) do not match\n",
+ GLIB_MAJOR_VERSION, GLIB_MINOR_VERSION, GLIB_MICRO_VERSION);
+ printf("*** library (version %d.%d.%d)\n",
+ glib_major_version, glib_minor_version, glib_micro_version);
+ }
+ else
+ {
+ if ((glib_major_version > major) ||
+ ((glib_major_version == major) && (glib_minor_version > minor)) ||
+ ((glib_major_version == major) && (glib_minor_version == minor) && (glib_micro_version >= micro)))
+ {
+ return 0;
+ }
+ else
+ {
+ printf("\n*** An old version of GLIB (%d.%d.%d) was found.\n",
+ glib_major_version, glib_minor_version, glib_micro_version);
+ printf("*** You need a version of GLIB newer than %d.%d.%d. The latest version of\n",
+ major, minor, micro);
+ printf("*** GLIB is always available from ftp://ftp.gtk.org.\n");
+ printf("***\n");
+ printf("*** If you have already installed a sufficiently new version, this error\n");
+ printf("*** probably means that the wrong copy of the glib-config shell script is\n");
+ printf("*** being found. The easiest way to fix this is to remove the old version\n");
+ printf("*** of GLIB, but you can also set the GLIB_CONFIG environment to point to the\n");
+ printf("*** correct copy of glib-config. (In this case, you will have to\n");
+ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
+ printf("*** so that the correct libraries are found at run-time))\n");
+ }
+ }
+ return 1;
+}
+],, no_glib=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ if test "x$no_glib" = x ; then
+ AC_MSG_RESULT(yes)
+ ifelse([$2], , :, [$2])
+ else
+ AC_MSG_RESULT(no)
+ if test "$GLIB_CONFIG" = "no" ; then
+ echo "*** The glib-config script installed by GLIB could not be found"
+ echo "*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in"
+ echo "*** your path, or set the GLIB_CONFIG environment variable to the"
+ echo "*** full path to glib-config."
+ else
+ if test -f conf.glibtest ; then
+ :
+ else
+ echo "*** Could not run GLIB test program, checking why..."
+ CFLAGS="$CFLAGS $GLIB_CFLAGS"
+ LIBS="$LIBS $GLIB_LIBS"
+ AC_TRY_LINK([
+#include <glib.h>
+#include <stdio.h>
+], [ return ((glib_major_version) || (glib_minor_version) || (glib_micro_version)); ],
+ [ echo "*** The test program compiled, but did not run. This usually means"
+ echo "*** that the run-time linker is not finding GLIB or finding the wrong"
+ echo "*** version of GLIB. If it is not finding GLIB, you'll need to set your"
+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
+ echo "*** is required on your system"
+ echo "***"
+ echo "*** If you have an old version installed, it is best to remove it, although"
+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
+ echo "***"
+ echo "*** If you have a RedHat 5.0 system, you should remove the GTK package that"
+ echo "*** came with the system with the command"
+ echo "***"
+ echo "*** rpm --erase --nodeps gtk gtk-devel" ],
+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
+ echo "*** exact error that occured. This usually means GLIB was incorrectly installed"
+ echo "*** or that you have moved GLIB since it was installed. In the latter case, you"
+ echo "*** may want to edit the glib-config script: $GLIB_CONFIG" ])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ GLIB_CFLAGS=""
+ GLIB_LIBS=""
+ ifelse([$3], , :, [$3])
+ fi
+ AC_SUBST(GLIB_CFLAGS)
+ AC_SUBST(GLIB_LIBS)
+ rm -f conf.glibtest
+])
+
+# Configure paths for libcdaudio -*- Autoconf -*-
+#
+# Derived from glib.m4 (Owen Taylor 97-11-3)
+#
+
+dnl AM_PATH_LIBCDAUDIO([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
+dnl Test for libcdaudio, and define LIBCDAUDIO_CFLAGS, LIBCDAUDIO_LIBS and
+dnl LIBCDAUDIO_LDADD
+dnl
+AC_DEFUN([AM_PATH_LIBCDAUDIO],
+[dnl
+dnl Get the cflags and libraries from the libcdaudio-config script
+dnl
+AC_ARG_WITH(libcdaudio-prefix,
+ AS_HELP_STRING([--with-libcdaudio-prefix=PFX],
+ [Prefix where libcdaudio is installed (optional)]),
+ [libcdaudio_config_prefix="$withval"], [libcdaudio_config_prefix=""])
+AC_ARG_WITH(libcdaudio-exec-prefix,
+ AS_HELP_STRING([--with-libcdaudio-exec-prefix=PFX],
+ [Exec prefix where libcdaudio is installed (optional)]),
+ [libcdaudio_config_exec_prefix="$withval"],
+ [libcdaudio_config_exec_prefix=""])
+AC_ARG_ENABLE(libcdaudiotest,
+ AS_HELP_STRING([--disable-libcdaudiotest],
+ [Do not try to compile and run a test libcdaudio program]),,
+ [enable_libcdaudiotest=yes])
+
+ if test "x$libcdaudio_config_exec_prefix" != x ; then
+ libcdaudio_config_args="$libcdaudio_config_args --exec-prefix=$libcdaudio_config_exec_prefix"
+ if test "x${LIBCDAUDIO_CONFIG+set}" != xset ; then
+ LIBCDAUDIO_CONFIG=$libcdaudio_config_exec_prefix/bin/libcdaudio-config
+ fi
+ fi
+ if test x$libcdaudio_config_prefix != x ; then
+ libcdaudio_config_args="$libcdaudio_config_args --prefix=$libcdaudio_config_prefix"
+ if test "x${LIBCDAUDIO_CONFIG+set}" != xset ; then
+ LIBCDAUDIO_CONFIG=$libcdaudio_config_prefix/bin/libcdaudio-config
+ fi
+ fi
+
+ AC_PATH_PROG(LIBCDAUDIO_CONFIG, libcdaudio-config, no)
+ min_libcdaudio_version=ifelse([$1], ,0.99.0,$1)
+ AC_MSG_CHECKING([for libcdaudio - version >= $min_libcdaudio_version])
+ no_libcdaudio=""
+ if test "$LIBCDAUDIO_CONFIG" = "no" ; then
+ no_libcdaudio=yes
+ else
+ LIBCDAUDIO_CFLAGS=`$LIBCDAUDIO_CONFIG $libcdaudio_config_args --cflags`
+ LIBCDAUDIO_LIBS=`$LIBCDAUDIO_CONFIG $libcdaudio_config_args --libs`
+ LIBCDAUDIO_LDADD=`$LIBCDAUDIO_CONFIG $libcdaudio_config_args --ldadd`
+ libcdaudio_config_major_version=`$LIBCDAUDIO_CONFIG $libcdaudio_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\).*/\1/'`
+ libcdaudio_config_minor_version=`$LIBCDAUDIO_CONFIG $libcdaudio_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\).*/\2/'`
+ libcdaudio_config_micro_version=`$LIBCDAUDIO_CONFIG $libcdaudio_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\).*/\3/'`
+ if test "x$enable_libcdaudiotest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $LIBCDAUDIO_CFLAGS $LIBCDAUDIO_LDADD"
+ LIBS="$LIBCDAUDIO_LIBS $LIBS"
+dnl
+dnl Now check if the installed libcdaudio is sufficiently new. (Also sanity
+dnl checks the results of libcdaudio-config to some extent
+dnl
+ rm -f conf.cdaudiotest
+ AC_TRY_RUN([
+#include <cdaudio.h>
+#include <stdio.h>
+#include <stdlib.h>
+
+char* my_strdup (char *str)
+{
+ char *new_str;
+
+ if (str) {
+ new_str = malloc ((strlen (str) + 1) * sizeof(char));
+ strcpy (new_str, str);
+ } else
+ new_str = NULL;
+
+ return new_str;
+}
+
+int main()
+{
+ int major,minor,micro;
+ int libcdaudio_major_version,libcdaudio_minor_version,libcdaudio_micro_version;
+ char *tmp_version;
+
+ system ("touch conf.cdaudiotest");
+
+ /* HP/UX 9 (%@#!) writes to sscanf strings */
+ tmp_version = my_strdup("$min_libcdaudio_version");
+ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
+ printf("%s, bad version string\n", "$min_libcdaudio_version");
+ exit(1);
+ }
+
+ libcdaudio_major_version=(cdaudio_getversion()>>16)&255;
+ libcdaudio_minor_version=(cdaudio_getversion()>> 8)&255;
+ libcdaudio_micro_version=(cdaudio_getversion() )&255;
+
+ if ((libcdaudio_major_version != $libcdaudio_config_major_version) ||
+ (libcdaudio_minor_version != $libcdaudio_config_minor_version) ||
+ (libcdaudio_micro_version != $libcdaudio_config_micro_version))
+ {
+ printf("\n*** 'libcdaudio-config --version' returned %d.%d.%d, but libcdaudio (%d.%d.%d)\n",
+ $libcdaudio_config_major_version, $libcdaudio_config_minor_version, $libcdaudio_config_micro_version,
+ libcdaudio_major_version, libcdaudio_minor_version, libcdaudio_micro_version);
+ printf ("*** was found! If libcdaudio-config was correct, then it is best\n");
+ printf ("*** to remove the old version of libcdaudio. You may also be able to fix the error\n");
+ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
+ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
+ printf("*** required on your system.\n");
+ printf("*** If libcdaudio-config was wrong, set the environment variable LIBCDAUDIO_CONFIG\n");
+ printf("*** to point to the correct copy of libcdaudio-config, and remove the file config.cache\n");
+ printf("*** before re-running configure\n");
+ }
+ else if ((libcdaudio_major_version != LIBCDAUDIO_VERSION_MAJOR) ||
+ (libcdaudio_minor_version != LIBCDAUDIO_VERSION_MINOR) ||
+ (libcdaudio_micro_version != LIBCDAUDIO_VERSION_MICRO))
+ {
+ printf("*** libcdaudio header files (version %d.%d.%d) do not match\n",
+ LIBCDAUDIO_VERSION_MAJOR, LIBCDAUDIO_VERSION_MINOR, LIBCDAUDIO_VERSION_MICRO);
+ printf("*** library (version %d.%d.%d)\n",
+ libcdaudio_major_version, libcdaudio_minor_version, libcdaudio_micro_version);
+ }
+ else
+ {
+ if ((libcdaudio_major_version > major) ||
+ ((libcdaudio_major_version == major) && (libcdaudio_minor_version > minor)) ||
+ ((libcdaudio_major_version == major) && (libcdaudio_minor_version == minor) && (libcdaudio_micro_version >= micro)))
+ {
+ return 0;
+ }
+ else
+ {
+ printf("\n*** An old version of libcdaudio (%d.%d.%d) was found.\n",
+ libcdaudio_major_version, libcdaudio_minor_version, libcdaudio_micro_version);
+ printf("*** You need a version of libcdaudio newer than %d.%d.%d.\n",
+ major, minor, micro);
+ printf("***\n");
+ printf("*** If you have already installed a sufficiently new version, this error\n");
+ printf("*** probably means that the wrong copy of the libcdaudio-config shell script is\n");
+ printf("*** being found. The easiest way to fix this is to remove the old version\n");
+ printf("*** of libcdaudio, but you can also set the LIBCDAUDIO_CONFIG environment to point to the\n");
+ printf("*** correct copy of libcdaudio-config. (In this case, you will have to\n");
+ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
+ printf("*** so that the correct libraries are found at run-time))\n");
+ }
+ }
+ return 1;
+}
+],, no_libcdaudio=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ if test "x$no_libcdaudio" = x ; then
+ AC_MSG_RESULT(yes)
+ ifelse([$2], , :, [$2])
+ else
+ AC_MSG_RESULT(no)
+ if test "$LIBCDAUDIO_CONFIG" = "no" ; then
+ echo "*** The libcdaudio-config script installed by libcdaudio could not be found"
+ echo "*** If libcdaudio was installed in PREFIX, make sure PREFIX/bin is in"
+ echo "*** your path, or set the LIBCDAUDIO_CONFIG environment variable to the"
+ echo "*** full path to libcdaudio-config."
+ else
+ if test -f conf.cdaudiotest ; then
+ :
+ else
+ echo "*** Could not run libcdaudio test program, checking why..."
+ CFLAGS="$CFLAGS $LIBCDAUDIO_CFLAGS"
+ LIBS="$LIBS $LIBCDAUDIO_LIBS"
+ AC_TRY_LINK([
+#include <cdaudio.h>
+#include <stdio.h>
+], [ return (cdaudio_getversion()!=0); ],
+ [ echo "*** The test program compiled, but did not run. This usually means"
+ echo "*** that the run-time linker is not finding libcdaudio or finding the wrong"
+ echo "*** version of libcdaudio. If it is not finding libcdaudio, you'll need to set your"
+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
+ echo "*** to the installed location. Also, make sure you have run ldconfig if that"
+ echo "*** is required on your system"
+ echo "***"
+ echo "*** If you have an old version installed, it is best to remove it, although"
+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"],
+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
+ echo "*** exact error that occured. This usually means libcdaudio was incorrectly installed"
+ echo "*** or that you have moved libcdaudio since it was installed. In the latter case, you"
+ echo "*** may want to edit the libcdaudio-config script: $LIBCDAUDIO_CONFIG" ])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ LIBCDAUDIO_CFLAGS=""
+ LIBCDAUDIO_LIBS=""
+ LIBCDAUDIO_LDADD=""
+ ifelse([$3], , :, [$3])
+ fi
+ AC_SUBST(LIBCDAUDIO_CFLAGS)
+ AC_SUBST(LIBCDAUDIO_LIBS)
+ AC_SUBST(LIBCDAUDIO_LDADD)
+ rm -f conf.cdaudiotest
+])
+
diff --git a/media-sound/cdcd/files/cdcd-0.6.6-configure.patch b/media-sound/cdcd/files/cdcd-0.6.6-configure.patch
new file mode 100644
index 000000000000..6755dab4d39f
--- /dev/null
+++ b/media-sound/cdcd/files/cdcd-0.6.6-configure.patch
@@ -0,0 +1,76 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,8 +2,6 @@
+
+ SUBDIRS = doc
+
+-AUTOMAKE_OPTIONS = ansi2knr
+-
+ bin_PROGRAMS = cdcd
+ man_MANS = cdcd.1
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,5 +1,5 @@
+ dnl Process this file with autoconf to produce a configure script.
+-AC_INIT(cdcd.c)
++AC_INIT(cdcd, 0.6.6)
+
+ MAJOR_VERSION=0
+ MINOR_VERSION=6
+@@ -8,29 +8,22 @@
+ PACKAGE=cdcd
+ VERSION=$MAJOR_VERSION.$MINOR_VERSION.$MICRO_VERSION
+
+-AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
++AM_INIT_AUTOMAKE
+ AM_CONFIG_HEADER(config.h)
+-AM_MAINTAINER_MODE
+
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_CPP
+-AM_C_PROTOTYPES
+ AC_CANONICAL_HOST
+
+ dnl Checks for libraries.
+-AC_CHECK_LIB(curses, tputs,,
+- [AC_MSG_ERROR([cannot find the curses library.
+-Check the INSTALL file, maybe you can find how to solve the problem.])])
+ AC_CHECK_LIB(readline, rl_completion_matches,,
+- [AC_MSG_ERROR([cannot find GNU libreadline 4.2 or higher.
+-Check the INSTALL file, maybe you can find how to solve the problem.])])
++ [AC_MSG_ERROR([cannot find GNU libreadline 4.2 or higher.])])
+ AC_CHECK_LIB(socket, socket)dnl Needed for Solaris 2.9.
+
+-AM_PATH_LIBCDAUDIO(,,[AC_MSG_ERROR([cannot find libcdaudio.
+-Check the INSTALL file, maybe you can find how to solve the problem.])])
++AM_PATH_LIBCDAUDIO(,,[AC_MSG_ERROR([cannot find libcdaudio.])])
+
+ have_libcdaudio=0
+ have_cdaudio=0
+@@ -40,6 +33,11 @@
+ default_device=/dev/unspecified
+ have_libcdaudio=1
+ ;;
++
++ *freebsd[567]*)
++ default_device=/dev/cd0
++ have_cdaudio=1
++ ;;
+
+ *bsd*)
+ default_device=/dev/wcd0a
+@@ -69,8 +67,8 @@
+ dnl Checks for header files.
+ AC_HEADER_STDC
+ AC_FUNC_ALLOCA
+-AC_CHECK_HEADERS([string.h strings.h sys/ptyvar.h])
+-AC_CHECK_HEADERS([errno.h locale.h malloc.h stdlib.h \
++AC_CHECK_HEADERS([string.h strings.h sys/ptyvar.h malloc.h])
++AC_CHECK_HEADERS([errno.h locale.h stdlib.h \
+ readline/readline.h readline/history.h sys/socket.h unistd.h],, \
+ [AC_MSG_ERROR([missing header file.])])
+
diff --git a/media-sound/cdcd/metadata.xml b/media-sound/cdcd/metadata.xml
new file mode 100644
index 000000000000..385a5882ed42
--- /dev/null
+++ b/media-sound/cdcd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">libcdaudio</remote-id>
+ </upstream>
+</pkgmetadata>