summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/dcaenc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/dcaenc')
-rw-r--r--media-sound/dcaenc/Manifest1
-rw-r--r--media-sound/dcaenc/dcaenc-2-r1.ebuild28
-rw-r--r--media-sound/dcaenc/dcaenc-2.ebuild16
-rw-r--r--media-sound/dcaenc/dcaenc-9999.ebuild28
-rw-r--r--media-sound/dcaenc/metadata.xml5
5 files changed, 78 insertions, 0 deletions
diff --git a/media-sound/dcaenc/Manifest b/media-sound/dcaenc/Manifest
new file mode 100644
index 000000000000..b6afc6c4b5b2
--- /dev/null
+++ b/media-sound/dcaenc/Manifest
@@ -0,0 +1 @@
+DIST dcaenc-2.tar.gz 351199 SHA256 1054e6113cd1304f35ca830f027a53e9efd989530fe6523f732a0a9cd4110199 SHA512 0029f7c3b06199fb8100ce933827013fdc58e5fddf984ddf1744849e5d6cc24ce76e09b868eef19a49e1036a142419c3304c1822492f64301ed4feaa6bea4910 WHIRLPOOL 6e806bbf2194a9380c5f0bab186be3f14d4163b0b029fc44328cbbce4e6b209d4faf07f0a5fb809214c90aeaaff332e47f187ff13b597876fbc6fd664b1d0019
diff --git a/media-sound/dcaenc/dcaenc-2-r1.ebuild b/media-sound/dcaenc/dcaenc-2-r1.ebuild
new file mode 100644
index 000000000000..7aa4bda32faa
--- /dev/null
+++ b/media-sound/dcaenc/dcaenc-2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999* ]]; then
+AUTOTOOLS_AUTORECONF=1
+EGIT_REPO_URI="git://gitorious.org/dtsenc/dtsenc.git"
+else
+SRC_URI="http://aepatrakov.narod.ru/olderfiles/1/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+fi
+
+inherit autotools autotools-multilib
+
+[[ ${PV} == 9999* ]] && inherit git-r3
+
+DESCRIPTION="DTS Coherent Acoustics audio encoder"
+HOMEPAGE="http://aepatrakov.narod.ru/index/0-2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="alsa"
+
+RDEPEND="alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/media-sound/dcaenc/dcaenc-2.ebuild b/media-sound/dcaenc/dcaenc-2.ebuild
new file mode 100644
index 000000000000..7e75824c88b3
--- /dev/null
+++ b/media-sound/dcaenc/dcaenc-2.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="DTS Coherent Acoustics audio encoder"
+HOMEPAGE="http://aepatrakov.narod.ru/index/0-2"
+SRC_URI="http://aepatrakov.narod.ru/olderfiles/1/${P}.tar.gz"
+LICENSE="LGPL-2.1+"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa"
+
+DEPEND="alsa? ( media-libs/alsa-lib )"
diff --git a/media-sound/dcaenc/dcaenc-9999.ebuild b/media-sound/dcaenc/dcaenc-9999.ebuild
new file mode 100644
index 000000000000..7aa4bda32faa
--- /dev/null
+++ b/media-sound/dcaenc/dcaenc-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999* ]]; then
+AUTOTOOLS_AUTORECONF=1
+EGIT_REPO_URI="git://gitorious.org/dtsenc/dtsenc.git"
+else
+SRC_URI="http://aepatrakov.narod.ru/olderfiles/1/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+fi
+
+inherit autotools autotools-multilib
+
+[[ ${PV} == 9999* ]] && inherit git-r3
+
+DESCRIPTION="DTS Coherent Acoustics audio encoder"
+HOMEPAGE="http://aepatrakov.narod.ru/index/0-2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="alsa"
+
+RDEPEND="alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/media-sound/dcaenc/metadata.xml b/media-sound/dcaenc/metadata.xml
new file mode 100644
index 000000000000..3bf6bcfeb512
--- /dev/null
+++ b/media-sound/dcaenc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>