summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-12-06 22:00:36 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-12-06 22:05:13 +0000
commit57d7b6052fb3996c81d077f39ac74593fc06e72d (patch)
treee74a09436ab3f57a658edede775e92c18ddfbf57 /media-sound/forked-daapd
parentapp-editors/neovim: Remove old (diff)
downloadgentoo-57d7b6052fb3996c81d077f39ac74593fc06e72d.tar.gz
gentoo-57d7b6052fb3996c81d077f39ac74593fc06e72d.tar.bz2
gentoo-57d7b6052fb3996c81d077f39ac74593fc06e72d.zip
media-sound/forked-daapd: Use antlr 3.5 instead of earlier version
My included patch has already been accepted upstream. Package-Manager: portage-2.2.26
Diffstat (limited to 'media-sound/forked-daapd')
-rw-r--r--media-sound/forked-daapd/files/antlr-3.5.patch81
-rw-r--r--media-sound/forked-daapd/forked-daapd-23.2-r1.ebuild (renamed from media-sound/forked-daapd/forked-daapd-23.2.ebuild)11
2 files changed, 88 insertions, 4 deletions
diff --git a/media-sound/forked-daapd/files/antlr-3.5.patch b/media-sound/forked-daapd/files/antlr-3.5.patch
new file mode 100644
index 000000000000..86461f3f0ba5
--- /dev/null
+++ b/media-sound/forked-daapd/files/antlr-3.5.patch
@@ -0,0 +1,81 @@
+From 7cf35d1e8bb8dedb710e4a60bada2739d60306d0 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Mon, 5 Oct 2015 23:10:45 +0100
+Subject: [PATCH 1/2] Allow ANTLR 3.5 to work
+
+This involves a harmless backwards-compatible adjustment to the
+grammar. I can't explain why this is necessary but this might help.
+
+http://stackoverflow.com/questions/20057063/follow-set-in-is-undefined-in-generated-parser
+---
+ src/RSP.g | 34 +++++++++++++++++-----------------
+ 1 file changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/src/RSP.g b/src/RSP.g
+index 435de16..6a27536 100644
+--- a/src/RSP.g
++++ b/src/RSP.g
+@@ -43,43 +43,43 @@ strcrit : FIELD strop STR -> ^(strop FIELD STR)
+ | FIELD NOT strop STR -> ^(NOT ^(strop FIELD STR))
+ ;
+
+-strop : EQUAL
+- | INCLUDES
+- | STARTSW
+- | ENDSW
++strop : equal=EQUAL
++ | includes=INCLUDES
++ | startsw=STARTSW
++ | endsw=ENDSW
+ ;
+
+ intcrit : FIELD intop INT -> ^(intop FIELD INT)
+ | FIELD NOT intop INT -> ^(NOT ^(intop FIELD INT))
+ ;
+
+-intop : EQUAL
+- | LESS
+- | GREATER
+- | LTE
+- | GTE
++intop : equal=EQUAL
++ | less=LESS
++ | greater=GREATER
++ | lte=LTE
++ | gte=GTE
+ ;
+
+ datecrit: FIELD dateop datespec -> ^(dateop FIELD datespec)
+ ;
+
+-dateop : BEFORE
+- | AFTER
++dateop : before=BEFORE
++ | after=AFTER
+ ;
+
+ datespec: dateref
+ | INT dateintval dateop dateref -> ^(dateop dateref INT dateintval)
+ ;
+
+-dateref : DATE
+- | TODAY
++dateref : date=DATE
++ | today=TODAY
+ ;
+
+ dateintval
+- : DAY
+- | WEEK
+- | MONTH
+- | YEAR
++ : day=DAY
++ | week=WEEK
++ | month=MONTH
++ | year=YEAR
+ ;
+
+ QUOTE : '"';
+--
+2.4.3
+
diff --git a/media-sound/forked-daapd/forked-daapd-23.2.ebuild b/media-sound/forked-daapd/forked-daapd-23.2-r1.ebuild
index 1a759656c323..1217563090ea 100644
--- a/media-sound/forked-daapd/forked-daapd-23.2.ebuild
+++ b/media-sound/forked-daapd/forked-daapd-23.2-r1.ebuild
@@ -20,8 +20,8 @@ IUSE="alsa flac itunes lastfm mpd musepack"
# Note: mpd support appears to be standalone, e.g. --enable-mpd doesn't
# result in additional linkage.
RDEPEND="
- >=dev-libs/antlr-c-3.1.3
dev-db/sqlite:3
+ dev-libs/antlr-c:0
dev-libs/confuse
dev-libs/libevent
dev-libs/libgcrypt:0
@@ -38,8 +38,7 @@ RDEPEND="
"
DEPEND="
- dev-java/antlr:3
- virtual/jre
+ dev-java/antlr:3.5
${RDEPEND}
"
@@ -49,13 +48,17 @@ pkg_setup() {
}
src_prepare() {
- # Required until upstream accepts https://github.com/ejurgensen/forked-daapd/pull/179
+ # Fixed in 23.3.
epatch "${FILESDIR}/${P}-fix-arg-enable.patch"
+ # https://github.com/ejurgensen/forked-daapd/pull/185
+ epatch "${FILESDIR}/antlr-3.5.patch"
+
eautoreconf
}
src_configure() {
+ ac_cv_prog_ANTLR=antlr3.5 \
econf \
--with-alsa \
$(use_enable flac) \