summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/jack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/jack')
-rw-r--r--media-sound/jack/Manifest1
-rw-r--r--media-sound/jack/files/jack-3.0.0-python26.patch12
-rw-r--r--media-sound/jack/jack-3.1.1-r1.ebuild52
-rw-r--r--media-sound/jack/metadata.xml5
4 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/jack/Manifest b/media-sound/jack/Manifest
new file mode 100644
index 000000000000..e52c7bdb13fc
--- /dev/null
+++ b/media-sound/jack/Manifest
@@ -0,0 +1 @@
+DIST jack-3.1.1.tar.gz 318119 SHA256 fef030c4ba68a747d11e04c8ec4ca545563dbef519a6b23a3ebd6bb9bcb038cc SHA512 e34bec0ae89a7619e1f446d1259be06415f57697d1b925799d00554940b4cb6cb40eba9e6e7cf9f2f9eacddbed9fe7a9a48e395530c8a701be3979162a9379d7 WHIRLPOOL b7e43e0a422cb405409eb5f411f92d611c9c5922dd84a6749e8b784a4211bf9f6659cb52302adf3e90962b602b74c08f6f7ca9ddfea3e336c278f0827fe1664a
diff --git a/media-sound/jack/files/jack-3.0.0-python26.patch b/media-sound/jack/files/jack-3.0.0-python26.patch
new file mode 100644
index 000000000000..98701345f3b3
--- /dev/null
+++ b/media-sound/jack/files/jack-3.0.0-python26.patch
@@ -0,0 +1,12 @@
+--- jack_functions.py
++++ jack_functions.py
+@@ -219,9 +219,9 @@
+ ff = blocks % CDDA_BLOCKS_PER_SECOND
+ return mm, ss, ff, blocks
+
+-def starts_with(str, with):
+- "checks whether str starts with with"
+- return str[0:len(with)] == with
++def starts_with(str, withstr):
++ "checks whether str starts with withstr"
++ return str[0:len(withstr)] == withstr
diff --git a/media-sound/jack/jack-3.1.1-r1.ebuild b/media-sound/jack/jack-3.1.1-r1.ebuild
new file mode 100644
index 000000000000..9bbef7dc6a8b
--- /dev/null
+++ b/media-sound/jack/jack-3.1.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit eutils distutils
+
+DESCRIPTION="A frontend for several cd-rippers and mp3 encoders"
+HOMEPAGE="http://www.home.unix-ag.org/arne/jack/"
+SRC_URI="http://www.home.unix-ag.org/arne/jack/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ dev-python/cddb-py
+ dev-python/id3-py
+ dev-python/pyid3lib
+ dev-python/pyvorbis
+ media-libs/flac
+ media-sound/lame
+ media-sound/cdparanoia"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.0-python26.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ dobin jack || die "dobin failed"
+
+ insinto $(python_get_sitedir)
+ PYTHON_MODNAME="$(ls jack_*.py)"
+ doins ${PYTHON_MODNAME}
+
+ newman jack.man jack.1
+
+ dodoc README doc/ChangeLog doc/TODO
+
+ dohtml doc/*html doc/*css doc/*gif
+}
diff --git a/media-sound/jack/metadata.xml b/media-sound/jack/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/jack/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>