summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/kmetronome
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/kmetronome')
-rw-r--r--media-sound/kmetronome/Manifest2
-rw-r--r--media-sound/kmetronome/kmetronome-0.10.1-r1.ebuild34
-rw-r--r--media-sound/kmetronome/kmetronome-1.0.0.ebuild45
-rw-r--r--media-sound/kmetronome/metadata.xml9
4 files changed, 90 insertions, 0 deletions
diff --git a/media-sound/kmetronome/Manifest b/media-sound/kmetronome/Manifest
new file mode 100644
index 000000000000..155608e28027
--- /dev/null
+++ b/media-sound/kmetronome/Manifest
@@ -0,0 +1,2 @@
+DIST kmetronome-0.10.1.tar.bz2 201241 SHA256 76907378433fe1e7041ba575b4cef8132819a3eed63373e1c2d4bfc746eb2d30 SHA512 27203f2a85e13cb61ccb214f445c9ce51c4b101a0114e6bf0133128a8998886b73b38c6215ee51c095de7494933706043c925d5be7a268c17a9086cabea78b86 WHIRLPOOL 759819de4d1586f616e210be69baaf36f42f464224f8247b809c1d85c7dd5090934fff6110d3b34a885b67b2815df9b79574e3c63167c069cd2432aff8533e69
+DIST kmetronome-1.0.0.tar.bz2 225715 SHA256 8b8acc5af534679ae947ee4b0fd415c298aecaefcef174988ea1f211c8d56e9f SHA512 69290c56119de78a75863c8afd891fbff2d26eeb739a5e65938ba6238e522b1fb79edc6ac0264b912cb70bc3028a6245ab16cc3d22f19e30ea9a33817589f426 WHIRLPOOL 24f769381bd8bdfcffeeb3b7bc8c9bbed8f9f04e74439f1694f7bbde348c3c8c8dcfc276d51eaadc9fee04b02d40b05338cba32de67193e4738035f793a3074e
diff --git a/media-sound/kmetronome/kmetronome-0.10.1-r1.ebuild b/media-sound/kmetronome/kmetronome-0.10.1-r1.ebuild
new file mode 100644
index 000000000000..37fec1640394
--- /dev/null
+++ b/media-sound/kmetronome/kmetronome-0.10.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="cs de es fr tr"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="MIDI based metronome using ALSA sequencer"
+HOMEPAGE="http://kmetronome.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="
+ media-libs/alsa-lib
+ media-sound/drumstick
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ mycmakeargs=(
+ -DSTATIC_DRUMSTICK=OFF
+ )
+
+ kde4-base_src_configure
+}
diff --git a/media-sound/kmetronome/kmetronome-1.0.0.ebuild b/media-sound/kmetronome/kmetronome-1.0.0.ebuild
new file mode 100644
index 000000000000..d0911153cc31
--- /dev/null
+++ b/media-sound/kmetronome/kmetronome-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="MIDI based metronome using ALSA sequencer"
+HOMEPAGE="http://kmetronome.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ >=media-sound/drumstick-1.0.0
+ !media-sound/kmetronome:4
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/media-sound/kmetronome/metadata.xml b/media-sound/kmetronome/metadata.xml
new file mode 100644
index 000000000000..9a940c2c43f6
--- /dev/null
+++ b/media-sound/kmetronome/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">kmetronome</remote-id>
+ </upstream>
+</pkgmetadata>