summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-10-16 13:39:48 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-16 13:39:48 +0200
commit8a0c14ea8f31dc9acc132600859c6bc2c311482b (patch)
tree096ba201aa88c5ec15b294262d5c555028c380dc /media-sound/litestream/files/litestream-1.3_rc3-fix-build-system.patch
parentmedia-sound/icecream: Port to EAPI 7 (diff)
downloadgentoo-8a0c14ea8f31dc9acc132600859c6bc2c311482b.tar.gz
gentoo-8a0c14ea8f31dc9acc132600859c6bc2c311482b.tar.bz2
gentoo-8a0c14ea8f31dc9acc132600859c6bc2c311482b.zip
media-sound/litestream: Port to EAPI 7
Bug: https://bugs.gentoo.org/697274 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/litestream/files/litestream-1.3_rc3-fix-build-system.patch')
-rw-r--r--media-sound/litestream/files/litestream-1.3_rc3-fix-build-system.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/litestream/files/litestream-1.3_rc3-fix-build-system.patch b/media-sound/litestream/files/litestream-1.3_rc3-fix-build-system.patch
new file mode 100644
index 000000000000..0ef4eaa8a664
--- /dev/null
+++ b/media-sound/litestream/files/litestream-1.3_rc3-fix-build-system.patch
@@ -0,0 +1,43 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,32 +1,27 @@
+ # $Id: Makefile,v 1.8 2005/09/06 21:26:02 roundeye Exp $
+
+ INCLUDES = -Iinclude
+-AR= ar
+-RANLIB= sh ranlib.sh
+
+-CFLAGS = $(INCLUDES) -Wall -g -DVERSION="\"Litestream 1.2\""
++CFLAGS += -Wall
+
+-LDFLAGS = # -lnsl -lsocket
++CPPFLAGS += $(INCLUDES) -DVERSION="\"Litestream 1.2\"" -DNO_VARARGS
+
+ all: litestream literestream source client server
+
+ .depend: $(WILDCARD *.c)
+- $(CC) -MM $(CFLAGS) -DDEPEND *.c > .depend
++ $(CC) -MM $(CFLAGS) $(CPPFLAGS) -DDEPEND *.c > .depend
+
+-client: stream_cli.o stream_sched.o hexdump.o client.o stream_log.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++client: stream_cli.o stream_sched.o hexdump.o stream_log.o
+
+-server: stream_serv.o stream_sched.o hexdump.o server.o stream_log.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++server: stream_serv.o stream_sched.o hexdump.o stream_log.o
+
+ literestream: stream_serv.o stream_sched.o restream.o hexdump.o icy.o yp.o stream_cli.o http.o textutils.o stream_log.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+ litestream: stream_serv.o stream_sched.o stream.o hexdump.o icy.o yp.o stream_cli.o http.o textutils.o stream_log.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+-source: stream_sched.o stream_cli.o http.o stream_log.o source.o mp3.o playlist.o textutils.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++source: stream_sched.o stream_cli.o http.o stream_log.o mp3.o playlist.o textutils.o
+
+ clean:
+ rm -f *.o source server client litestream literestream .depend *.core